Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1688to1692
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

KKLeinste gibt #Zahl / Zahlenformate mit punkten

KKLeinste gibt #Zahl / Zahlenformate mit punkten
28.04.2019 13:12:53
Norman
Hallo,
ich möchte folgende Werte mit KKleinste sortieren:
410489.00.60/1
4621.04.80/11
411061.01.25/1
411686.00.45/1
Aber ich bekomme nur#Zahl wiedergegeben. Erkennt kkleinste die Werte nicht als Zahl?

12
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Das sind keine Zahlen! sondern Text! (owT)
28.04.2019 13:15:51
EtoPHG

AW: KKLeinste gibt #Zahl / Zahlenformate mit punkten
28.04.2019 13:16:05
Hajo_Zi
410489.00.60/1 ist keine Zahl und lkeine Zahl.

Beiträge von Werner, Luc, robert, J.O.Maximo und folgende lese ich nicht.
Die Beiträge werden auch ignoriert, es erfolgt keine Antwort.
AW: KKLeinste gibt #Zahl / Zahlenformate mit punkten
28.04.2019 13:25:18
Norman
Danke für die schnelle Antwort.
Kann ich die Werte trotzdem per Formel sortieren?
AW: KKLeinste gibt #Zahl / Zahlenformate mit punkten
28.04.2019 13:27:19
Hajo_Zi
warum nicht einfach sortieren?
Gruß Hajo
AW: KKLeinste gibt #Zahl / Zahlenformate mit punkten
28.04.2019 13:34:57
Norman
ich bekomme die Werte über eine Formel ausgegeben.
Einfach sortieren geht schon, müsste ich aber jedesmal manuell machen.
Es geht in diesem Fall nur um Bequemlichkeit :-)
Anzeige
AW: KKLeinste gibt #Zahl / Zahlenformate mit punkten
28.04.2019 13:36:32
Hajo_Zi
dazu kann ich nichts schreiben, was wohl daran liegt das ich nicht auf fremde Rechner schaue und ich baue keine Datei nach.
Formel können nicht sortiert werden. Würde ich vermuten.
Gruß Hajo
Sortierkriterium bis zum ersten Punkt
28.04.2019 13:45:46
WF
Hi,
in B1 folgende Arrayformel:
{=INDEX(A:A;VERGLEICH(KKLEINSTE(LINKS(A$1:A$4;FINDEN(".";A$1:A$4)-1)*1;ZEILE(X1))&"*";B:B;0))}
bis B4 runterkopieren
Weiter als B4 runterkopiert, gibt's #WERT!
WF
AW: wolltest anstelle B:B wohl A:A schreiben owT
29.04.2019 10:30:38
neopa
Gruß Werner
.. , - ...
Text sortieren mit Formel
28.04.2019 22:07:28
Josef
Hallo
Dein Text steht in Spalte A
In B1 folgende Formel:
=VERWEIS(2;1/(AGGREGAT(14;6;ZÄHLENWENN(A$1:A$99;">="&A$1:A$99);ZEILE(A1))=ZÄHLENWENN(A:A;"> ="&A$1:A$99));A:A) &""
und Formel nach Bedarf nach unten kopieren.
Gruss Sepp
Anzeige
AW: hier ist ein kleiner Darstellungsfehler ...
29.04.2019 09:54:17
neopa
Hallo Sepp @ all,
... hab aber auch erst eine Weile gebraucht, bis ich diesen entdeckt habe. In der Formel darf es das Leerzeichen zwischen "&gt" und "= nicht geben.
Gruß Werner
.. , - ...
AW: Deine Textwert als Zahlenwerte sortiert ...
29.04.2019 10:04:30
neopa
Hallo Norman,
... wenn Du nicht viele tausende derartige Datenwerte sortieren willst (dann würde ich zu PQ raten; dazu google dann mal nach PowerQuery, was oft auch als PQ abgekürzt wird; oder frage nach), dann würde ich folgende Sortierungsformel vorschlagen (wenn abwärts sortieren gesucht sein sollte, ist nur eine minimale Formelanpassung notwendig):
Arbeitsblatt mit dem Namen 'Tabelle3'
 DE
1Datenaufwärts sortiert
2410489.00.60/14621.03.80/11
34621.04.80/114621.04.80/10
4411061.01.25/14621.04.80/11
5411686.00.45/1410489.00.60/1
6411061.01.12/1410489.99.60/1
74621.03.80/11411061.01.12/1
84621.04.80/10411061.01.25/1
9410489.99.60/1411686.00.45/1
10  

ZelleFormel
E2=WENNFEHLER(INDEX(D:D;AGGREGAT(15;6;ZEILE(D$1:D$99)/(WECHSELN(WECHSELN(WECHSELN(D$1:D$99;".";",";1);".";"");"/";"")+0=AGGREGAT(15;6;WECHSELN(WECHSELN(WECHSELN(D$1:D$99;".";",";1);".";"");"/";"")/(D$1:D$99>"");ZEILE(D1)));1));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Gruß Werner
.. , - ...
Anzeige
AW: hierzu nachgetragen ...
29.04.2019 10:19:15
neopa
Hallo,
... diese Formel setzt voraus, dass die Datenstruktur für alle zu sortierenden Daten gleich ist. Also Ziffernfolgen, die durch zwei "." und ein "/" getrennt sind.
Diese Sortierung ergibt natürlich auch eine andere, als wenn die Daten als Textwerte sortiert werden, so wie es Sepp vorgeschlagen hat.
Gruß Werner
.. , - ...

311 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige