Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Aggregat: eindeutige Liste nach Spalten anordnen

Aggregat: eindeutige Liste nach Spalten anordnen
19.06.2019 13:02:00
Chriss
Hallo Forum,
ich möchte eine eindeutige Liste durch Aggregat erzeugen und diese dann mit Hilfe von Index von rechts nach links in Zeile 1 anzeigen lassen.
Leider stehe ich auf dem Schlauch hinsichtlich Zählenwenn in diesem Fall.
Ausgangsspalte beinhaltet Duplikate aus Text & Zahl.
Bitte wenn möglich ohne Hilfsspalte.
Die Datei hier:
https://www.herber.de/bbs/user/130484.xlsx
Vielen Dank für eure Hilfe!
Gruß,
Chriss

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: nicht mit 1 sondern 0 vergleichen ...
19.06.2019 13:10:37
neopa
Halo Chris,
... in D1:
=WENNFEHLER(INDEX($A:$A;AGGREGAT(15;6;ZEILE($A2:$A99)/($A2:$A99"")/(ZÄHLENWENN($C1:C1;$A2:$A99)=0); SPALTE(A1)));"")

und nach rechts kopieren.
Gruß Werner
.. , - ...
AW: nicht mit 1 sondern 0 vergleichen ...
19.06.2019 13:31:09
Chriss
Hallo Werner,
super, vielen Dank für die schnelle Hilfe.
Allerdings ist mir eine Sache aufgefallen:
Es sollte eigentlich eine eindeutige Liste aus 5 Positionen sein, Excel spuckt aber nur 4 aus.
Irgendwas stimmt da noch nicht, ich sehe aber auch den Fehler nicht.
"EE333" wird nicht gelistet, der Rest schon.
Gruß,
Chriss
AW: sorry, mein Fehler ...
19.06.2019 13:35:44
neopa
Hallo Chriss,
... ich hatte meine endgültige Formel nicht nach D1 zurückkopiert aber diese hier eingestellt.
Es muss natürlich anstelle SPALTE(A1 lediglich eine 1 stehen.
Also so:
=WENNFEHLER(INDEX($A:$A;AGGREGAT(15;6;ZEILE($A2:$A99)/($A2:$A99"")/(ZÄHLENWENN($C1:C1;$A2:$A99)=0); 1));"")
Gruß Werner
.. , - ...
Anzeige
AW: sorry, mein Fehler ...
19.06.2019 13:42:39
Chriss
Hallo Werner,
gar kein Problem, großen Dank an dich - jetzt funktioniert alles einwandfrei :-)!
Gruß,
Chriss
AW: bitteschön owT
19.06.2019 14:30:46
neopa
Gruß Werner
.. , - ...

307 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige