Microsoft Excel

Herbers Excel/VBA-Archiv

Summewenn mit Bezug auf ein Datum


Betrifft: Summewenn mit Bezug auf ein Datum von: Birgit
Geschrieben am: 10.09.2019 08:52:57

Guten Morgen allerseits,

ich versuche gerade folgende Formel:

=SUMMEWENNS('Datenabzug SAP Q4'!$W$2:$W$99999;'Datenabzug SAP Q4'!$N$2:$N$99999;"L*"; 'Datenabzug SAP Q4'!$V$2:$V$99999;"*EL";'Datenabzug SAP Q4'!$D$2:$D$99999;">=17.06.2019"; 'Datenabzug SAP Q4'!$D$2:$D$99999;"<=23.06.2019";'Datenabzug SAP Q4'!$P$2:$P$99999;"Mannheim")

so abzuändern, dass sich das von mir eingesetzte Datum stattdessen auf eine Zelle bezieht.

Meine Idee sah dann so aus:

=SUMMEWENNS('Datenabzug SAP Q4'!$W$2:$W$99999;'Datenabzug SAP Q4'!$N$2:$N$99999;"L*"; 'Datenabzug SAP Q4'!$V$2:$V$99999;"*EL";'Datenabzug SAP Q4'!$D$2:$D$99999;">=B28"; 'Datenabzug SAP Q4'!$D$2:$D$99999;"<=B29";'Datenabzug SAP Q4'!$P$2:$P$99999;"Mannheim")

B28 und B29 sind dann jeweils mit einem Datum versehen.

Grund hierfür ist: Ich möchte gerne das man in dieser Tabelle nur das Datum in den Bezugszellen ändern muss und nicht gleich jede einzelne Formel.

Leider funktioniert die Änderung nicht so wie ich es möchte. Die ursprüngliche Formel allerdings funktioniert einwandfrei.

Schlussendlich bekomme ich keine Fehlermeldung oder #NV oder sonst etwas, die Zelle bleibt einfach leer.

Hat jemand eine Idee?

Vielen lieben Dank und Gruß
Birgit

  

Betrifft: AW: Summewenn mit Bezug auf ein Datum von: 1712166.html
Geschrieben am: 10.09.2019 08:54:33

Hola,

">="&B28
Gruß,
steve1da
  

Betrifft: AW: Summewenn mit Bezug auf ein Datum von: 1712168.html
Geschrieben am: 10.09.2019 08:57:22

:-) Ja das klappt nun, herzlichen Dank.

Beiträge aus dem Excel-Forum zum Thema "Summewenn mit Bezug auf ein Datum"