Microsoft Excel

Herbers Excel/VBA-Archiv

subtrahieren von Werten mit wechselnden Vorzeichen


Betrifft: subtrahieren von Werten mit wechselnden Vorzeichen von: Dieter Klotz
Geschrieben am: 10.09.2019 14:30:54

hallo,
ich möchte vom Gesamtjahreswert (A2) den Monatswert (B2) subtrahieren.
Da A2 jedoch negativ ist, rechnet Excel die Werte einfach zusammen.
Welche Formel benötige ich, wenn, wie in der Tabelle dargestellt, die Vorzeichen variieren?
Vielen Dank vorab
Gruß Dieter

https://www.herber.de/bbs/user/131953.xlsx

  

Betrifft: AW: subtrahieren von Werten mit wechselnden Vorzeichen von: 1712268.html
Geschrieben am: 10.09.2019 14:33:03

Hola,

=WENN(A2<0;A2+B2;A2-B2)
Gruß,
steve1da
  

Betrifft: AW: subtrahieren von Werten mit wechselnden Vorzeichen von: 1712274.html
Geschrieben am: 10.09.2019 14:49:08


hey, steve1da
Suuuuuper schnell und (wenn man es dann so sieht) gar nicht mal so schwer ;-)

Vielen lieben Dank für die schnelle Hilfe :-)

  

Betrifft: AW: subtrahieren von Werten mit wechselnden Vorzeichen von: 1712291.html
Geschrieben am: 10.09.2019 16:07:03

=A2-VORZEICHEN(A2)*B2


ginge auch.


LG UweD

Beiträge aus dem Excel-Forum zum Thema "subtrahieren von Werten mit wechselnden Vorzeichen"