Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMEWENN über mehrere


Betrifft: SUMMEWENN über mehrere von: stef26
Geschrieben am: 10.09.2019 17:26:18

Hallo liebe Excelprofis,
ich bräuchte einmal eure Hilfe bei einem Thema das mir sonst uznmengen an Zeit kosten würde.

Ich habe in einer Tabelle in der Zeile F1 bis BY1 die Namen von Tabellenblättern hinterlegt.
Wie kann ich der Formel Summenwenn die in der Zeile 2 beginnt anstelle der Tabelle1 den Namen der Tabelle aus der Zeile 1 zuweisen?
=SUMMEWENN(Tabelle1!$I$106:$J$300;A2;Tabelle1!$J$106:$J$300)

nimm nicht Tabelle1 sondern den Namen der Tabelle der in der Zeile1 steht.

Geht das?
Wenn ja wie?

Viele Grüße
Stefan

  

Betrifft: AW: SUMMEWENN über mehrere von: 1712319.html
Geschrieben am: 10.09.2019 17:32:48

Hallo Stefan,

Indirekt(F1 &"!$I$106:$J$300")


GrußformelHomepage

  

Betrifft: Oder INDIREKT("'"&F1&"'!I106:J300"), falls der ... von: 1712323.html
Geschrieben am: 10.09.2019 17:46:31

…Bereich statisch sein soll, Stefan.
Gruß, Luc :-?

„Der beste Beweis für intelligentes Leben im Universum ist, dass noch niemand versucht hat, Kontakt mit uns aufzunehmen.“ H.Lesch, 2018, Sonneberg
Deshalb Intelligenz steigern mit …

  

Betrifft: AW: da war ich etwas zu langsam owT von: 1712326.html
Geschrieben am: owT

Gruß Werner
.. , - ...

  

Betrifft: AW: Oder INDIREKT("'"&F1&"'!I106:J300"), falls der ... von: 1712329.html
Geschrieben am: 10.09.2019 18:03:17

DANKESCHÖN für die zahlreichen Rückmeldungen.
Auf INDIREKT bin ich nicht gekommen, genau das war was ich benötigt habe

DANKE
Gruß
Stefan

  

Betrifft: Deine Begründung.... von: 1712332.html
Geschrieben am: 10.09.2019 18:47:25

Hi Luc,

...habe ich jetzt nicht ganz verstanden:

...falls der Bereich statisch sein soll...

Deine Hochkomma-Änderung erlaubt nunmehr Blattnamen mit Leer-/Sonderzeichen - das wäre für mich der Mehrwert.
Das Enfernen der $ aus dem Bezugsstring hingegen ändert doch nix (die $ stören ja nicht - sind halt nur überflüssig)...?

VG, Boris

  

Betrifft: Du warst doch schon auf dem Weg, ... von: 1712335.html
Geschrieben am: 10.09.2019 18:57:36

…Boris; ;-)
warum sind die $ überflüssig? Weil die Bereichsangabe als Text ohnehin statisch ist, statischer sogar als Absolut-Adressierung. Müsste sie aber dynamisch sein, dürfte man den Bereich nicht so in den Text einbeziehen, sondern müsste ihn etwas aufwendiger flexibilisieren. Wie, weißt Du doch auch…
Gruß, Luc :-?

  

Betrifft: Wir verstehen uns gerade miss... von: 1712336.html
Geschrieben am: 10.09.2019 19:04:33

Hi Luc,

...was Du schreibst, weiß ich natürlich, besonders wie man es dynamisiert.

Aber "I1:I1000" oder "$I$1:$I$1000" - beides als String - ist halt komplett das Selbe - nur sind die $ schlicht überflüssig - stören aber auch nicht.
Und beide Varianten sind statisch.

Deine Anmerkung ...falls der Bereich statisch sein soll... klang für mich so, dass das bei Hajos Variante nicht der Fall wäre.

VG, Boris

  

Betrifft: Nee, das war nicht gemeint, statisch ist beides, … von: 1712339.html
Geschrieben am: 10.09.2019 19:45:49

…Boris,
weshalb ich gerade deshalb konsequenterweise die $ weggelassen hatte. Einen kurzen Augenblick lang kam mir dabei der Gedanke, dass man diese Kombination 2er Aktionen missverstehen könnte, aber ich hab's dann doch dabei belassen. Und siehe da… ;-)
Pardon für die Verständnisfalle erbeten!
Luc :-?

  

Betrifft: Erbeten und erteilt ;-)) oT von: 1712346.html
Geschrieben am: 10.09.2019 20:04:37

VG, Boris

  

Betrifft: AW: da Deine Blattnamen uns nicht bekannt sind ... von: 1712324.html
Geschrieben am: 10.09.2019 17:49:26

Hallo Stefan

... und evtl. Sondezeichen beinhalten können, nutze vorsichtshalber folgende Formel (für Blattnamen in F1):

=WENNFEHLER(SUMMEWENN(INDIREKT("'"&F1&"'!I106:J300");A2;INDIREKT("'"&F1&"'!J106:J300"));"Blattname gibt es nicht")

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "SUMMEWENN über mehrere "