Das Archiv des Excel-Forums

Matrixformel mit Summenfunktion


Betrifft: Matrixformel mit Summenfunktion
von: Jörg

Geschrieben am: 11.09.2019 18:33:07
Hallo zusammen,

ich benötige einmal eure Hilfe.
Es geht darum das in Spalte A verschiedene Namen (teilweise mit Leerzeilen) aufgelistet sind. In Spalte B stehen Werte die in Bezug zur Spalte A stehen. Wenn dort eine Leerzeile ist dann gehört der Wert zu dem letzten Namen aus Spalte A.

Ich möchte jetzt das Ganze, zum besseren lesen, zusammen fassen. Das heißt in Spalte D fliegen erstmal alle Leerzeilen aus der Spalte A raus. Das klappt mit meiner Matrixformel auch wunderbar. Aber jetzt benötige ich noch eine Formel (für Spalte E) die mir auch die jeweiligen Werte zusammen rechnet.

Zum besseren Verständnis hänge ich noch eine Beispieldatei an.
https://www.herber.de/bbs/user/131995.xlsx
Für eure Hilfe bedanke ich mich schon einmal im Voraus.

Viele Grüße Jörg
PS:

Nach diesem Muster ist die Tabelle aufgebaut:
Spalte A Spalte B
a 5
[leer] 1,98
b 3

Die Formel für Spalte C sieht wie folgt aus:
{=WENN(SUMMENPRODUKT(($A$5:$A$22<>"")*1)"";   ZEILE($5:$22));ZEILE(A1))))   }

Betrifft: Datei mit Power Query zurück...
von: 1712531.html
Geschrieben am: 11.09.2019 18:48:20
https://www.herber.de/bbs/user/131996.xlsx

Betrifft: AW: mit einer SUMME()-Formel ...
von: 1712532.html

Geschrieben am: 11.09.2019 18:51:28
Hallo Jörg,

... z.B. wie folgt in E5:

=WENN(D5="";"";WENN(D6="";SUMME(INDEX(B:B;VERGLEICH(D5;A:A;0)):B994);SUMME(INDEX(B:B;VERGLEICH(D5;A:A;0)):INDEX(B:B;VERGLEICH(D6;A:A;0)-1))))

und Formel nach unten kopieren.

Gruß Werner
.. , - ...

Betrifft: AW: mit einer SUMME()-Formel ...
von: 1712538.html
Geschrieben am: 11.09.2019 19:09:37
Vielen Dank Werner,

die Formel tut genau das was ich möchte.

Viele Grüße
Jörg

Betrifft: AW: sieh Dir noch die zu Spalte D an ...
von: 1712542.html

Geschrieben am: 11.09.2019 19:14:50
Hallo Jörg,

... und die PowerQuery-Lösung, die Dir Robert aufgezeigt hat. Die ist einfach und ist vor allem bei Massendatenauswertung de Formellösung überlegen. Einziger kleiner Nachteil, Du musst bei Datenänderungen eine Aktualisierung vornehmen, was allerdings nur eine Tastenkombination oder ein Mausklick ist.

Gruß Werner
.. , - ...

Betrifft: AW: sieh Dir noch die zu Spalte D an ...
von: 1712698.html
Geschrieben am: 12.09.2019 15:00:24
Hallo Werner,
ich hab das PowerQuery Addon nicht. Außerdem soll die Datei auch auf den verschiedensten Geräten funktionieren und da macht sich das erfahrungsgemäß per Formel besser.
Aber nochmal vielen Dank für die Hilfe.
Grüße Jörg

Betrifft: AW: und zur Datenauflistung in Spalte D ...
von: 1712534.html

Geschrieben am: 11.09.2019 18:56:44
Hallo Jörg,
... die auch einfacher mit einer Matrixfunktion(alität)sformel, die keines spez. Formelabschluss wie eine klassische Matrixformel benötigt.
In D5: =WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE(A$5:A$99)/(A$5:A$99<>"");ZEILE(A1)));"")

und Formel nach unten kopieren.
Gruß Werner
.. , - ...

Betrifft: AW: nachgefragt ...
von: 1712540.html
Geschrieben am: 11.09.2019 19:10:56
Hallo Robert,

... warum benennst Du den Spaltennamen nicht gleich beim Gruppieren um? Spart doch einen Schritt ein.

Gruß Werner
.. , - ...

Betrifft: Flüchtigkeitsfehler :-)) owT
von: 1712541.html

Geschrieben am: 11.09.2019 19:13:46

Betrifft: AW: von Fehler kann man da aber nicht sprechen owT
von: 1712543.html
Geschrieben am: 11.09.2019 19:15:37
Gruß Werner
.. , - ...

Excel-Beispiele zum Thema "Matrixformel mit Summenfunktion"

Ausgabe einer benutzerdefinierten Funktion in Matrixformel download SVERWEIS-, WVERWEIS- und Matrixformel-Beispiele download
Anzahl nach 2 Kriterien ermitteln mit DB-Funktion und MatrixFormel download Temporärer VBA-Einsatz einer Matrixformel download
Eintragen von Matrixformeln in eine Jahres-/Monatsmatrix download Benutzerdefinierte Funktion als Matrixformel download