Das Archiv des Excel-Forums

Index Vergleich Formel mit Summenformel


Betrifft: Index Vergleich Formel mit Summenformel
von: Rodrigo

Geschrieben am: 12.09.2019 08:58:02
Hallo,

ich würde gern 3 Monate (3 Zellen) innerhalb meiner Index Vergleich Formel summieren. Ich versuche ein Bild von meiner Beispielliste die einen Auszug meiner tatsächlichen liste darstellt hochzuladen.

Das ist die Formel
=WENNFEHLER(INDEX($B$4:$G$8;
VERGLEICH(A4;$A$4:$A$8;0);
VERGLEICH($K$2&$K$3;$B$1:$G$1&$B$2:$G$2;0));0)

hier der Screenshot:

Userbild

Vielleicht kann jemanden helfen.

Danke

Betrifft: AW: Index Vergleich Formel mit Summenformel
von: 1712596.html
Geschrieben am: 12.09.2019 09:03:35
Hola,

vielleicht versteh ichs auch nur falsch...

=SUMMENPRODUKT(($B$2:$G$2=J$3)*($B4:$G4))
Gruß,
steve1da

Betrifft: AW: Index Vergleich Formel mit Summenformel
von: 1712598.html

Geschrieben am: 12.09.2019 09:08:30
Hallo steve1da,

geht schon in die richtige Richtung. Summeprodukt zu verwenden ist eine gute Idee. Nur bräuchte ich diese Formel in meine schon vorhandene Formel integriert. Ich bin leider nicht so gut im verschachteln von Formeln.

Betrifft: AW: Index Vergleich Formel mit Summenformel
von: 1712599.html
Geschrieben am: 12.09.2019 09:09:42
Hola,

warum verschachteln? Bringt meine Formel nicht die richtigen Ergebnisse?
Das kann natürlich sein, weil man auf Bildchen keine Formatierungen erkennen kann.

Gruß,
steve1da

Betrifft: AW: Index Vergleich Formel mit Summenformel
von: 1712602.html

Geschrieben am: 12.09.2019 09:16:57
Deine Formel bringt das richtige Ergebnisse für das vereinfachte Beispiel. Ich meine Verschachteln in diese schon vorhandene Formel, die brauche ich. Zelle K2 und K3 sind dropdown listen mit verschiedenen Kritieren deshalb brauche ich diese Formel um die richtigen Werte zu ziehen (in Wirklichkeit ist meine Liste viel größer)

=WENNFEHLER(INDEX($B$4:$G$8;
VERGLEICH(A4;$A$4:$A$8;0);
VERGLEICH($K$2&$K$3;$B$1:$G$1&$B$2:$G$2;0));0)

Ich hoffe jetzt ist es etwas verständlicher. Vielleicht gibt es ja auch einen einfachere Lösung.

Betrifft: AW: Index Vergleich Formel mit Summenformel
von: 1712605.html
Geschrieben am: 12.09.2019 09:23:50
Hola,
mein letzter Rateversuch:

=SUMMENPRODUKT(($B$1:$G$1=K2)*($B$2:$G$2=K$3)*($A$4:$A$8=A4)*($B4:$G8))
Gruß,
steve1da

Betrifft: AW: nachgefragt ...
von: 1712635.html

Geschrieben am: 12.09.2019 10:51:54
Hallo,

... warum stellst Du nicht (D)eine (abgespeckte) Beispieldatei ein?

Gruß Werner
.. , - ...

Betrifft: AW: nachgefragt ...
von: 1712646.html
Geschrieben am: 12.09.2019 11:00:26
Hallo Werner,

gut, hier ist die Datei. Ich würde wie schon erklärt gerne die Funktionalität meiner Formel behalten, wie man in der Datei sieht werden die richtigen Daten gezogen auch wenn ich K2 und K3 ändere. Zusätzlich möchte ich nun aber die Summen für das Quartal bilden. Wie man an meiner Beispiel Spalte J sieht. Q3Fy19 besteht aus Apr, May und Juni. So wie von steve1da schon gepostet nur eben integriet in meine Formel - das ist was ich nicht hinbekomme.

https://www.herber.de/bbs/user/132004.xlsx

Betrifft: AW: noch unklar was du genau anstrebst ...
von: 1712654.html

Geschrieben am: 12.09.2019 11:20:45
Hallo Rodrigo,

... die Ergebnisses in Spalte J kannst Du mit der Formel von SF erzeugen. Anstelle dessen hätte ich nu =SUMMEWENN(B$2:G$2;J$3;B4:G4) genutzt.

Was aber meinst Du mit "zusätzlich" genau? Willst Du den Ergebniswert zu dem aus für die Eingabe aus J2 addieren? Macht für für mich keinen Sinn, weil dann ein falsches Ergebnis erzeugt wird.
Warum ist Deine Formel in K4 überhaupt so kompliziert? Kann es noch weitere Kombinationen der gleichen Monatsangaben mit den Angaben in Zeile 2 geben?

Gruß Werner
.. , - ...

Betrifft: AW: noch unklar was du genau anstrebst ...
von: 1712683.html
Geschrieben am: 12.09.2019 13:28:13
Hallo Werner,

ja genau, die Kriterien von Zeile 1 und 2 müssen erfüllt werden. Deswegen geht Summewenn nicht. Die Formel von SF =SUMMENPRODUKT(($B$2:$G$2=I$3)*($B4:$G4)) liefert das richtige Ergebnis aber nur für 1 Kritierium. Ich brauche noch das 2. Kriterium aus Zeile 2. Ich glaube das hat er mit
=SUMMENPRODUKT(($B$1:$G$1=K2)*($B$2:$G$2=K$3)*($A$4:$A$8=A4)*($B4:$G8)) versucht. Aber da kommt nicht mehr das richtige Ergbenis raus, da ist wohl noch irgendwo ein kleiner Fehler drin den ich nicht sehe.

Betrifft: AW: noch unklar was du genau anstrebst ...
von: 1712685.html

Geschrieben am: 12.09.2019 13:30:58
Hola,

bei Excel Gut hätte ich erwartet dass du 2 kleiner Fehler bemerkst:
=SUMMENPRODUKT(($B$1:$G$1=J$2)*($B$2:$G$2=J$3)*($A$4:$A$8=A4)*($B$4:$G$8))
Gruß,
steve1da

Betrifft: AW: noch unklar was du genau anstrebst ...
von: 1712712.html
Geschrieben am: 12.09.2019 15:40:32
Danke für die Lösung steve1da. Hab wenig geschlafen und gut ist eine dehnbarer Begriff :D

Betrifft: AW: wie geschrieben, macht das mE keinen Sinn ...
von: 1712727.html

Geschrieben am: 12.09.2019 16:03:44
Hallo Rodrigo,

... das von Dir noch immer geforderte und von SF lediglich "1:1" so umgesetzte, ist in meinen Augen "doppelt gemoppelt". Das hast bisher auch auf meine Frage hin, noch keinen Grund aufgezeigt, weshalb eine derartige doppelte Prüfung notwendig sei. Und wenn so was notwendig wäre, dann ist immer noch

=SUMMEWENNS(B4:G4;B$1:G$1;J$2;B$2:G$2;J$3) einfacher.

Gruß Werner
.. , - ...

Betrifft: AW: wie geschrieben, macht das mE keinen Sinn ...
von: 1712733.html
Geschrieben am: 12.09.2019 16:10:47
Hallo Werner,
momentan habe ich keinen Grund für eine doppelte Prüfung der 2 Kriterien. Ich werde beide Lösungen mit meiner original Liste prüfen. Vielleicht fällt mir dann noch was auf.
Danke und Grüße

Excel-Beispiele zum Thema "Index Vergleich Formel mit Summenformel"

Zellen vergleichen und markieren download Tabellen vergleichen download
Tabellenvergleich und Übernahme der Doppel download Spalten A und B vergleichen und Doppel in C listen download
Werte vergleichen download Bereiche auf Übereinstimmung vergleichen download
Daten in jeweils einer Spalte zweier Tabellen vergleichen download SVERWEIS, WVERWEIS, INDEX, VERGLEICH und Zielwertsuche download
Werte vergleichen und Ergebnis in Tabelle eintragen download Preisvergleiche download
Tabellen vergleichen und Zeilen ersetzen download Tabellen vergleichen und bei Nichtübereinstimmung markieren download
Textdateien vergleichen und Unterschiede dokumentieren download Setzen der Hintergrundfarbe nach Wertevergleich download
Spalte A mit B vergleichen und Doppel in C eintragen download Tabellenvergleich über die bedingte Formatierung download
Telefonnumern mit Liste vergleichen und durch Namen ersetzen download Vergleich von zwei Listen und Ausgabe eines Wahrheitswertes download
Nach Vergleich Kommentar einfügen download Vergleich von Zellwerten mit unterschiedlichen Methoden download
Werte vergleichen und übertragen download Teilstrings vergleichen und markieren download
Bei TextBox-Eingaben Mustervergleich und Formatierung download Textmuster vergleichen download
Unterschiedliche Smilies bei Zellvergleich download Anzeigen von Werten und Formeln download
Zeile einfügen und Formeln und Werte übernehmen download Formeln mit Zelladressen speichern download
Zeilenumbruch in Formel erzwingen download Aktueller Arbeitsblattname in Formel download
Variable in Formel einbauen download Ein Zeichen in einer Formel suchen download
Variable in Excel-Formel einbauen. download Summenformel unter Zahlenreihe eintragen download
Arbeitszeittabelle und SVERWEIS-Formel download Zeilen mit leeren Formeln beim Druck unterdrücken download
Ausgabe einer benutzerdefinierten Funktion in Matrixformel download Listung der mit der Formel KOMBINATIONEN() ermittelten Elemente download
Alle Formeln und Links in Werte wandeln download Formel bis zur letzten Zeile der Nebenspalte kopieren download
Summenformel per VBA eintragen download Namen löschen ohne Formeln zu zerstören download
Anzeige der Formel mit Quellblattangabe download Alle Formeln und Zahlen löschen download
Textstring in berechenbare Formel umwandeln download Spielpaarungen von Vorrunde bis Finale durch Formeln ermitteln download
Zahlenstring mit Formel auslesen und Fehlermeldung verhindern download Wahrheitsprüfung einer mit Zellwerten zusammengestzten Formel download
SVERWEIS-Formel über mehrere Fundstellen download Mittelwert einer Zahlenreihe bis zur Zeile mit der Formel download
SVERWEIS-, WVERWEIS- und Matrixformel-Beispiele download Beispiel für die Anwendung der SUMMEWENN-FORMEL download
Datei auswählen, öffnen und Formelsuchdialog anzeigen download Formelbereich in Einzelelemente aufschlüsseln download
Signal, wenn sich Formelwert über eine Grenze bewegt download Formeleingabe über ShortCut download
UserForm-Aufruf, wenn Formel-Wert Grenze überschreitet download In Abhängigkeit von einem Formelwert Makro starten download
In Abhängigkeit von einem Formelwert Mail mit Outlook versenden download Anzahl nach 2 Kriterien ermitteln mit DB-Funktion und MatrixFormel download
Sortierung mit Formel-Leerstrings am Ende download Nach Formelkalkulation Zellwert erhöhen download
Markierung von Formeln über bedingte Formatierung download Zellschutz nur für Formeln download
Text in Formel und Formel in Text download Blatt ohne Code, Steuerelement und Formeln speichern download
Zählen von in einer Formel vorkommenden Zahlen download Temporärer VBA-Einsatz einer Matrixformel download
Eintragen von Matrixformeln in eine Jahres-/Monatsmatrix download Dynamischer Blattname in SVERWEIS-Formel download
Bei Eintrag Übernahme der Formel aus Nebenzelle download TextBox-Eingabe mit Formel weiterberechnen und zurückgeben download
Formeltexte anzeigen download Formel zur Ermittlung von Ostersonntag download
Ermittlung von Datenbank- und Array-Formelergebnissen per VBA download Nur Summenformel zur längsten Spalte eintragen download