Microsoft Excel

Herbers Excel/VBA-Archiv

Wiedergabe der Zeilennummer mit jüngstem Datum


Betrifft: Wiedergabe der Zeilennummer mit jüngstem Datum von: Pogonatherum
Geschrieben am: 13.09.2019 09:47:45

Hallo Excel Fan Gemeinde,

https://www.herber.de/bbs/user/132020.xlsx

Aufgabenstellung: In meiner Tabelle sind Ausgaben dokumentiert.

Ich möchte entweder in H3 eine Formel haben die anhand B1 nur alle Ausgaben dieses Jahres addiert (d. h. Zeilen 31ff werden hier nicht berücksichtigt, da aus 2018)

oder ich möchte in G3 die Wiedergabe der Zeilenummer mit dem jüngsten Datum, also Heute unter Berücksichtigung das es die Zeile mit der höchsten Nummer ist, da mehrere Zeilen mit dem selben Datum vorkommen können.

Ich werde nur eine Lösungen brauchen, freue mich aber über beide Lösungsvorschläge - man lernt nie aus...

Grüße

Alex

  

Betrifft: AW: Wiedergabe der Zeilennummer mit jüngstem Datum von: 1712826.html
Geschrieben am: 13.09.2019 09:51:47

Hola,

=SUMMENPRODUKT((JAHR(A2:A35)=JAHR(B1))*(E2:E35))
Gruß,
steve1da
  

Betrifft: AW: Wiedergabe der Zeilennummer mit jüngstem Datum von: 1712828.html
Geschrieben am: 13.09.2019 09:55:38

Sowie

     =VERGLEICH(MAX(A2:A35);A2:A35;0)

  

Betrifft: AW: Wiedergabe der Zeilennummer mit jüngstem Datum von: 1712849.html
Geschrieben am: 13.09.2019 11:04:36

Die Formel MAX ist für mich neu.
Von daher kann ich sie noch nicht ganz zuordnen.
Die Formel MAX gibt die größte Zahl (jüngeres Datum hat höheren Wert-klar) im Bereich A2:A35 an!
Der Vergleich gibt die Position der gewünschten Zahl an, gibt aber in meinem Fall eine um eins niedrigere Zahl an: 11. Anzeigen sollte er aber 12
Meine Tabelle ist über 1000 Zeilen lang, und fängt auch erst bei Zeile 9 an. Die Änderung soweit: VERGLEICH(MAX(A9:A2000);A9:A2000;0) führt dazu das ich einen Wert von 1033 erhalte. Das wäre in meinem Fall der 27.12.2018. Da meine Zeilen erst aber Zeile 9 beginnen habe ich der Formel +8 hinzugefügt = VERGLEICH(MAX(A9:A2000);A10:A2000;0)+8
Soweit passt die Formel, zeigt aber leider nicht das gewünschte Ergebnis vom 13.09.2019 Zeile 634

  

Betrifft: AW: Wiedergabe der Zeilennummer mit jüngstem Datum von: 1712855.html
Geschrieben am: 13.09.2019 11:22:18

Hola,

Vergleich zeigt die Position des gesuchten Wertes innerhalb des Bereichs an, hier also A9:A2000.
Im Bereich A2:A35 steht die höchste Zahl in A12, das ist die 11. Zeile in diesem Bereich.
+8 oder -1 ist hier also völlig falsch.

Gruß,
steve1da

  

Betrifft: AW: Wiedergabe der Zeilennummer mit jüngstem Datum von: 1712862.html
Geschrieben am: 13.09.2019 11:38:37

Ich möchte aber die letzte Zeile mit dem neusten Datum anzeigen lassen, das wäre in meinem Fall aber doch die Zeile 12 nicht 11. Ich brauche die Zeilennummer und nicht die Position innerhalb eines Bereichs.

  

Betrifft: AW: Wiedergabe der Zeilennummer mit jüngstem Datum von: 1712863.html
Geschrieben am: 13.09.2019 11:41:30

Hola,

schon klar. In der GESAMTEN Spalte A ist das jüngste Datum in A12. Im Bereich A2:A35 ist die Zelle A12 aber die 11. Zeile. Vielleicht verstehst du es ja so:
=VERGLEICH(MAX(A:A);A:A;0)
=VERGLEICH(MAX(A2:A35);A2:A35;0)
Die erste Formel ergibt 12, die zweite Formel ergibt 11. In beiden Fällen steht das jüngste Datum in A12.

Gruß,
steve1da

  

Betrifft: AW: Wiedergabe der Zeilennummer mit jüngstem Datum von: 1712950.html
Geschrieben am: 13.09.2019 15:26:35

OK geschnallt. Also ist für mich die 1. Formel die beste Wahl.
Jedoch habe ich immer noch nicht die optimale Formel, denn hier wird die erste Zeile des jüngsten Datums angezeigt.
Für heute habe ich zum Beispiel 5 Einträge, letzter Eintrag in Zeile 634, die Formel zeigt aber nun an 630.
Allerdings kann ich ja in Zeile 635 schon mal das Datum von morgen einsetzen und dann bekomme ich zwar 635 angezeigt, da aber da keine sonstigen Werte drin sind, verfälscht dies nicht mein Endergebnis.

Viele Grüße

ALex

  

Betrifft: AW: Wiedergabe der Zeilennummer mit jüngstem Datum von: 1712834.html
Geschrieben am: 13.09.2019 10:04:42

odeer so...


=SUMMEWENNS(E:E;A:A;">="& B1;A:A;"<"& DATUM(JAHR(B1)+1;1;1))


LG UweD

  

Betrifft: AW: Wiedergabe der Zeilennummer mit jüngstem Datum von: 1712842.html
Geschrieben am: 13.09.2019 10:38:18

Vielen Dank den schnellen Antworten

Beiträge aus dem Excel-Forum zum Thema "Wiedergabe der Zeilennummer mit jüngstem Datum"