Microsoft Excel

Herbers Excel/VBA-Archiv

Wert suchen und ab Wert Zahlen addieren


Betrifft: Wert suchen und ab Wert Zahlen addieren von: Alexander Hein
Geschrieben am: 13.09.2019 10:54:28

Hallo zusammen,

leider komme ich derzeit nicht mehr weiter. Ich hab folgendes Problem:

Ich hab 2 Spalten (Spalte A und Spalte B).

In Spalte A steht Text.
In spalte B stehen Zahlen.

Nun sollen alle Zahlen in Spalte B bis zu einem bestimmten Text (eindeutiger Name) in Spalte A mit der Zahl 1000000 addiert werden. Sobald der gesuchte Text auftaucht, soll inder selben Zeile in Spalte B und die darauffolgenden Zahlen mit -1000000 addiert werden. Leider ist die Tabelle unterschiedlich lang. Ein ebstimmte Range ist daher nicht bekannt.

Ich bin für jede Hilfe unglaublich dankbar. Das Problem scheint so simpel, aber meine VBA Kentnisse sind derzeit noch sehr ausbaufähig.

Vielen Dank und viele Grüße
Alex

  

Betrifft: AW: Wert suchen und ab Wert Zahlen addieren von: 1712870.html
Geschrieben am: 13.09.2019 12:00:20

Hallo Alex,

eine Beispieltabelle würde die Chancen auf Hilfestellung vermutlich deutlich steigern...

Gruß
Jochen

  

Betrifft: AW: Wert suchen und ab Wert Zahlen addieren von: 1712871.html
Geschrieben am: 13.09.2019 12:04:31

Moin Alex!

Sub Makro1()
 
     Dim C As Range, Summand As Double
     
     Summand = 100000
     
     For Each C In Range("A1").CurrentRegion.Columns(1).Cells
         
         
         If C.Text = "Muster" Then Summand = -100000
            
         If IsNumeric(C.Offset(0, 1).Text) Then
             C.Offset(0, 1).Value = C.Offset(0, 1).Value + Summand
         End If
         
     
     Next C
 
 End Sub

Gruß Gerd
  

Betrifft: AW: Wert suchen und ab Wert Zahlen addieren von: 1712930.html
Geschrieben am: 13.09.2019 14:35:17

Hallo Gerd,

super! Vielen lieben Dank für das Makro. :) Hat super weitergeholfen!

Viele Grüße
Alexander Hein

  

Betrifft: Summe bis *1000000* von: 1712873.html
Geschrieben am: 13.09.2019 12:17:56

Hi,

folgende Arrayformel:
{=SUMME(B1:INDEX(B:B;MIN(WENN(ISTZAHL(FINDEN(1000000;A1:A99));ZEILE(1:99)))))}

"und die darauffolgenden Zahlen mit -1000000 addiert werden"
kapier ich nicht ?

WF

Beiträge aus dem Excel-Forum zum Thema "Wert suchen und ab Wert Zahlen addieren "