Microsoft Excel

Herbers Excel/VBA-Archiv

Zufallslosung und Aufteilen


Betrifft: Zufallslosung und Aufteilen von: Udo
Geschrieben am: 14.09.2019 11:18:22

Hallo habe eine Frage

Ich habe 24 Mannschaften in den Zeilen A9 bis A 32 stehen.Jetzt möchte ich per Zufallslosung diese 24 Mannschaften in 4 gleich große Gruppen (6) teilen. Das heißt melden sich nur 20 Mannschaften das eben dann in jeder Gruppe nur 5 Mannschaften stehen usw.
Ich bitte um eure Mithilfe Danke und LG

  

Betrifft: AW: Zufallslosung und Aufteilen von: 1713032.html
Geschrieben am: 14.09.2019 11:44:37

Hallo

Könnte man so machen
Bsp für 20 Teams

Tabelle1

 ABC
10,17716758Team 01Team 11
20,68229305Team 02Team 03
30,07339211Team 03Team 01
40,62846468Team 04Team 17
50,8116606Team 05Team 15
60,88706831Team 06Team 07
70,26769527Team 07Team 14
80,74549079Team 08Team 09
90,35615738Team 09Team 12
100,58790275Team 10Team 13
110,04868747Team 11Team 18
120,37912087Team 12Team 16
130,42587123Team 13Team 10
140,33892153Team 14Team 04
150,24206771Team 15Team 02
160,54369228Team 16Team 08
170,19508387Team 17Team 05
180,44537273Team 18Team 06
190,89713671Team 19Team 19
200,99941383Team 20Team 20

Formeln der Tabelle
ZelleFormel
A1=ZUFALLSZAHL()
C1=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A2=ZUFALLSZAHL()
C2=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A3=ZUFALLSZAHL()
C3=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A4=ZUFALLSZAHL()
C4=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A5=ZUFALLSZAHL()
C5=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A6=ZUFALLSZAHL()
C6=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A7=ZUFALLSZAHL()
C7=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A8=ZUFALLSZAHL()
C8=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A9=ZUFALLSZAHL()
C9=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A10=ZUFALLSZAHL()
C10=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A11=ZUFALLSZAHL()
C11=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A12=ZUFALLSZAHL()
C12=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A13=ZUFALLSZAHL()
C13=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A14=ZUFALLSZAHL()
C14=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A15=ZUFALLSZAHL()
C15=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A16=ZUFALLSZAHL()
C16=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A17=ZUFALLSZAHL()
C17=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A18=ZUFALLSZAHL()
C18=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A19=ZUFALLSZAHL()
C19=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)
A20=ZUFALLSZAHL()
C20=SVERWEIS(KKLEINSTE($A$1:$A$20;ZEILE());$A$1:$B$20;2;0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

wobei Du die Teams in Spalte("B") schreibst und nur in A1 und C1 die dargestellten Formeln schreibst.
Nun brauchst Du A1 und C1 nur runterkopieren bis Zeile(20)

Gruß Matthias
  

Betrifft: AW: Zufallslosung und Aufteilen von: 1713037.html
Geschrieben am: 14.09.2019 12:02:27

Danke für deine rasche Antwort.
Leider ist es nicht ganz das was ich suche, ich bräuchte so was ähnliches das mir die Gruppen aufjedenfall gleich groß hält. sollle ich nur 17 Mannschaften eintragen sind es dann zb. 5,4,4,4
Bei 15 z.B 4,4,4,3 usw.
Danke

  

Betrifft: AW: Zufallslosung und Aufteilen von: 1713041.html
Geschrieben am: 14.09.2019 12:11:23

Hi Udo,

Zitat:
das mir die Gruppen aufjedenfall gleich groß hält

bei 17 Mannschaften willst du: 5,4,4,4
bei 15 Mannschaften willst du: 4,4,4,3

in beiden Fällen sind die Mannschaften - nicht - gleich groß


???????????????


Nach deinen Vorgaben würden bei 17 gemeldeten Mannschaften 4 Gruppen á 4 Mannschaften gebildet werden
4 x 4 = 16, Rest 1!

Nach deinen Vorgaben würden bei 15 gemeldeten Mannschaften 3 Gruppen á 4 Mannschaften gebildet werden
3 x 4 = 12, Rest 3!

Sorry, verstehe dich nicht.

Ciao
Thorsten

  

Betrifft: AW: Zufallslosung und Aufteilen von: 1713042.html
Geschrieben am: 14.09.2019 12:18:42

Hallo
Bei 17 Mannschaften wären dann
in der Gruppe A - 5 Mannschaften
in der Gruppe B - 4 Mannschaften
in der Gruppe C - 4 Mannschaften
in der Gruppe D - 4 Mannschaften

so wäre es perfekt für mich. Gruppen müssen immer 4 bleiben
und bei ungerader Anmeldung, wären dann die Gruppen eben nicht exakt gleich gross.
Ich hoffe mich verständlich ausgedrückt zu haben.

  

Betrifft: Das Prinzip ist doch das Gleiche von: 1713047.html
Geschrieben am: 14.09.2019 12:49:23

Ist doch egal wieviele Teams sich gemeldet haben.
Du teilst die Gesamtmeldungen duch 4.

Vorrausgesetzt es haben sich genügend Teams gemeldt!

Hast Du einen Rest von 1 hast Du:
1 Gruppe mit 5 Teams und 3 Gruppen mit 4 Teams

Hast Du einen Rest von 2 hast Du:
2 Gruppen mit 5 Teams und 2 Gruppen mit 4 Teams

Hast Du einen Rest von 3 hast Du:
3 Gruppen mit 5 Teams und 1 Gruppe mit 4 Teams



Die Zufallsauswertung per Formeln bleibt doch die Gleiche

Gruß Matthias
  

Betrifft: AW: Das Prinzip ist doch das Gleiche von: 1713049.html
Geschrieben am: 14.09.2019 12:59:08

Ok Danke für deine eure Mühe

  

Betrifft: AW: Zufallslosung und Aufteilen von: 1713051.html
Geschrieben am: 14.09.2019 13:10:29

Hallo Udo,

Mein Lösungsvorschlag ohne jede Gewähr (aber ich verwende einen aktuellen Virenscanner):
https://www.herber.de/bbs/user/132037.xlsm

Viele Grüße,
Bernd P

  

Betrifft: AW: Zufallslosung und Aufteilen von: 1713058.html
Geschrieben am: 14.09.2019 14:36:22

Perfekt
Dankeschön

  

Betrifft: AW: Zufallslosung und Aufteilen von: 1713060.html
Geschrieben am: 14.09.2019 14:51:16

Hi

in B9:B32: =Wenn(A9:A32)="";"";Zufallszahl())
in C9:C32: =Wenn(A9:A32)="";"";Rest(Rang(B9:B32;B9)-1;4)+1)

zum Fixieren der Auslosung, B9:B32 oder C9:C32 kopieren und als Wert einfügen.

Gruß Daniel

  

Betrifft: AW: Zufallslosung und Aufteilen von: 1713081.html
Geschrieben am: 14.09.2019 17:43:35

Hi

Geht bei mir nicht ?
LG Udo

  

Betrifft: bring mal bei RANG die Parameter in die richtiger von: 1713084.html
Geschrieben am: 14.09.2019 17:55:39

Reihenfolge und setze den Zellbereich auf die Zufallszahlen absolut.
Rang(B9;$B$9:$B$32)
Gruß Daniel

  

Betrifft: AW: bring mal bei RANG die Parameter in die richtiger von: 1713085.html
Geschrieben am: 14.09.2019 18:07:03

Jetzt klappts

Dankesehr

Beiträge aus dem Excel-Forum zum Thema "Zufallslosung und Aufteilen"