Microsoft Excel

Herbers Excel/VBA-Archiv

Excel 2013 Formeln


Betrifft: Excel 2013 Formeln von: haette
Geschrieben am: 14.09.2019 17:12:53

Hallo.
Fragen:
Die Damen und Herren habe ich nun dank der neuen Spalte per Formel
= ZÄHLENWENN($C$3:$C$1674;"F") & " Damen Mitglieder"
ausgezähl. Ist die Formel gut oder habt ihr eine bessere?
Gleichzeitig habe ich noch eine Spalte mit eingefügt, wo ich die aktiven mit X markiert habe. - = ZÄHLENWENN($D$3:$D$1674;"X") & " aktive Damen u Herren" -

Nur bekomme ich die Formel für die % nicht hin
Also 646 Damen Mitglieder sind wieviel %
- =(WENN($C$3:$C$1674;"F") DANN(ANZAHL($C$3:$C$1674)) -
und 1028 Herren Mitglieder sind wieviel %
und 1281 aktive Damen u Herren sind wieviel %
was ist falsch an der Formel ?? die Zelle steht auf Prozent

Meinen Dank im Voraus
Dieter

  

Betrifft: AW: Excel 2013 Formeln von: 1713076.html
Geschrieben am: 14.09.2019 17:20:35

Hallo dieter,

=ZÄHLENWENN($C$3:$C$1674;"F") /ANZAHL($C$3:$C$1674)

GrußformelHomepage

  

Betrifft: AW: Excel 2013 Formeln von: 1713077.html
Geschrieben am: 14.09.2019 17:21:38

WENN($C$3:$C$1674;"F") DANN ????
Den Befehl "DANN" kenne ich noch nicht.
Google doch mal "Excel Wenn".

  

Betrifft: AW: Excel 2013 Formeln von: 1713123.html
Geschrieben am: 14.09.2019 20:05:29

Anfrage gelöst
allen Beteiligten mein Herzlichen Dank
Dieter

  

Betrifft: AW: Excel 2013 Formeln von: 1713078.html
Geschrieben am: 14.09.2019 17:29:37

Hallo Hajo,
geht nicht, Ergebnist - #DIV/0! -

  

Betrifft: AW: Excel 2013 Formeln von: 1713079.html
Geschrieben am: 14.09.2019 17:34:05

Dazu kann ich nichts schreiben, was wohl daran liegt das ich nicht auf fremde Rechner Schaue.

Gruß Hajo

  

Betrifft: AW: Excel 2013 Formeln von: 1713116.html
Geschrieben am: 14.09.2019 19:36:49

Hallo Hajo,
sorry es fehlt die 2
=ZÄHLENWENN($C$3:$C$1674;"F") /ANZAHL($C$3:$C$1674)
=ZÄHLENWENN($C$3:$C$1674;"F") /ANZAHL2($C$3:$C$1674)
schönen Gruß
Dieter

  

Betrifft: AW: Excel 2013 Formeln von: 1713122.html
Geschrieben am: 14.09.2019 20:04:48

Anfrage gelöst
allen Beteiligten mein Herzlichen Dank
Dieter

  

Betrifft: AW: Excel 2013 Formeln von: 1713080.html
Geschrieben am: 14.09.2019 17:40:12

Auch wenn sich hier der echte Neuling zeigt, sollten wir doch bereit sein, weiterzuhelfen... ;-)

Also:
Die Zahlen hast Du ja alle schon ermittelt. Der Rest ist Prozentrechnung:
Anteil der Damen = Zahl der Damen/Mitgliederzahl
Anteil der Herren = Zahl der Herren/Mitgliederzahl
Anteil der Aktiven = Zahl der Aktiven/Mitgliederzahl

Mit Deinen Zellbezügen müsste das dann für die Damen heißen:

=zählenwenn($C$3:$C$1674;"F")/anzahl($C$3:$C$1674;"F")

Der Teil mit "zählenwenn" liefert die Zahl der Damen, der Teil mit "anzahl" die Gesamtmitgliederzahl, das / dazwischen sorgt für das Teilen der beiden Zahlen. Wenn nun die Zelle auf % gestellt ist, wie Du das nennst, dann wird auch ein Prozentsatz dabei herauskommen.
Gruß
Werner

  

Betrifft: AW: Excel 2013 Formeln von: 1713082.html
Geschrieben am: 14.09.2019 17:45:51

...und mach mal aus "anzahl" stattdessen "anzahl2", dann klappt das auch.

Der Befehl "anzahl" zählt nur Zellen, die eine Zahl als Inhalt haben. Solche hast Du da nicht, daher kommt Null als Wert und damit die Fehlermeldung mit dem Teilen durch Null.

"anzahl2" zählt dagegen alle nichtleeren Zellen, egal was sie enthalten. Damit klappts.

Gruß
Werner

  

Betrifft: AW: Excel 2013 Formeln von: 1713098.html
Geschrieben am: 14.09.2019 18:44:30

Ergebnis
27,40%
71,23%
97,30%
ist nicht richtig

müsste sein
27,78%
72,22%
50,00%

  

Betrifft: AW: Excel 2013 Formeln von: 1713092.html
Geschrieben am: 14.09.2019 18:29:03

Hallo Werner, danke für dein Verständnis

ich habe die Datei auf 72 Mitglieder reduziert, der besseren übersichtshalber

also bei deiner Formel kommt als Ergebnis
#DIV/0!

die Ergebnisse missten sein
20 Damen : 72 = 27,78%
52 Herren : 72 = 72,22%
36 aktive : 72 =50,00%

Also:
in Spalte C steht ein F (für Frau oder Damen) und ein M (für Mann oder Herren)
in Spalte D steht ein X für aktive Damen u Herren
die Formel habe ich für angepasst
=ZÄHLENWENN($C$3:$C$74;"F")/ANZAHL($C$3:$C$74;"F")
=ZÄHLENWENN($C$3:$C$74;"M")/ANZAHL($C$3:$C$74;"M")
=ZÄHLENWENN($C$3:$D$74;"X")/ANZAHL($D$3:$D$74;"X")

Gruß Dieter

  

Betrifft: Crossposting wird nicht gerne gesehen von: 1713083.html
Geschrieben am: 14.09.2019 17:47:03

aber wenn du es machst, solltest du trotzdem alle Foren, in denen du die Frage gestellt hast, im Auge behalten und auf Antworten reagieren.
Vor allem wenn du die Frage neu ein einem anderen Forum stellst, NACHDEM du im alten Forum eine Antwort bekommen hast, ist das extrem unhöflich, weil du damit dem Antworter im anderen Forum signalisierst, dass dich seine Antwort nicht interessiert und du sie bewusst ignorierst.
Damit macht man sich keine Freunde.
Gruß Daniel

  

Betrifft: AW: Crossposting wird nicht gerne gesehen von: 1713095.html
Geschrieben am: 14.09.2019 18:36:29

Hallo Daniel,

da hast du recht
ich behalte auch alle im Auge
und vor allem reagieren ich.auf Antworten

schöne Grüsse
Dieter

  

Betrifft: AW: Crossposting wird nicht gerne gesehen von: 1713097.html
Geschrieben am: 14.09.2019 18:40:14

Hola,

http://www.office-loesung.de/p/viewtopic.php?f=166&t=816850

Gruß,
steve1da

  

Betrifft: AW: Crossposting wird nicht gerne gesehen von: 1713108.html
Geschrieben am: 14.09.2019 19:17:29

naja, in dem Fall hatte ich dir um 16:15 MESZ geantwortet und du hast hier ne Stunde später die Frage erneut gestellt, ohne dort zu reagieren.
In diesem fall stimmt das, das du über dich sagst, leider nicht.
Gruß Daniel

  

Betrifft: AW: Crossposting wird nicht gerne gesehen von: 1713113.html
Geschrieben am: 14.09.2019 19:24:42

wo hattest du geanwortet??

  

Betrifft: AW: Crossposting wird nicht gerne gesehen von: 1713114.html
Geschrieben am: 14.09.2019 19:27:51

ich dachte, du hast deine Foren im Griff?
du solltest doch wissen, wo du die frage überall gestellt hast.
um dein Gedächstnis aufzufrischen, nutze den Link von SF.
allerdings habe ich den Inhalt des Beitrags entfernt, da mich dein Verhalten aus den genannten Gründen ärgert.
Gruß Daniel

  

Betrifft: AW: Crossposting wird nicht gerne gesehen von: 1713119.html
Geschrieben am: 14.09.2019 19:47:54

"gelöscht"
das hatte ich gesehen
woher soll ich das Riechen, warum du gelöscht hast
ich werde dein Unmut mir zu Herzen nehmen

nichts Böses wollte ich, nur eine schnelle Lösung

  

Betrifft: AW: Crossposting wird nicht gerne gesehen von: 1713121.html
Geschrieben am: 14.09.2019 19:55:37

du hättest halt nochmal schauen müssen, bevor du die Frage hier gestellt hast, dann hättest du auch die ursprüngliche Antwort gesehen.

Gruß Daniel

  

Betrifft: AW: Crossposting wird nicht gerne gesehen von: 1713115.html
Geschrieben am: 14.09.2019 19:29:30

auch unter Daniel ??

  

Betrifft: AW: Crossposting wird nicht gerne gesehen von: 1713117.html
Geschrieben am: 14.09.2019 19:39:27

Namen sind Schall und rauch.
Wer, ist auch egal.
Du hattest eine Antwort dort bekommen, und später hier erneut gefragt, ohne dort vorher auf die Antwort zu reagieren, obwohl genügend Zeit dazwischen lag.
das ist - höflich forumuliert - dem dortigen Antworter gegenüber sehr unhöflich.
Gruß Daniel

  

Betrifft: AW: Excel 2013 Formeln von: 1713103.html
Geschrieben am: 14.09.2019 19:04:19

Hallo Dieter,
ich weiß nicht, ob Du Dein Problem schon gelöst hast, aber hier kommt mein Hinweis, wo in Deinen Formeln das Problem liegt:

Du hast im hinteren Teil bei der Anzahl
1. nicht Anzahl2 benutzt (das ist nötig, damit Du alle nichtleeren Zellen zählst)
2. zusätzlich eine Bedingung mit Semikolon eingefügt. Das führt zu falschen Ergebnissen. Schreibe in die Klammer hinter Anzahl2 einfach nur den zu untersuchenden Zellbereich. Dann klappt das auch.

=ZÄHLENWENN($C$3:$C$74;"F")/ANZAHL2($C$3:$C$74)
=ZÄHLENWENN($C$3:$C$74;"M")/ANZAHL2($C$3:$C$74)
=ZÄHLENWENN($D$3:$D$74;"X")/ANZAHL2($D$3:$D$74)

In der letzten Zeile zählst Du aus unerfindlichen Gründen auch die Spalte C mit. Das macht zwar nix, weil dort vermutlich keine X stehen werden, ergibt aber keinen Sinn, sollte man also ändern, um die Formeln verständlich zu halten.

Gruß
Werner

  

Betrifft: AW: Excel 2013 Formeln von: 1713109.html
Geschrieben am: 14.09.2019 19:22:12

so:
ich hatte noch keine Lösung

- unerfindlichen Gründen auch die Spalte C mit - war mein Eingabefehler

die beiden ersten Formeln geben jetzt das Richtige Ergebnis wieder super

aber die dritte nicht
=ZÄHLENWENN($D$3:$D$74;"X")/ANZAHL2($D$3:$D$74)
Ergebnis 100,00%
es haben ja nur 36 Personen ein X, bei den restlichen steht nichts

  

Betrifft: AW: Excel 2013 Formeln von: 1713118.html
Geschrieben am: 14.09.2019 19:43:34

Hi, da die nicht mit "X" gefüllten Zeilen leer sind und durch Anzahl2 nicht erfasst werden, stimmen die 100%. Du müstest Anzahl2 beispielsweise auf die Spalte C beziehen, da dort ja garantiert für jeds Mitglied ein Wert steht:
=ZÄHLENWENN($D$3:$D$74;"X")/ANZAHL2($C$3:$C$74)


Gruß
Regina

  

Betrifft: AW: Excel 2013 Formeln von: 1713125.html
Geschrieben am: 14.09.2019 20:08:39

Hallo Regina,
das wars, Danke
Anfrage gelöst
allen Beteiligten mein Herzlichen Dank
Dieter

  

Betrifft: AW: Excel 2013 Formeln von: 1713124.html
Geschrieben am: 14.09.2019 20:07:23

Hallo Werner,
Anfrage gelöst
allen Beteiligten mein Herzlichen Dank
Dieter

  

Betrifft: ist doch logisch von: 1713126.html
Geschrieben am: 14.09.2019 20:11:24

wenn da 36 mal X steht und der Rest leer ist, ergibt ANZAHL2 36

WF

Beiträge aus dem Excel-Forum zum Thema "Excel 2013 Formeln"