Microsoft Excel

Herbers Excel/VBA-Archiv

Hilfe! Doppelte Werte entfernen


Betrifft: Hilfe! Doppelte Werte entfernen von: RS
Geschrieben am: 17.09.2019 11:47:22

Guten Tag,

ich hoffe ihr könnt mir helfen am besten schaut ihr euch die Datei an, da ich es nicht so einfach erklären kann :).

In Spalte A habe ich alle meine Artikelnummern, Spalte B Datum; Spalte C EK´s.
Ich würde gerne in Spalte A nur einmal die Artikelnummer haben, also quasi im Querformat.

https://www.herber.de/bbs/user/132070.xlsx

Siehe Datei.

Vielen Dank vorab.

  

Betrifft: AW: Hilfe! Doppelte Werte entfernen von: 1713443.html
Geschrieben am: 17.09.2019 11:53:29

Moin,

zum Probieren ist deine Muster-xlsx nicht geeignet.
Du bist zu faul, realistische kalendarische Daten in Spalte_B einzutragen, dann bin ich zu faul, deine Arbeit zu machen und dann noch eine Lösung zu liefern.

Gruß
Günther

  

Betrifft: AW: Hilfe! Doppelte Werte entfernen von: 1713456.html
Geschrieben am: 17.09.2019 12:32:52

Moin Günter,

danke vorab für dein Feedback, anbei mit Datum und xls Formatierung(Ist die besser?).

https://www.herber.de/bbs/user/132073.xls

  

Betrifft: parallele Auflistung - Arrayformel von: 1713475.html
Geschrieben am: 17.09.2019 14:43:16

Hi,

schreib in G3 folgende Arrayformel:
{=WENNFEHLER(INDEX($B:$C;KKLEINSTE(WENN($A$1:$A$99=$F3;ZEILE(X$1:X$99));RUNDEN(SPALTE(A1)/2;0)); 1+ISTGERADE(SPALTE()));"") }
nach rechts und nach unten kopieren

Die Spalten entsprechend formatieren; Datum / Standard

WF

Ob in Spalte B ein richtiges Datum, oder Unsinn steht, ist natürlich egal.

  

Betrifft: AW: parallele Auflistung - Arrayformel von: 1713529.html
Geschrieben am: 17.09.2019 18:05:32

Moin,
ich wollte mich zumindest noch einmal gemeldet haben (der Anstand gebietet es). Du hast jetzt offensichtlich eine vernünftige Lösung. Meine wäre gewiss aufwendiger und könnte deine Vorgabe nicht zu 100% erfüllen, da eine korrekte (Kreuz)Tabelle nicht mehrere gleiche/identische Überschriften haben darf.

Gruß
Günther

  

Betrifft: AW: (m)eine alternative Formellösung ... von: 1713548.html
Geschrieben am: 17.09.2019 21:18:15

Hallo,

... ist zwar etwas länger als die von WF, hat jedoch dafür mE folgende Vorteile, abgesehen davon, dass sie ohne denspez. Matrixformalabschluss auskommt.

- Die Quelldaten in A:B Deines Tabellenblattes sind nicht nach Datum sortiert (was Du natürlich einfach nachholen könntest) und werden mit der Formel WF (entsprechend Deiner Vorgabe) auch 1:1 in der unsortierten Reihenfolge in der Ergebnistabelle angeordnet. Wenn Du das so haben willst, müsste ich meine Formel dafür noch anpassen. Mit meiner Formel werden die Datumsangaben von links nach rechst aufwärts sortiert gelistet.

- Bei meiner Tabelle kannst Du auch nachträglich eine Datenstrukturänderung derart vornehmen, dass Du z.B. vor Spalte F eine Spalte löschst oder einfügst ohne dass Du die Formel anpassen musst.

- durch die zusätzliche bedingte Formatierung, musst Du nicht nachträglich die Preisformate wieder anpassen, wenn Du die Formel G3 nach rechts und unten ziehend kopierst:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJKLMNOP
2ArtikelNr.DatumPreis  ArtikelNr.DatumPreisDatumPreisDatumPreisDatumPreisDatumPreis
3109.07.20181  111.08.20161,1118.08.20161,0208.05.20171,1909.07.20181,0006.05.20191,20
4106.05.20191,2  229.08.201610,0022.10.201811,00      
5111.08.20161,11  318.08.201615,0010.09.201816,0022.10.201810,0007.01.201912,00  
6108.05.20171,19  410.09.201819,0007.01.201910,00      
7118.08.20161,02  507.01.20195,0008.04.20194,0006.05.20197,00    
8229.08.201610  618.08.20161,00        
9222.10.201811             
10307.01.201912             
11318.08.201615             
12322.10.201810             
13310.09.201816             
14407.01.201910             
15410.09.201819             
16507.01.20195             
17508.04.20194             
18506.05.20197             
19618.08.20161             
20                

ZelleFormatWert
G3TT.MM.JJJJ;;11.08.2016

ZelleFormel
G3=WENNFEHLER(WENN(G$2=$H$2;VERWEIS(9;1/($A$1:$A$99=$F3)/($B$1:$B$99=F3);$C:$C);AGGREGAT(15;6;$B$3:$B$99/($A$3:$A$99=$F3);ZÄHLENWENN($F$2:G$2;G$2)));"")

Zellebedingte Formatierung...Format
G31: G$2="Preis"abc
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Gruß Werner
.. , - ...




  

Betrifft: AW: (m)eine alternative Formellösung ... von: 1713795.html
Geschrieben am: 19.09.2019 09:23:55

Vielen Dank :)

Beiträge aus dem Excel-Forum zum Thema "Hilfe! Doppelte Werte entfernen "