Microsoft Excel

Herbers Excel/VBA-Archiv

Zellen aus Liste in Spalten korrekt umsortieren


Betrifft: Zellen aus Liste in Spalten korrekt umsortieren von: Stefan Fackler
Geschrieben am: 18.09.2019 09:04:21

Hallo,

ich habe eine Liste mit Artikelnummern und Bildernamen, welche untereinander stehen.
Es gibt je Artikelnummer unterschiedlich viele Bildernamen und somit Zeilen, die Artikelnummer kommt somit öfter vor (Spalte A) und die Bildernamen (Spalte B) kommen jeweils nur einmal vor.

Ich bräuchte jedoch je Artikel eine Zeile mit den vorkommenden Bildernamen, die Bildernamen sollten dann in den Spalten B/C/D/usw. stehen.

IST:
ALMA ALMA_29_MLTD_FondoGris.jpg
ALMA ALMA_29_MLTD_FondoGrisV.jpg
CARP CARPE_25_FondoGris SF.jpg
CARP CARPE_25_FondoGrisV SF.jpg
GAIN GAIN_D20FondoGris SF.jpg
GAIN GAIN_D20FondoGrisV SF.jpg
GAIN GAIN_M10iFondoGris SF.jpg
GAIN GAIN_M10iFondoGrisV SF.jpg

SOLL:
ALMA ALMA_29_MLTD_FondoGris.jpg ALMA_29_MLTD_FondoGrisV.jpg
CARP CARPE_25_FondoGris SF.jpg CARPE_25_FondoGrisV SF.jpg
GAIN GAIN_D20FondoGris SF.jpg GAIN_D20FondoGrisV SF.jpg
GAIN_M10iFondoGris SF.jpg GAIN_M10iFondoGrisV SF.jpg

Die Bilder kommen zwischen 1 und 9 mal vor.

Irgendwie finde ich keinen Lösungsansatz und würde mich über Hilfe freuen!

  

Betrifft: AW: Zellen aus Liste in Spalten korrekt umsortieren von: 1713590.html
Geschrieben am: 18.09.2019 09:08:45

Hola,

und woher wissen wir was zum Artikelnamen gehört und was zum Bildnamen? Wo werden die getrennt?

Gruß,
steve1da

  

Betrifft: AW: Zellen aus Liste in Spalten korrekt umsortieren von: 1713595.html
Geschrieben am: 18.09.2019 09:29:33

Sorry, das kommt im Post nicht ganz rüber.

Spalte A
ALMA

Spalte B
ALMA_29_MLTD_FondoGris.jpg

Die ersten 4 Buchstaben unter IST sind jeweils Spalte A, und der Name des Bildes daneben.

Kann ich das besser darstellen im Forum?

  

Betrifft: AW: Zellen aus Liste in Spalten korrekt umsortieren von: 1713601.html
Geschrieben am: 18.09.2019 09:38:55

Hola,

=WENNFEHLER(INDEX(Tabelle4!$B:$B;AGGREGAT(15;6;ZEILE(Tabelle4!$B$2:$B$9)/(Tabelle4!$A$2:$A$9=$A2); SPALTE(A1)));"")

In A2, A3, A4....stehen die Artikelnamen. Die Formel dann nach rechts und nach unten ziehen.

Gruß,
steve1da

  

Betrifft: AW: Zellen aus Liste in Spalten korrekt umsortieren von: 1713603.html
Geschrieben am: 18.09.2019 09:54:37

Wow, das funktioniert ja super genial!
Vielen Dank für Deine schnelle Hilfe

Beiträge aus dem Excel-Forum zum Thema "Zellen aus Liste in Spalten korrekt umsortieren"