Microsoft Excel

Herbers Excel/VBA-Archiv

Auswerten wer wie oft


Betrifft: Auswerten wer wie oft von: Timo
Geschrieben am: 19.09.2019 07:16:20

Hallo zusammen,

ich würde gerne Auswerten wer innerhalb von einem Bestimmten Zeitraum wie oft bei "A" war und wer bei "B".
Dabei sollen aber nur die Aufgelistet werden die dort waren und nicht alle.
z.B.:
......"Name"....."Anzahl"
501.:...E.........4
..........B.........2
..........F.........6
519.:...A.........2
..........C.........1
..........G.........7

https://www.herber.de/bbs/user/132104.xlsx

Gruß und Vielen Dank Timo

  

Betrifft: AW: Auswerten wer wie oft von: 1713838.html
Geschrieben am: 19.09.2019 11:11:25

Moin,

keine Ahnung, ob du dieses Ergebnis haben willst ... (mit PQ berechnet)

Spalte1	Wert	Anzahl
    501	D	4
    501	E	3
    501	A	10
    501	B	6
    501	H	7
    519	X	8
    519	Y	9
    519	Z	7
    519	W	6
Gruß
Günther
  

Betrifft: AW: Auswerten wer wie oft von: 1713846.html
Geschrieben am: 19.09.2019 11:45:42

Hi Timo

Hier mein Formel-Gewurstel...
https://www.herber.de/bbs/user/132110.xlsx

Bedingt, dass es im 3 Zeilen und 1 Leerzeile pro Nummer sind.

=ZÄHLENWENN(INDEX(Tabelle1!$A:$L;ZEILE(A1)*4-2;$AD$2-DATUM(2019;1;1)+3):INDEX(Tabelle1!$A:$L; ZEILE(A1)*4;$AD$3-DATUM(2019;1;1)+3);B$1)

cu
Chris

  

Betrifft: AW: Auswerten wer wie oft von: 1713926.html
Geschrieben am: 19.09.2019 14:59:49

Hi Chris

Vielen Dank für deine Hilfe :-)


Gruß Timo

  

Betrifft: AW: Auswerten wer wie oft von: 1713863.html
Geschrieben am: 19.09.2019 12:27:04

Hallo Günther

Ja genau so habe ich mir das vorgestellt.
Was ist denn PQ ?

Gruß Timo

  

Betrifft: AW: Auswerten wer wie oft von: 1713896.html
Geschrieben am: 19.09.2019 14:12:01

Moin Timo,

PQ ist die zwischenzeitlich häufig gebrauchte Abkürzung von Power Query, einem Tool für/in Excel. In Excel-2010/13 ein kostenloses Add-In, ab 2016/365 unter dem Stichwort Daten | Abrufen und transformieren integriert. Die von mir erstelle Datei findest du hier: https://www.herber.de/bbs/user/132116.xlsx

Allgemeines zu Power Query: http://www.excel-ist-sexy.de/kategorie/power-query/basics-pqq/

Stichwortartig die Vorgehensweise:
* Import der Daten in PQ
* Leere Zeilen entfernen
* Spalte1 nach unten auffüllen
* Entpivotieren (Basis-Wissen dazu: http://www.excel-ist-sexy.de/vorbereitung-fuer-pivot-unvorteilhafte-quelldaten/)
* Datum (Text) zu Datum (Datum) umwandeln
* Gruppieren nach Spalte1
* Schließen & laden, um die Daten in ein Arbeitsblatt zu bringen.

Gruß
Günther

  

Betrifft: AW: Auswerten wer wie oft von: 1713924.html
Geschrieben am: 19.09.2019 14:58:14

Vielen Dank Günther für die Hilfe und Erklärung.

Gruß Timo

  

Betrifft: AW: Auswerten wer wie oft von: 1713925.html
Geschrieben am: 19.09.2019 14:58:17

Vielen Dank Günther für die Hilfe und Erklärung.

Gruß Timo

Beiträge aus dem Excel-Forum zum Thema "Auswerten wer wie oft "