Microsoft Excel

Herbers Excel/VBA-Archiv

Formel Datum


Betrifft: Formel Datum von: Sebastian
Geschrieben am: 19.09.2019 08:13:13

Guten morgen ,

wir haben in D13 eine Formel:
=WENN($C13<>"";JAHR(HEUTE())-JAHR($C13);"")

Wir geben das Eintrittsdatum ein und dann kommt bei über ein Jahr eine 1 raus.Anschließend haben wir die komplette spalte mit Zellenformation hinterlegt 0 "Jahre" somit steht 1 Jahr drin.

Wir wollen aber, wenn es unter ein Jahr ist, das dann steht 8 Monate. Wie würde das gehen ?

  

Betrifft: AW: Formel Datum von: 1713800.html
Geschrieben am: 19.09.2019 09:32:25

Hallo Sebastian,

z.B. so:

=WENN($C13<>"";WENN(DATEDIF($C13;HEUTE();"Y")<1;DATEDIF($C13;HEUTE();"M") & " Monat"&WENN(DATEDIF($C13;HEUTE();"M")>1;"e";"");DATEDIF($C13;HEUTE();"Y") &" Jahr"&WENN(DATEDIF($C13;HEUTE();"Y")>1;"e";""));"")

Zellen als Standard formatieren; die Formel ergibt einen Text

Gruß Rolf

  

Betrifft: die reinen .. Formel Datum von: 1713805.html
Geschrieben am: 19.09.2019 09:37:44


Hallo Sebastian,

die Monate dazwischen kannst Du schon mal mit

=datedif(A2; A3; "M")

abfragen, Gruss Mike

Beiträge aus dem Excel-Forum zum Thema "Formel Datum"