Microsoft Excel

Herbers Excel/VBA-Archiv

Doppelte Beiträge in Liste nur einmal auswählen


Betrifft: Doppelte Beiträge in Liste nur einmal auswählen von: Bernd Kuropka
Geschrieben am: 20.09.2019 09:41:30

Moin zusammen,

ich habe eine Datei in der in der Spalte R und in der Spalte W Artikel aufgeführt sind. Diese Artikel können mehrmals erscheinen. Ich brauche aber jeweils immer nur einmal den Artikel und die Anzahl des Erscheinens:

Beispiel:
a
b
a
v
d
e
e
g
g
h

Daraus soll in der Spalte AA,AB (für Spalte R) und AC;AD für Spalte W folgendes werden :
a 2
b 1
v 1
d 1
e 2
g 2
h 1

Für eure Hilfe wäre ich sehr dankbar, liebe Leute.

Gruß der Bernd

  

Betrifft: AW: Doppelte Beiträge in Liste nur einmal auswählen von: 1714045.html
Geschrieben am: 20.09.2019 10:07:16

Hallo

Einfach mit Duplikate entfernen arbeiten ...

Tabelle1

 ABC
1a2a2
2b1b1
3a2a2
4v1v1
5d1d1
6e2e2
7e2e2
8g2g2
9g2g2
10h1h1

Formeln der Tabelle
ZelleFormel
B1=ZÄHLENWENN($A$1:$A$10;A1)
C1=A1&B1
B2=ZÄHLENWENN($A$1:$A$10;A2)
C2=A2&B2
B3=ZÄHLENWENN($A$1:$A$10;A3)
C3=A3&B3
B4=ZÄHLENWENN($A$1:$A$10;A4)
C4=A4&B4
B5=ZÄHLENWENN($A$1:$A$10;A5)
C5=A5&B5
B6=ZÄHLENWENN($A$1:$A$10;A6)
C6=A6&B6
B7=ZÄHLENWENN($A$1:$A$10;A7)
C7=A7&B7
B8=ZÄHLENWENN($A$1:$A$10;A8)
C8=A8&B8
B9=ZÄHLENWENN($A$1:$A$10;A9)
C9=A9&B9
B10=ZÄHLENWENN($A$1:$A$10;A10)
C10=A10&B10


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

C1:C10 Formeln durch Werte ersetzen und dann Duplikate entfernen.
Natürlich Deine Spalten anpassen.

Gruß Matthias
  

Betrifft: AW: Doppelte Beiträge in Liste nur einmal auswählen von: 1714064.html
Geschrieben am: 20.09.2019 11:16:47

Moin,
oder mit weniger als 5 Mausklicks per Power Query (Gruppieren) ... ;-)

Gruß
Günther

  

Betrifft: Ja, konnte ich nachvollziehen ... von: 1714104.html
Geschrieben am: 20.09.2019 14:57:29

Hallo Günther

Gute Idee ...

Hab es getestet und konnte alles nachvollziehen.
Gefällt mir sogar besser als mein Vorschlag :-)

Gruß Matthias

  

Betrifft: AW: Doppelte Beiträge in Liste nur einmal auswählen von: 1714096.html
Geschrieben am: 20.09.2019 14:12:31

Moin liebe Leute,

manchmal ist das Leben sooo einfach, man muss es nur begreifen.... War da wohl echt vernagelt.....

Lieben Dank für eure Hilfe....

Beiträge aus dem Excel-Forum zum Thema "Doppelte Beiträge in Liste nur einmal auswählen"