Microsoft Excel

Herbers Excel/VBA-Archiv

Zahlenwerte zählen ab bestimmter Zahl


Betrifft: Zahlenwerte zählen ab bestimmter Zahl von: Niklas B.
Geschrieben am: 25.09.2019 15:55:37

Hallo zusammen,

ich würde gerne (am liebsten als Excel-Formel) die 0-en zählen, die nach der letzten 1 in einer Zahlenreihe (aus 0en und 1en bestehend) kommen:

1 0 0 1 0 0

Heißt:
Ich möchte, dass die Formel "2" ausgibt, da nach der letzten 1 zwei 0-en stehen.

Kriegt man das mit einer Excel Formel hin oder brauche ich dafür vba (falls nur mit vba möglich: wie?)

VG Niklas

  

Betrifft: AW: Zahlenwerte zählen ab bestimmter Zahl von: Matthias
Geschrieben am: 25.09.2019 16:51:41

Moin!
Schau mal hier:
http://www.excelformeln.de/formeln.html?welcher=108

MIt der letzten Formel und dem Zusatz darunter solltest es klappen.
VG


  

Betrifft: die letzten Nullen zählen von: WF
Geschrieben am: 25.09.2019 16:52:02

Hi,

=ZÄHLENWENN(INDEX(A1:Z1;VERWEIS(2;1/(A1:Z1<>0);SPALTE(A1:Z1))):Z1;0)

WF


  

Betrifft: AW: Zahlenwerte zählen ab bestimmter Zahl von: Matthias
Geschrieben am: 25.09.2019 16:54:06

Hab's nochmal getestet:
So sollte die Formel funktionieren:
=LÄNGE(A1)-VERWEIS(9^9;FINDEN(1;A1;SPALTE(1:1)))

Dein Test steht in A1
VG


  

Betrifft: AW: Zahlenwerte zählen ab bestimmter Zahl von: Niklas B.
Geschrieben am: 25.09.2019 17:12:54

Da bekomme ich nur den Fehler #N/A.
Die Zahlenreihe steht in A1:A6.


  

Betrifft: dito in Spalte A von: WF
Geschrieben am: 25.09.2019 17:32:27

=ZÄHLENWENN(INDEX(A1:A99;VERWEIS(2;1/(A1:A99<>0);ZEILE(X1:X99))):A99;0)

WF


  

Betrifft: AW: dito in Spalte A von: Niklas B.
Geschrieben am: 25.09.2019 18:45:19

Perfekt, jetzt funktioniert's.

Danke und LG!


  

Betrifft: AW: dito in Spalte A von: Niklas B.
Geschrieben am: 25.09.2019 18:45:49

Perfekt, jetzt funktioniert's.

Danke und LG!


  

Betrifft: AW: dito in Spalte A von: Niklas B.
Geschrieben am: 25.09.2019 18:51:04

Perfekt, jetzt funktioniert's.

Danke und LG!


Beiträge aus dem Excel-Forum zum Thema "Zahlenwerte zählen ab bestimmter Zahl"