Microsoft Excel

Herbers Excel/VBA-Archiv

Formelproblem


Betrifft: Formelproblem von: Kurt
Geschrieben am: 30.09.2019 21:53:42

Hall0,
nah langer Zeit habe ich mal wieder ein Problem, bei dem ich scheitere.
Ich möchte aus einer Zelle z.B. A3 einen Wert in B3 übernehmen, wenn eine oder mehrere der drei folgenden Fälle eintreten.
Bedingung 1: Wert 1 zwischen 5 und 10
Bedingung 2: Wert 2 zwischen 15 und 20
Bedingung 3: Wert 3 zwischen 25 und 30

Ich bekomme das Ergebnis nicht in eine Formel.

  

Betrifft: AW: Formelproblem von: Manuel
Geschrieben am: 30.09.2019 22:03:41

Hallo Kurt

Mit der Annahme, dass Wert 1 in A1, Wert 2 in B1 und Wert 3 in C1 steht, sollte diese Formel funktionieren.

=WENN(ODER(UND(A1>5;A1<10);UND(B1>15;B1<20);UND(C1>25;C1<30));A3;"")
Bei den Extremalwerten wird "" angezeigt.

Die Formel funktioniert so, dass mindestens eine der drei Bedingungen WAHR sein muss. (Wird mit ODER geprüft.) Da deine Bedinungen wiederum aus zwei Teilen bestehen, wird jede Bedingung mit einem UND geprüft.

Freundliche Grüsse

Manuel


  

Betrifft: ohne UND - ohne ODER von: WF
Geschrieben am: 30.09.2019 22:47:13

=WENN((A1>5)*(A1<10)+(B1>15)*(B1<20)+(C1>25)*(C1<30);A3;"")

WF


  

Betrifft: AW: Formelproblem von: Kurt
Geschrieben am: 30.09.2019 23:06:15


Hallo Manuel, erst mal vielen dank für Deine prompte Antwort. Ich habe die Prinzipformel an meine konkreten Bedingungen angepasst, da mein Fragebeispiel nur das Prinzip klären sollte.
Konkret ist folgendes:

=WENN(ODER(UND(Service!D$10>EJ4;EJ4EJ4; EJ4EJ4;EJ4
Wert D10 im Arbeitsblatt Service ist 2; Wert D12 ist 3
Wert D14 im Arbeitsblatt Service ist 7; Wert D16 ist 4
Wert D18 im Arbeitsblatt Service ist 16; Wert D12 ist 3

Wenn ich die Formel fortlaufend in die Spalte EJ eintrage, werden aber durchlaufend alle Werte ausgegeben, obwohl zwischen den ersten beiden Bedingungen ein Wert ausgelassen werden müßte. Wo mache ich den Denkfehler?