Microsoft Excel

Herbers Excel/VBA-Archiv

suche Formel: identisch mit 4 werten


Betrifft: suche Formel: identisch mit 4 werten von: ray
Geschrieben am: 01.10.2019 14:34:20

Hallo,

ich möchte in einer Zeile 4 Spalten (B2, U2, Z2 und AE2)abfragen, ob eine Zahl mehrfach vorhanden ist, aber nur in dieser Zeile.

Das:

=WENN(UND(IDENTISCH(U2;Z2));"";"nicht ")&"identisch"

funktioniert leider nur mit zwei Spalten.

Wie kann ich das lösen?


Viele Grüße aus Hamburg

Ray

  

Betrifft: AW: suche Formel: identisch mit 4 werten von: Pierre
Geschrieben am: 01.10.2019 15:12:41

Hallo Ray,

Es ist egal, welche Zahl mehrfach vorkommt?
Es ist egal, wie oft die Zahl dann vorkommt? Ob 2 oder 3 oder gar 4 Mal?

Dann reicht das:

=WENN(ODER(B2=U2;B2=Z2;B2=AE2;U2=Z2;U2=AE2;Z2=AE2);"ja";"nein")
Gruß Pierre


  

Betrifft: AW: suche Formel: identisch mit 4 werten von: ray
Geschrieben am: 01.10.2019 15:18:49

Moin Pierre,

ja ist egal, mit Wenn und oder hab ich auch probiert, dachte aber es geht vielleicht kürzer...

Vielen Dank und Grüße
Ray


Beiträge aus dem Excel-Forum zum Thema "suche Formel: identisch mit 4 werten"