Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Wenn Feld leer, dann Auswahlliste

Wenn Feld leer, dann Auswahlliste
02.10.2019 10:59:00
Jörg
Hallo zusammen,
mein Thema gab es an verschiedenen Stellen schon, aber ich habe es bisher nicht geschafft, es für meine Problemstellung zu adaptieren.
Somit bitte ich Euch um Hilfe.
Ich möchte folgendes:
1) Ich habe eine Tabelle mit Spaltenüberschriften und Darunter werden
zeilenweise Daten eingegeben.
2) Wenn nun ein Wert in Spalte E(z.B. E2) eingetragen wird, dann soll in der Zelle G2 eine sverweis-Funktion ausgeführt werden. Dieses Problem ist ja prinzipiell über die wenn-Funktion zusammen mit sverweis zu lösen.
3) Wenn aber in E2 "kein Wert" eingetragen wird, soll in G2 über ein Dropdownfeld eine Datenliste zur Auswahl angezeigt werden.
Ich bekomme das weder per Formel noch per VBA hin.
Kann mir hier jemand helfen?
Danke schon einmal im Voraus.
Jörg

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW:(D)eine Beispieldatei könnte hilfreich sein owT
02.10.2019 11:19:44
neopa
Gruß Werner
.. , - ...
AW: Wenn Feld leer, dann Auswahlliste
02.10.2019 11:49:11
Daniel
Hi
im Prinzip so mit zwei zusätzlichen Spalten.
ist etwas tricky, aber schaus dir mal an.
einziges Probelm ist, wenn der Anwender bei leerer Spalte E einen Wert in H einträgt und danach E befüllt. das müsste man ggf per Makro unterstützen und H per marko leeren.
https://www.herber.de/bbs/user/132331.xlsx
Gruß Daniel
AW: eine Möglichkeit dafür wäre...
02.10.2019 11:55:34
neopa
Hallo Jörg,
... leere die Zelle E2 und schreib folgende Formel in G2: =WENN(E2="";"";SVERWEIS(E2;$J$2:$K$9;2;0)) und zusätzlich die Datengültigkeit Liste mit der Formel: =WENN(E2="";"";SVERWEIS(E2;$J$2:$K$9;2;0)) Diese Zelle kopiere nach unten.
Jetzt kannst Du die Zellenwerte wieder füllen. Doch wisse, wenn Du für eine leere zelle in E eine Dropdownauswahl in Spalte G getroffen hast, wird dadurch die Zellformel in G gelöscht und kann somot keine Auswertung mehr für einen Spaltenwert in E vornehmen.
Gruß Werner
.. , - ...
Anzeige
AW: eine Möglichkeit dafür wäre...
02.10.2019 12:55:12
Jörg
Hallo Werner,
klasse - so funktioniert es - ich hatte es bereits ähnlich probiert, aber der Schlüssel ist die Formel in der Auswahlliste für das Dropdownfeld an "letzter" Stelle zu setzen.
Ev. kann man ja per VBA noch schreiben, wenn das Feld in Spalte E "aktiv gelöscht wird", in Spalte G wieder die alte Formel gesetzt wird. Bekommst Du das hin? Falls nicht - auch nicht so schlimm, aber Du hast mir spitzenmäßig gehofen. Tausend Dank auf alle Fälle.
Viele Grüße,
Jörg
AW: aus VBA-Lösungen halte ich mich heraus owT
02.10.2019 13:32:39
neopa
Gruß Werner
.. , - ...
AW: Wenn Feld leer, dann Auswahlliste
02.10.2019 11:40:00
Jörg
Ausversehen ins Archiv geschoben - ist aber noch offen

324 Forumthreads zu ähnlichen Themen


Hallo!
Ist es denn eigentlich möglich zu überprüfen ob eine Zelle gerade geleert wurde?
Hintergrund ist, dass ich gern sicherstellen möchte, dass der User wirklich den Zelleninhalt löschen wollte.
Ich würde gern eine Mitteilung erscheinen lassen wenn eine Zelle vom Inhalt her gelösc...
Anzeige

Hi,
ich möchte auf meinem Sheet abprüfen, ob die Zelle A41 und B41 leer sind, und wenn ja, soll eine Grafik (.bmp / wurde eingefügt mit Kopieren und einfügen und heisst im Namensfeld "Bild 01")
gelöscht oder unsichtbar werden.
Wie mache ich dies ?
Danke mal
Gruss
Tom<...

Guten Morgen,
wer kann mir beim folgenden Code eine kleine Änderung durchführen:
1.) das Makro sollte abgebrochen werden, wenn im Blatt "Daten" die Zelle "AB12" leer ist und
2.) es sollte eine MsgBox mit dem Hinweis kommen, dass die Eingabe bei "AB12" fehlt und das sollte mit OK bes...
Anzeige

Hallo Zusammen,
leider habe ich so ganz wenig Ahnung von VBA, weiß aber auch nicht wie ich mir sonst normal mit
Excel weiterhelfen könnte da es zuviele Daten sind.
Hab folgendes Problem, ich möchte gerne dass alle leeren Zellen in den Spalten B-D mit dem Inhalt der Zellen eine Zeile...

Moin,
auf der Arbeit soll ich eine Tabelle anpassen:
In Tabellenblatt1 ist eine Matrix M6:P109, in einigen Zeilen (Artikelnummern in loser Reihenfolge) stehen Werte, (die Artikel, die im Bürobestand fehlen) in den meisten nicht.
Die Zeilen, in denen Werte stehen, sollen nun in Tabel...

Hi,
wie kann ich denn prüfen , ob die Zelle B230 im Tabellenblatt "Umsatz" leer ist ?
(Wichtig, es ist nicht das Aktive Tabellenblatt)
Danke Dieter

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige