Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Summenprodukt ohne Duplikate mit Bedingung

Summenprodukt ohne Duplikate mit Bedingung
03.02.2020 00:21:40
Jürgen
Schönen guten Abend,
ich hoffe auf Hilfe bei einem Problem mit einer Summenproduktformel. Ich möchte gerne die Planwerte für Sales Orders im folgenden Beispiel aufaddieren, wobei Duplikate von der Summe ausgeschlossen werden sollen (Leerzeilen dazwischen sind möglich):
Position / Sales Order / Planwert SO / Wert ohne Duplikate
30 / 1234 / 10 / 10
30 / 1234 / 10 / 0
30 / 4532 / 5 / 5
40 / 2345 / 15 / 15
40 / 3342 / 7 / 7
50 / 6678 / 5 / 5
50 / 6678 / 5 / 0
50 / 4345 / 3 / 3
Summe 60 / 45
Ich habe das Problem mit folgender Formel gelöst:
=SUMMENPRODUKT(N(VERGLEICH(""&B$1:B$99;""&B$1:B$99;)=ZEILE($1:$99));C$1:C$99)
Soweit so gut. Ich muss jedoch noch zusätzlich diese Selektion so einschränken, dass sie nur für Werte mit einer gleichen Positionsnummer, z.B. 30 gelten. Im Bsp. oben soll als Ergebnis für Pos. 30 also 15 herauskommen.
Meine Frage: Wie erweitere ich meine Formel, so dass ich auf das gewünschte Ergebnis komme?
Besten Dank im Voraus!
Jürgen

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Summenprodukt ohne Duplikate mit Bedingung
03.02.2020 07:28:27
Klaus
Hallo Jürgen,
ungetestet (gehe davon aus, Position 30 ist eine Zahl)
=SUMMENPRODUKT((N(VERGLEICH(""&B$1:B$99;""&B$1:B$99;)=ZEILE($1:$99)))*(C$1:C$99)*(A$1:A$99=30))
Wenn 30 keine Zahl, sondern ein String ist muss es in der Formel in " gesetzt werden.
LG,
Klaus
AW: Summenprodukt ohne Duplikate mit Bedingung
03.02.2020 07:55:06
Jürgen
Hallo Klaus,
besten Dank für die prompte Antwort. 30 ist tatsächlich eine Zahl.
Die Lösung funktioniert leider nicht (Wert Fehler). Vielleicht liegt das an den Leerzeilen?
Ich habe hier eine entsprechende Testdatei hochgeladen:
https://www.herber.de/bbs/user/134942.xlsx
Kannst Du bitte nochmal schauen? Vielen Dank
Anzeige
AW: Planwerte in den Vergleich mit einbeziehen ...
03.02.2020 08:10:46
neopa
Hallo Jürgen,
... in G2:
=WENN(ZÄHLENWENN(A2:A$3;A2)=1;SUMMENPRODUKT(N(VERGLEICH(B$1:B$99&C$1:C$99;B$1:B$99&C$1:C$99;)=ZEILE(A$1:A$99))*(A$1:A$99=A2);C$1:C$99);"")
und Formel nach unten kopieren
Gruß Werner
.. , - ...
AW: Planwerte in den Vergleich mit einbeziehen ...
03.02.2020 11:59:43
Jürgen
Hallo Werner,
genial! Das hilft mir sehr, besten Dank!!
Viele Grüße
Jürgen
AW: gerne owT
03.02.2020 14:13:50
neopa
Gruß Werner
.. , - ...

89 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige