Microsoft Excel

Herbers Excel/VBA-Archiv

Listenumwandlung- und -Sortierung

Betrifft: Listenumwandlung- und -Sortierung von: Bernd Kur
Geschrieben am: 07.03.2020 14:45:24

Moin zusammen,


habe da mal wieder ein Problem. Ich hoffe mal sehr, das mir hier jemand helfen wird.


Ich habe eine Aufstellung über die Spieltage unserer Mannschaften im Verein.

Dort stehen in der Spalte A & B die Schlüsselzahlen. Diese werden in den Spalten C & D mit Namen versehen.

Nun möchte ich folgendes:

Minimal:

Wenn ich in der Zelle C 22 die Nummer 1 eingebe, dann sollen alle Spiele dieses Vereins von oben nach unten, also in Abfolge der Spieltage aufgelistet werden. Die Krux an der Sache ist, das die ja meistens abwechselnd in der Spalte C oder der Spalte D auftauchen. Trotzdem soll der chronolgische Ablauf eingehalten werden (das ist das woran ich scheitere).


Maximal (Königslösung).

Wenn ich in der Zelle C29 die Nummer eingebe, dann soll das selbe wie bei Minimal geschehen, jedoch sollen in der Spalte A der Spieltag und in Spalte B das Datum angezeigt werden.


Ich hoffe mal, dass ich das klar und verständlich ausgedrückt habe und hoffe jetzt, das jemand dieses Rätsel lösen kann.

Ich bedanke mich schon einmal...


https://www.herber.de/bbs/user/135682.xlsx


LG Bernd

Betrifft: AW: z.B. mit 3 Formeln ...
von: neopa C
Geschrieben am: 07.03.2020 17:31:23

Hallo Bernd,

... für die Auswertung von C29 nutze ich nachfolgend bewusst konsequent VERGLEICH() anstelle SUMMENPRODUKT()

Basisformel ist Formel in Spalte B. Formeln A30:B30 nach unten und C30 zusätzlich nach rechts kopieren:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCD
1  25. Spieltag03.05.2020
2113Ma 1Ma 13
3212Ma 2Ma 12
4311Ma 3Ma 11
5410Ma 4Ma 10
659Ma 5Ma 9
768Ma 6Ma 8
8714Ma 7Ma 14
9    
10  26. Spieltag10.05.2020
11141Ma 14Ma 1
12132Ma 13Ma 2
13123Ma 12Ma 3
14114Ma 11Ma 4
15105Ma 10Ma 5
1696Ma 9Ma 6
1787Ma 8Ma 7
18    
29  11 
3025. Spieltag03.05.2020 Ma 11
3126. Spieltag10.05.2020Ma 11 
32    

ZelleFormel
A30=VERWEIS(9;1/(D$1:D$19=B30);C:C)&""
B30=WENN(ZEILE(A1)>ANZAHL(D$1:$D$19);"";KKLEINSTE(D$1:D$19;ZEILE(A1)))
C30=WENNFEHLER(INDEX(C:C;VERGLEICH($B30;$D:$D;0)-1+VERGLEICH($C$29; INDEX(A:A;VERGLEICH($B30;$D:$D;0)):INDEX(A:A;WENN($B31="";999;VERGLEICH($B31;$D:$D;0)));0));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Gruß Werner
.. , - ...

Betrifft: AW: z.B. mit 3 Formeln ...
von: Bernd Kur
Geschrieben am: 07.03.2020 18:47:34

Moin Werner,

irgendwie mache ich da wohl nicht das Richtige, denn so sieht es bei mir dann aus :-(.
Kannst du da bitte noch einmal drüber schauen . Danke

LG Bernd



Betrifft: AW: in Spalten C & D sollten Namen stehen ...
von: neopa C
Geschrieben am: 07.03.2020 18:55:46

Hallo Bernd,

... hattest Du eingangs geschrieben. Dafür hatte ich die Formeln aufgestellt. In Deinem neuen Beispiel stehen aber wieder nur Zahlenwerte. Wenn dem so sein soll(te), müsste die Formel in Spalte B dem angepasst werden. Was also gilt?

Gruß Werner
.. , - ...

Betrifft: AW: in Spalten C & D sollten Namen stehen ...
von: Bernd Kur
Geschrieben am: 07.03.2020 20:06:35

Moin Werner,

mit Namen / Buchstaben ergibt sich folgendes Bild..., da kommt der Buchstabe nicht...

LG Bernd



Betrifft: AW: kann so ja auch nicht, denn ...
von: neopa C
Geschrieben am: 09.03.2020 12:45:53

Hallo Bernd,

... jetzt hast Du in C29 ein "a" geschrieben, obwohl Du doch da die Schlüsselzahl 1 einschreiben wolltest. Wenn Du das tust, dann kommen auch Deine Textdaten (bei Dir die Buchstaben).

Gruß Werner
.. , - ...

Betrifft: AW: kann so ja auch nicht, denn ...
von: Bernd Kur
Geschrieben am: 09.03.2020 16:56:00

Ja klasse ! Manchmal bin ich aber ziemlich blöd...

Alles klar, jetzt läuft! Vielen lieben Dank !

Bernd

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 09.03.2020 17:28:37

Gruß Werner
.. , - ...