Microsoft Excel

Herbers Excel/VBA-Archiv

Frage zum Vergleich

Betrifft: Frage zum Vergleich von: websnake75
Geschrieben am: 13.08.2020 11:03:53

Hallo,

der Werner hat mir am 06.08.2020 hier im Forum eine schöne Formel erstellt, der Beitrag ist hier zu finden.

www.herber.de/forum/cgi-bin/callthread.pl?index=1775572#1775607
Nun versuche ich diese nachzuvollziehen, scheitere aber an dem Vergleich. Wenn ich diesen aus der gesamten Funktion herausnehme, liefert Excel immer #Wert.

Ich konte nur rausfinden, dass hier EURUSD mit einem &-Opperator und dem Datum verbunden wird.
Kann mir jemand einen Tip geben, was da beim Vergleich passiert?
Die ganze Formel:
=WENN((ZÄHLENWENN(A32:A99;A31)=0)*(A31="EURUSD");SUMMENPRODUKT((A$1:A31="EURUSD")*(ZEILE($A$1:A31) >=AGGREGAT(14;6;ZEILE(A$1:A31)/(A$1:A31="EURUSD")/(VERGLEICH(A$1:A31&C$1:C31;A$1:A31&C$1:C31;0) =ZEILE(A$1:A31));5));B$1:B31*(VERGLEICH(A$1:A31&$C$1:C31;A$1:A31&C$1:C31;0)=ZEILE(A$1:A31)));"")

Gruß
Ronald

Betrifft: AW: etwas erklärend hierzu ...
von: neopa C
Geschrieben am: 13.08.2020 11:39:14

Hallo Ronald,

... der Vergleichsformelteil der Formel allein für sich in einer Zelle eingesetzt, bedürfte eines spez. Matrixformelabschlusses um dessen Ergebnis nicht als #Wert auszugeben. Da dieses in der Formel abler lediglich ein Formelbestandteil der AGGREGAT()-Formel ist, die so einen spez. Formelabschluss normalerweise nicht benötigt, wird diese Funktionalität innerhalb dieses übergeordneten Formelteils dem VERGLEICH()-Formelteil "vererbt".

Du kannst zum nachvollziehen, was der Vergleichsformelteil in der Formel ermittelt, jedoch diesen Teil der Formel in der Eingabezeile markieren und anschließend durch Betätigung der Taste [F9] Dir dessen Zwischenergebniswertematrix anschauen (wenn der auszuwertende Bereich nicht zu groß definiert ist, was hier der Fall ist).

Gruß Werner
.. , - ...

Betrifft: AW: etwas erklärend hierzu ...
von: websnake75
Geschrieben am: 13.08.2020 14:34:52

Danke Werner, jetzt habe ich verstanden, was da passiert.

Betrifft: AW: gerne, freut mich owT
von: neopa C
Geschrieben am: 13.08.2020 15:40:00

Gruß Werner
.. , - ...