Microsoft Excel

Herbers Excel/VBA-Archiv

Summe aus bedingten Berechnungen

Betrifft: Summe aus bedingten Berechnungen von: Maurice 1887
Geschrieben am: 20.08.2020 17:20:26

Hallo zusammen,


ich stecke aus technischer Seite grade im Stau. Ich möchte aus einem Datensatz mit den Kategorien Name, Startdatum, Enddatum und Tage für jeden Namen die monatlich angefallenen Tage summieren, wobei die Personen Einträge in mehreren Zeilen haben und die Werte für Tage, Start und Ende immer unterschiedlich sind. Wichtig ist, dass die Tage auch proportional zu den Monaten gerechnet werden, sollten Start- und/oder Enddatum nicht im selben Monat liegen (Gesucht: Juli, Start: XX. Juli, Ende: XX. August = Tage * x%).

Nun hängt es in den Fällen 2 und 3, sprich ein Datum liegt außerhalb. Hier mein Vorgehen für den Fall, dass der Start im und das Ende außerhalb des Monats liegt:



1. Bedingung = Name<br><br>
2. Bedingung 01.mm.yy <= Start <= 31.mm.yy<br><br>
3. Bedingung 31.mm.yy < Ende<br><br>
<br><br>
(Hilfstabelle mit Anfang und Ende der jeweiligen Monate ist vorhanden)<br><br>
4. Bedingungen 1-3 erfüllt => Tage * Nettoarbeitstage(Start-31.xx.yy) / Nettoarbeitstage(Start-Ende)<br><br>
5. Ergebnisse summieren<br><br>

Nun habe ich schon mit WENN, SUMMEWENNS und SUMMENPRODUKT herumprobiert, komme aber auf keinen grünen Zweig. Ist es überhaupt möglich, diese Tage erst zeilenweise bedingt zu berechnen und dann zu summieren, ohne Rechenschritte auszulagern?

Betrifft: AW: Summe aus bedingten Berechnungen
von: Günther
Geschrieben am: 20.08.2020 18:14:41

Moin,
das sollte ganz prima mit deiner Version über Power Query (Daten | Abrufen und transformieren) gehen.
Aber:
= if Muster-xlsx (+ haendischer Loesung) = false then Hilfsbereitschaft = 0

 
Gruß
Günther  |  mein Excel-Blog

Betrifft: AW: Summe aus bedingten Berechnungen
von: Maurice 1887
Geschrieben am: 20.08.2020 19:53:51

Hallo Günther,

tut mir Leid, ich hatte eben keinen Zugriff auf die Tabelle und musste auch noch ein paar Sachen zwecks Datenschutz verändern.







Das erste Bild zeigt die Tabelle, in der die errechneten Tage angezeigt werden sollen, das 2. Bild zeigt einen Ausschnitt der Daten, wobei die relevanten Kategorien gezeigt sind.


Folgende Codes habe ich versucht:


=SUMME(WENN(UND(Daten!$L:$L=Overview!$P$2;$B10>=Daten!Q:Q;Daten!$Q:$Q>=Overview!$C10;$C10< Daten!$R:$R);Daten!S:S*NETTOARBEITSTAGE(Daten!Q:Q;C10)/NETTOARBEITSTAGE(Daten!Q:Q;Daten!R:R)))

Und

=SUMMENPRODUKT(--(Daten!$L:$L=Overview!$P$2)*--(Daten!Q:Q>=Overview!B11)*--(Daten!Q:Q< Overview!B12)*--(Daten!R:R>Overview!C11)*Daten!S:S*NETTOARBEITSTAGE(Daten!Q:Q;Overview!C11) /NETTOARBEITSTAGE(Daten!Q:Q;Daten!R:R))



Kann man damit was anfangen?

Betrifft: AW: Summe aus bedingten Berechnungen
von: Günther
Geschrieben am: 20.08.2020 20:27:41

[Zitat]Kann man damit was anfangen?[/Zitat]

Ob "man" damit etwas anfangen kann, das weiß ich nicht. Photoshop kann das gewiss. Und Excel garantiert nicht...
Ich überlasse andren Helfern das Feld.

 
Gruß
Günther  |  mein Excel-Blog

Betrifft: AW: Summe aus bedingten Berechnungen
von: Oberschlumpf
Geschrieben am: 20.08.2020 22:33:52

hey günther,

red doch nich nur drum herum, nenn die dinge klar + deutlich beim namen!
so z bsp:

Maurice , zeig bitte per upload eine Excel-Bsp-Datei.

ciao
Thorsten

Betrifft: AW: Summe aus bedingten Berechnungen
von: Maurice 1887
Geschrieben am: 21.08.2020 10:16:41

Hallo Oberschlumpf,

danke. Hätte ich eigentlich auch selbst drauf kommen müssen.

Ich habe da mal eine Mini-Version zusammengestellt. Sie ist zwar, wie in den Anmerkungen steht, nur auf diesen einen Fall innerhalb der Datenauswertung ausgelegt, aber sobald dieser gelöst ist, kann ich die Formel ohne große Probleme auf die anderen Fälle anpassen.

https://www.herber.de/bbs/user/139744.xlsx

Betrifft: AW: die Funktion NETTOARBEITSTAGE() ...
von: neopa C
Geschrieben am: 21.08.2020 16:45:28

Hallo Maurice,

... kann keine Datumsbereiche auswerten. Formelmäßig müsstest Du diese in Tabelle 2 für jeden Datensatz und Monat ermitteln.

Darüber hinaus ist mir unklar, was die Tagesangaben in Tabelle2!D:D bedeuten und auf was konkret sich Dein Beispiel in Tabelle1! Zeile 10 bezieht.

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Summe aus bedingten Berechnungen"