Microsoft Excel

Herbers Excel/VBA-Archiv

Kopieren und einfügen

Betrifft: Kopieren und einfügen von: mimi maiaw
Geschrieben am: 24.08.2020 10:41:04

Hallo zusammen,

ich habe ein „kleines“ Problem und benötige Hilfe.


Am besten wäre eine Formel und kein Makro.


Wenn in Tabelle „Ziel“ in Zelle A27 eine 1 steht dann möchte ich aus Tabelle „1“ Zelle AU4 kopieren und in Tabelle „Ziel“ Zelle E27 einfügen.

Wenn in Tabelle „Ziel“ in Zelle A27 eine 1 steht dann möchte ich aus Tabelle „1“ Zelle AV4 kopieren und in Tabelle „Ziel“ Zelle F27 einfügen.

Wenn in Tabelle „Ziel“ in Zelle A27 eine 1 steht dann möchte ich aus Tabelle „1“ Zelle AW4 kopieren und in Tabelle „Ziel“ Zelle G27 einfügen


https://www.herber.de/bbs/user/139806.xlsx



VG,

Mimi

Betrifft: AW: Kopieren und einfügen
von: Herbert_Grom
Geschrieben am: 24.08.2020 11:06:48

Hallo,

zu 1: =WENN(A27=1;'1'!AU4;"")

Daraus kannst du dann die anderen Formeln erstellen.

Servus

Betrifft: AW: Kopieren und einfügen
von: mimi maiaw
Geschrieben am: 24.08.2020 11:16:29

Danke sehr :)

Betrifft: AW: Gerne geschehen und danke für die Rückmeldung!
von: Herbert_Grom
Geschrieben am: 24.08.2020 11:41:26

,,,

Betrifft: AW: könnte sein, dass Du folgendes brauchst? ...
von: neopa C
Geschrieben am: 24.08.2020 11:23:45

Hallo Mimi,

... in E27 folgende Formel: =INDIREKT($A27&"!"&ADRESSE(4;SPALTE(AU9))) und diese nach rechts und unten ziehend kopieren.

Gruß Werner
.. , - ...

Betrifft: AW: könnte sein, dass Du folgendes brauchst? ...
von: mimi maiaw
Geschrieben am: 24.08.2020 13:43:25

ich habe mal versucht die Funktion etwas zu erweitern.
also wenn jetzt in der Zelle A27 2 steht dann will ich AU4 aus Tabelle 2 kopiert haben usw.

=WENNS(A27=1;'1'!$AU$4;"";A27=2;'2'!$AU$4;"";A27=3;'3'!$AU$4;"";A27=4;'4'!$AU$4;"")

Diese Funktion funktioniert aber nur wenn in der Zelle A27 eine 1 steht. Wenn also in Zelle A27 2,3 oder 4 steht, taucht #WERT! auf.
Weißt du eventuell was das Problem ist?

Betrifft: AW: die Funktion WENNS() gibt es vor 2013 nicht...
von: neopa C
Geschrieben am: 24.08.2020 13:53:12

Hallo mimi,

... die Du als bei Dir vorhandene Excel-Version angeben hast. Also hast Du eine neue Version im Einsatz.

Aber wenn Du meine Formel nutzt, brauchst Du WENNS() auch nicht. Siehe:

Arbeitsblatt mit dem Namen 'Ziel'
 ABCDEFG
271   4534564
282   97845

ZelleFormel
E27=INDIREKT($A27&"!"&ADRESSE(4;SPALTE(AU9)))
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


und Formel nach rechts und unten kopieren.

Gruß Werner
.. , - ...

Betrifft: AW: die Funktion WENNS() gibt es vor 2013 nicht...
von: mimi maiaw
Geschrieben am: 24.08.2020 14:07:39

Hi Werner,

hab es jetzt mit deine Formel probiert und es funktioniert :D

Danke und VG

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 24.08.2020 20:11:29

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Kopieren und einfügen"