Microsoft Excel

Herbers Excel/VBA-Archiv

Index Vergleich mit & brauche mal Hilfe

Betrifft: Index Vergleich mit & brauche mal Hilfe von: Nilo
Geschrieben am: 28.08.2020 10:44:17

Hi zusammen,
ich habe eine Denkblockade :)

In Mappe1 stehen in A (Zahlen) und G (Text)
In Mappe2 stehen in G (Text) und in E (Zahlen)

Ich möchte in Mappe1 prüfen ob die Kombi A+G auch in Mappe2 G+E vorkommt
und wenn (Index) in D in Mappe2 = ja dann X sonst Y

Mein Ansatz:
Formel soll dann in Range eingetragen werden:

Formel = "=WENN(INDEX(Mappe2!$D:$D;VERGLEICH($A2&G$1;Mappe2!$G:$G&Mappe2!$E:$E;0))=""ja"";""X""; _
""Y"")"
ActiveSheet.Range("G2:BU" & loLetzte).FormulaLocal = Formel
Das geht so leider nicht :(
Vergleich mit & zieht nicht !

Es geht nur wenn ich in Mappe2 G+E in F konkateniere und den Vergleich dann auf F verweise:
=WENN(INDEX(Mappe2!$D:$D;VERGLEICH($A3&H$1;Mappe2!$F:$F;0))=""ja"";""X"";""Y"")
Ich benötige jedoch einen Ansatz ohne G+E in Mappe2 zu konkatenieren.

Ich hoffe ihr könnt mir helfen

Danke und Gruß
Nilo

Betrifft: ach Mist, ich wieder: ist ja ne Matrixformel...
von: Nilo
Geschrieben am: 28.08.2020 10:57:00

geht jetzt :)
{=WENN(INDEX(Mappe2!$D:$D;VERGLEICH($A2&G$1;Mappe2!$G:$G&Mappe2!$E:$E;0))="ja";"X";"Y")}
Danke trotzdem... :)

Betrifft: AW: ach Mist, ich wieder: ist ja ne Matrixformel...
von: SF
Geschrieben am: 28.08.2020 11:13:59

Hola,

mach es doch ohne Matrixformel, einfach mit Wenn(Zählenwenns(.....

Gruß,
steve1da

Betrifft: meinst Du so?
von: Nilo
Geschrieben am: 28.08.2020 11:34:52

=WENN(ZÄHLENWENNS(Mappe2!$E:$E;$A2;Mappe2!$G:$G;AG$1;Mappe2!$D:$D;"ja");"X";"Y")
Das geht nicht! (oder ich mache was falsch)

Das Ergebnis ist immer Y obwohl das kriterium Mappe2!$D:$D;"ja" vorkommt bzw. da ist.

Habe ich einen Denkfehler?

Betrifft: AW: meinst Du so?
von: SF
Geschrieben am: 28.08.2020 11:38:04

Hola,

kann es sein dass du die Spalten vertauscht hast?
Jetzt vergleichst du A2 mit Spalte E in Mappe2, in der anderen Formel war es Spalte G. AG1 kam auch in der anderen Formel nicht vor.

Gruß,
steve1da

Betrifft: stimmt, Spaltendreher :)
von: Nilo
Geschrieben am: 28.08.2020 11:43:01

=ZÄHLENWENNS(Mappe2!$G:$G;$A425;Mappe2!$E:$E;AG$1;Mappe2!$D:$D;"ja")
Jetzt gehts (war ja klar ...)

PS: hatte die Formel schon nacht rechts gezogen daher AG1

Vielen Dank @Steve
Gruß
Nilo

Beiträge aus dem Excel-Forum zum Thema "Index Vergleich mit & brauche mal Hilfe"