Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema MsgBox
BildScreenshot zu MsgBox MsgBox-Seite mit Beispielarbeitsmappe aufrufen

Letzter Tag des Monats, Zeilennummer + 1

Betrifft: Letzter Tag des Monats, Zeilennummer + 1 von: Dieter(Drummer)
Geschrieben am: 02.09.2020 11:36:16

Guten Tag VBA Spezialisten/innen.

Es soll der letzte Tag des Monats + nächste Zelle, als Zeilennummer in MsgBox gezeigt werde.
Fakt ist: In Spalte B, in B11, steht z.B. 01.09.2020.

Nun suche ich die VBA Lösung, wie ich die Zeilennummer (Zahl) des letzten Tag des Monats aus der Spalte + nächste Zelle, angezeigt erhalte. Ideal wäre, wenn die Zeilennummer (Zahl) zum weiter einfügen im Zwischenspeicher vorhanden wäre, geht aber auch ohne.

Mein Versuch beinhaltet als Suchkriterium z.B. 30.09.2020. Der Monat kann aber wechseln, dann müsste ich des Suchkritium jedesmal im Code anpassen.

Mit der Bitte um Hilfe,
grüßt Dieter(Drummer)
Musterdatei anbei: https://www.herber.de/bbs/user/139984.xlsm

Mein bisheriger Code:

  • Sub Zeilennummer_Monatsletzter()
      Dim i As Integer
      Dim suchspalte As String
      suchspalte = "B"
      For i = 1 To ActiveSheet.UsedRange.Rows.Count
        If Range(suchspalte & i).Value = "30.09.2020" Then
          MsgBox "Letzer Tag im Monat steht in Zeile " & i + 1
          Exit Sub
        End If
      Next
      MsgBox "Monatsletzer nicht gefunden"
    End Sub

  • Betrifft: AW: Letzter Tag des Monats, Zeilennummer + 1
    von: Matthias L
    Geschrieben am: 02.09.2020 11:52:05

    Hallo

    Schreib doch den Monatsletzten in eine Formel

    Blutdruck

     B
    830.09.2020
    9 
    10Datum
    11Di 01.09.2020
    12Di 01.09.2020

    Formeln der Tabelle
    ZelleFormel
    B8=DATUM(JAHR(B11);MONAT(B11)+1;0)
    B12=B11


    Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

    Auf diese Zelle beziehst Du Dich dann im VBA-Code.

    Gruß Matthias

    Betrifft: AW: Letzter Tag des Monats, Zeilennummer + 1
    von: Dieter(Drummer)
    Geschrieben am: 02.09.2020 12:08:06

    Danke Matthias für Rückmeldung.

    Das hilft mir leider nicht, da ich die Zeilennummer (Zahl) brauche, um in der Tabelle, Formel _ in C5:
    =MITTELWERT(Blutdruck!$D$11:$D70)
    die Zeilennummer (hier 70) wechseln muss, wenn es ein anderer Monat ist.

    Evtl. hast Du da auch eine VBA Lösung.

    Gruß, Dieter(Drummer)

    Betrifft: AW: Letzter Tag des Monats, Zeilennummer + 1
    von: Werner
    Geschrieben am: 02.09.2020 13:12:17

    Hallo,

    welche Excel Version hast du denn? 2010 oder älter?

    Gruß Werner

    Betrifft: AW: Excel Version 2010
    von: Dieter(Drummer)
    Geschrieben am: 02.09.2020 13:17:33

    Danke Werner für Rückfrage. Evtl. hast Du ja eine Lösung.
    Gruß, Dieter(Drummer)

    Betrifft: AW: für Deinen Mittelwert brauchst Du das nicht ..
    von: neopa C
    Geschrieben am: 02.09.2020 13:17:59

    Hallo Dieter,

    ... ausreichend ist einfach z.B. =MITTELWERT(Blutdruck!$D$11:$D999) weil Leerzellen nicht als 0-Werte in die Mittelwertermittlung eingehen und somit das Ergebnis nicht verfälschen.

    Gruß Werner
    .. , - ...

    Betrifft: AW: Danke Werner ...
    von: Dieter(Drummer)
    Geschrieben am: 02.09.2020 13:40:16

    ... somit wird nur der Mittelwert aus den Zellbereich gewertet, die Inhalte haben. So ist die Abfrage, wann Monatsende ist, nicht mehr relevant. Das hilft mir schon weiter.

    Vielen Dank und
    Gruß, Dieter(Drummer)

    Betrifft: AW: bitteschön owT
    von: neopa C
    Geschrieben am: 02.09.2020 13:50:01

    Gruß Werner
    .. , - ...

    Betrifft: dann brauchst du es wohl nicht mehr...
    von: Werner
    Geschrieben am: 02.09.2020 13:55:39

    Hallo,

    ...da ich es schon habe lade ich dir deine Mappe mit Makro trotzdem noch hoch.

    Die Formeln in B67 bis C72 habe ich angepasst, damit das nicht in den Folgemonat läuft.

    Wie du darauf kommst, dass der Monatsletzte im Januar in Zeile 70 steht weiß ich nicht.

    https://www.herber.de/bbs/user/139990.xlsm

    Gruß Werner

    Betrifft: AW: Danke Werner ...
    von: Dieter(Drummer)
    Geschrieben am: 02.09.2020 14:21:49

    ... auch für diese prima Lösung, mit der ich auch etwas anfangen kann.

    Du hast natürlich Recht, dass Januar bis Zeile 72 geht.

    Danke und Gruß,
    Dieter(Drummer)

    Betrifft: Gerne u. Danke für die Rückmeldung. o.w.T.
    von: Werner
    Geschrieben am: 02.09.2020 15:02:18



    Beiträge aus dem Excel-Forum zum Thema "Letzter Tag des Monats, Zeilennummer + 1"