Microsoft Excel

Herbers Excel/VBA-Archiv

AGGREGAT: filtern & sortieren?

Betrifft: AGGREGAT: filtern & sortieren? von: Herbert_Grom
Geschrieben am: 02.09.2020 17:10:28

Hallo,

kann man eine Liste, mit einer Formel, gleichzeitig filtern und sortieren?

https://www.herber.de/bbs/user/140002.xlsx

Servus

Betrifft: AW: AGGREGAT: filtern & sortieren?
von: Marc
Geschrieben am: 02.09.2020 17:31:05

Hallo,

machs doch einfach mit einem Filter :D

Hier mal als Beispiel in deiner Tabelle. Du könntest ihn auch direkt auf die linke Spalte Packen, dann bräuchtest du keine extra Spalte und Formel.

https://www.herber.de/bbs/user/140003.xlsx

Gruß Marc

Betrifft: AW: AGGREGAT: filtern & sortieren?
von: Herbert_Grom
Geschrieben am: 02.09.2020 17:32:35

Hallo Marc,

vielen Dank für deinen Tipp, doch das ist nicht das, wonach ich gefragt habe.

Servus

Betrifft: AW: AGGREGAT: filtern & sortieren?
von: Marc
Geschrieben am: 02.09.2020 17:33:54

Hallo Herbert,

meines wissens musst du das ganze dann über ein Makro laufen lassen. Probier dazu mal den Makroaufzeichner und wende das Makro dann mit einem Button auf die Range an.

Gruß Marc

Betrifft: AW: AGGREGAT: filtern & sortieren?
von: Herbert_Grom
Geschrieben am: 02.09.2020 17:51:11

Hallo Marc,

bitte nicht böse sein, aber ich will wissen, ob das mit einer AGGREGAT- oder ARRAY-Formel geht. Alles andere ist mir geläufig! Danke!

Servus

Betrifft: AW: AGGREGAT: filtern & sortieren?
von: Daniel
Geschrieben am: 02.09.2020 17:58:08

Hi
ja kann man.
Es gibt in Excel die Funktionen FILTER und SORTIEREN.
damit sollte sich eine entsprechende Formel erstellten lassen
allerdings ist die Excelversion nicht ohne Relevanz.

Gruß Daniel

Betrifft: AW: ja, es geht ...
von: neopa C
Geschrieben am: 02.09.2020 17:58:24

Hallo Herbert,

... nachfolgende Formel ist noch zu optimieren, und evtl. Leerzellen noch auszufiltern ... doch das Abendessen "ruft" ;-)

In C2:

=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE(A$2:A$81)/(ZÄHLENWENN(A$2:A$81;"<="&A$2:A$81) =AGGREGAT(15;6;ZÄHLENWENN(A$2:A$81;"<="&A$2:A$81)/(ZÄHLENWENN(C$1:C1;A$2:A$99)=0);1)) /(ZÄHLENWENN(C$1:C1;A$2:A$99)=0);1));"")


Gruß Werner
.. , - ...

Betrifft: AW: ja, es geht ...
von: Herbert_Grom
Geschrieben am: 02.09.2020 18:33:47

Hallo Werner,

vielen Dank! Aber mit dieser Formel klappt's noch nicht. Er bringt mir nur dreimal den ersten Eintrag. Hast du bitte noch einen Tipp?

Servus

P.S.: Seit heute Opa!

Betrifft: AW: dann sieh mal ...
von: neopa C
Geschrieben am: 02.09.2020 18:46:24

Hallo Herbert,

... in nachfolgender Formel hab im inneren AGGREGAT()-Formelteil nur noch die Bedingung (A$2:A$99>0) damit Leerzellen im Auswertungsbereich unberücksichtigt bleiben und ich damit den Auswertungsbereich niht mehr auf den letzten Datenwert begrenzen muss.

Arbeitsblatt mit dem Namen 'Bestellhistorie'
 ABC
1Medikament Medikament
2Adenuric 80 mg Accu Chek Aviva
3Amlodipin 1A Pharma 5 mg ACCU-CHEK® FastClix Lanzetten
4Atorvastatin 1A Pharma 20 mg Adenuric 80 mg
5Protaphane FlexPen Amlodipin 1A Pharma 5 mg
6Ramipril 1A Pharma 5 mg Atorvastatin 1A Pharma 20 mg
7SIOFOR 1000 mg Carvedilol 1A Pharma 25 mg
8Voltaren Resinat 75 mg Loratadin 1A Pharma 10 mg
9Protaphane FlexPen Optifine 25x6 mm 6 mm
10SIOFOR 1000 mg Pantoprazol 1A Pharma 20 mg
11Trulicity 1,5 mg Protaphane FlexPen
12Accu Chek Aviva Ramipril 1A Pharma 5 mg
13Adenuric 80 mg SIOFOR 1000 mg
14Atorvastatin 1A Pharma 20 mg TRESIBA 200 FlexTouch 3 ml
15Carvedilol 1A Pharma 25 mg Trulicity 1,5 mg
16Optifine 25x6 mm 6 mm Voltaren Resinat 75 mg
17Protaphane FlexPen  
18Amlodipin 1A Pharma 5 mg  
19Protaphane FlexPen  
20Ramipril 1A Pharma 5 mg  
21SIOFOR 1000 mg  
22Trulicity 1,5 mg  
23Accu Chek Aviva  
24Adenuric 80 mg  

ZelleFormel
C2=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE(A$2:A$99)/(ZÄHLENWENN(A$2:A$99;"<="&A$2:A$99)=AGGREGAT(15;6;ZÄHLENWENN(A$2:A$99;"<="&A$2:A$99)/(A$2:A$99>0)/(ZÄHLENWENN(C$1:C1;A$2:A$99)=0);1))/(ZÄHLENWENN(C$1:C1;A$2:A$99)=0);1));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


oT: Gratulation; dann bist Du jetzt auch familär echt in unserer "Generation" angekommen :-)

Gruß Werner
.. , - ...

Betrifft: AW: hierzu ergänzt ...
von: neopa C
Geschrieben am: 02.09.2020 19:31:36

Hallo Herbert,

... mit den neuen Funktionen in OFFICE365 könnte die Auswertungsformel sicherlich einfacher zu erstellen gehen. Aber wie Du weißt, bin ich nicht im Besitz dessen.

Unabhängig von jeder Excelversion, ist eine Pivotauswertung die einfachste, schnellste (in Erstellung und Auswertung) sowie flexibelste (kannst im Ergebnis filtern, kannst die Sortierung drehen) Lösung. Zur Erstellung bedarf es nur weniger Mausklicks.

Gruß Werner
.. , - ...

Betrifft: AW: hierzu ergänzt ...
von: Herbert_Grom
Geschrieben am: 03.09.2020 08:48:12

Hallo Werner,

super, es funzt! Viiielen Dank! Das dürfte nun eine meiner wertvollsten Formeln überhaupt sein. Allerdings habe ich von dir schon div. Formeln "gebunkert"! Und auch von WF habe ich viele Formeln in meinem Portfolio.

Danke nochmals und auch für die Aufnahme in die "Familie"! ;o)=)

Servus

Betrifft: AW: gern getan, wünsche einen schönen AbendowT
von: neopa C
Geschrieben am: 03.09.2020 18:19:50

Gruß Werner
.. , - ...

Betrifft: AW: mit Pivot oder PQ geht es einfacher owT
von: neopa C
Geschrieben am: 02.09.2020 18:00:02

Gruß Werner
.. , - ...

Betrifft: AW: mit Pivot oder PQ geht es einfacher owT
von: Herbert_Grom
Geschrieben am: 03.09.2020 09:37:28

Hallo Werner,

du hast halt schon wieder recht, mit PQ geht es auch und auch noch viel schneller & unkomplizierter! Aber das ist halt nicht so mein Favorit.

Was aber schon krass ist, ist das es nun Funktionen gibt, die nur in der 365er Version vorhanden sind. Die wollen einen wieder mit aller Macht in die 365er Version zwingen. Verstehe ich ja auch ein Stück weit. Jeder hat gerne regelmäßige Einnahmen und MS eben auch. Mal sehen, wie lange ich noch widerstehe!

Servus

Beiträge aus dem Excel-Forum zum Thema "AGGREGAT: filtern & sortieren?"