Microsoft Excel

Herbers Excel/VBA-Archiv

INDEX VERGLEICH

Betrifft: INDEX VERGLEICH von: LaFu
Geschrieben am: 11.09.2020 10:38:25

Moin,
Ich habe ein INDEX + VERGLEICH Formeln verwendet, um in Tabelle 2 nur die Forderungen darzustellen, welche auch Teil einer neuen Berechnung sein sollen
Problem: Ich komme Forderungen mehrfach angezeigt, weil die Formel natürlich nicht erkennt, dass sie einen Wert bereits obendrüber verwendet hat
https://www.herber.de/bbs/user/140188.xlsx

Wo ist mein Fehler?

VG

Betrifft: AW: nicht eindeutig was Du meinst ...
von: neopa C
Geschrieben am: 11.09.2020 10:49:39

Hallo LaF,

... ich interpretiere es jetzt erst einmal so:
In G3:
=WENNFEHLER(VERWEIS(9;1/(A$1:A$99=A3)/(C$1:C$99="Ja");B:B);"")
und Formel nach unten kopieren. Meinst Du es so?

Gruß Werner
.. , - ...

Betrifft: AW: nicht eindeutig was Du meinst ...
von: LaFu
Geschrieben am: 11.09.2020 11:09:17

Danke für deine Antwort.

Das funktioniert leider nicht.

Vielleicht wird es durch meine (händische) Darstellung nun besser verständlich:

https://www.herber.de/bbs/user/140190.xlsx

Das ganz soll mit einer Formel funktionieren, jedoch funktioniert meine Vorangehensweise - wie in der Falschen Darstellung offensichtlich - nicht.

VG

Betrifft: AW: ja, jetzt verständlicher ...
von: neopa C
Geschrieben am: 11.09.2020 11:21:14

Hallo LaFu,

in E3 folgende Formel:

=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE(A$3:A$99)/(C$3:C$99="Ja");ZEILE(E1)));"")

und diese ziehend nach unten kopieren. In Spalte F reicht dann wieder eine einfache SVERWEIS()-Formel.
Gruß Werner
.. , - ...

Betrifft: AW: ja, jetzt verständlicher ...
von: Luschi
Geschrieben am: 11.09.2020 11:45:38

Hallo LaFu,

und mit Excel 365 ist das Alles viel einfacher: =FILTER($A$3:$B$99;$C$3:$C$99="Ja")

Gruß von Luschi
aus klein-Paris

- nix nach Unten ziehen
- kein S-Verweis
- kein WennFehler

Betrifft: Funktioniert einwandfrei owT
von: LaFu
Geschrieben am: 11.09.2020 11:54:02

.

Betrifft: AW: schön, doch ...
von: neopa C
Geschrieben am: 11.09.2020 12:28:56

Hallo LaFu,

... solltest Du schon Office365 im Einsatz haben (kann man im Forum als thread-Eröffner leider noch immer nicht angeben), dann ist der Vorschlag von Luschi sicherlich eine bessere Alternative (ich hab allerdings selbst auch nur XL2016 im Einsatz und kann es deshalb nicht testen).

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "INDEX VERGLEICH"