Microsoft Excel

Herbers Excel/VBA-Archiv

Formel für ein Monat vor heute

Betrifft: Formel für ein Monat vor heute von: Corinna
Geschrieben am: 22.09.2020 22:30:41

Liebes Forum,


ich komme bei folgender Fragestellung nicht weiter (Excel 2019):

Ich habe eine Spalte mit Geburtstagen. Nun soll in der Spalte daneben immer "Geschenk kaufen" stehen, wenn sich der Monat des jeweiligen Geburtstages einen Monat vor dem heutigen Datum befindet.

Also zb alle September Geburtstagskinder erhalten im August den Hinweis "Geschenk kaufen".


Bitte erlöst mich!!!

Vielen Dank und liebe Grüße,

Corinna

Betrifft: AW: Formel für ein Monat vor heute
von: Thomas
Geschrieben am: 22.09.2020 23:55:43

HI, wenn du nur den monat betrachtest dann ist hier die formel:

=IF(MONTH(X5)-MONTH(NOW())=1,"Geschenk kaufen","")

mein excel läuft auf englischen formeln, musst das dann noch abänden.
if=wenn, month=monat, now=heute

Betrifft: AW: Formel für ein Monat vor heute
von: Corinna
Geschrieben am: 23.09.2020 00:07:13

Wow, wie toll! Das hat super funktioniert! Vielen Dank, jetzt kann ich schlafen gehen :)

Betrifft: Bitte die Januar-Kinder nicht vergessen!
von: Daniel
Geschrieben am: 23.09.2020 00:14:43

Die werden von dieser Formel nicht berücksichtigt.

Gruß Daniel

Betrifft: AW: Bitte die Januar-Kinder nicht vergessen!
von: Corinna
Geschrieben am: 23.09.2020 08:28:28

Ach ja Mist! Oh nein, noch jemand eine Idee?
Danke jedenfalls für den Hinweis!

Betrifft: ganz unten
von: WF
Geschrieben am: 23.09.2020 08:39:00

.

Betrifft: AW: Formel für ein Monat vor heute
von: fcs
Geschrieben am: 23.09.2020 01:02:21

HAllo Corinna,

mein Vorschlag.
Der nächste Geburtstag wird hier aus dem Geburtsdatum berechnet.

LG
Franz

HTML add In




Tabelle1
 ABCD
1GeburtsdatumGeburtstagHinweisGeschenk gekauft
228.02.199228.02.2021  
320.10.199520.10.2020Geschenke kaufen 
421.10.199521.10.2020 x
522.10.199522.10.2020 x
623.10.199523.10.2020Geschenke kaufen 
724.10.199524.10.2020  
825.10.199525.10.2020  
923.09.200223.09.2020Gratulieren 
1024.09.200224.09.2020Geschenke kaufen 

verwendete Formeln
Zelle Formel Bereich N/A
B2:B10=DATUM(JAHR(HEUTE())+WENN(HEUTE()>DATUM(JAHR(HEUTE());MONAT(A2);TAG(A2));1;0);MONAT(A2);TAG(A2))  
C2:C10=WENN(ODER(B2-HEUTE()<0;B2-HEUTE()>30);"";WENN(B2-HEUTE()=0;"Gratulieren";WENN(D2="x";"";"Geschenke kaufen")))  

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.21 einschl. 64 Bit






Betrifft: AW: Formel für ein Monat vor heute
von: Corinna
Geschrieben am: 23.09.2020 08:35:35

Danke Franz für deinen Vorschlag.
Das Problem ist, ich habe nur eine Spalte mit den Geburtsdaten und soll ohne einer weiteren Hilfsspalte diese Formel erstellen: WENN(Geburtstag im nächsten Monat)dann "Geschenk kaufen".

Ich sitze schon seit einer Woche an dieser Formel; mittlerweile bereitet sie mir schlaflose Nächte ;-)

Vielen Dank für Eure raschen Antworten!
LG

Betrifft: AW: Formel für ein Monat vor heute
von: Thomas
Geschrieben am: 22.09.2020 23:56:42

=IF(MONTH(X5)-MONTH(NOW())=1,"Geschenk kaufen","")

mein excel läuft nur auf englisch, dass sollten die übersetzungen sein
if=wenn
month=monat
now=heute

Betrifft: mit Januargeburtstagen
von: WF
Geschrieben am: 23.09.2020 08:37:33

=WENN(SUMME(1*(MONAT(A5)-MONAT(HEUTE())={1;-11}));"Geschenk";"")

WF

Betrifft: AW: mit Januargeburtstagen
von: Corinna
Geschrieben am: 23.09.2020 09:09:33

Mega!! Danke!! Hat geklappt und wäre ich nie selbst drauf gekommen.
LG

Betrifft: AW: mit Januargeburtstagen
von: Luschi
Geschrieben am: 23.09.2020 10:34:22

Hallo Corinna,

da muß ich schon staunen:
- keine Beispiel-Demo-Datei
- dann 1 Formel, die nicht überprüft werden kann
- und Du rufst 'Mega'
- damit ist niemand geholfen

Gruß von Luschi
aus klein-Paris

Betrifft: AW: mit Januargeburtstagen
von: Günther
Geschrieben am: 23.09.2020 10:59:13

Ich gebe Luschi Recht.
Und ergänzend noch meine Anmerkung, dass hier der Einsatz von EDATUM() gewiss deutlich transparenter wäre. Und da ich es probiert habe, existiert natürlich meine Formel. Aber ich möchte niemandem die Gelegenheit nehmen, sein eigenes Erfolgserlebnis zu haben 8-)
 
Gruß
Günther  |  mein Excel-Blog

Betrifft: AW: mit Januargeburtstagen
von: Corinna
Geschrieben am: 23.09.2020 13:07:26

Wie müsste denn meine Antwort aussehen, um Euch beide glücklich zu machen?
Sonnigen Gruß,
Corinna

Beiträge aus dem Excel-Forum zum Thema "Formel für ein Monat vor heute"