Microsoft Excel

Herbers Excel/VBA-Archiv

Summewenns und Zählenwenns

Betrifft: Summewenns und Zählenwenns von: Melpomene X
Geschrieben am: 23.09.2020 19:05:47



Hallo liebe Community,


ich brauche dringend eure Hilfe. Vermutlich ist es relativ einfach und ich hab auch eine Idee wie man da ran geht, aber ich habe jetzt schon einige Stunden mit dem Problem verbracht und ich schaffe es schlichtweg nicht.

In der Spalte A ist die Bezeichnung des Objektes eingetragen, wobei die Zeilen 2, 17, 27, 28 blau markiert sind. In diese Zeilen müssen später auch die Ergebnisse der Abfragen hinein (da ich diese später über SVerweis in eine andere Tabelle gebe). Die blauen Zellen der Spalte 1 haben alle 19 Zeichen.

Alle Längen der Spalte B sind vorgegeben.

In die Spalte C sollen die Längen der Zellen addiert werden, deren ersten 19 Zeichen gleich den ersten 19 Zeichen, der blauen Zeilen haben und an den Positionen 22 und 23 „ER“ stehen haben. Gibt es eine solche Zelle nicht, so ist die Zelle leer zu lassen.

In die Spalte D sollen die Längen der Zellen addiert werden, deren ersten 19 Zeichen gleich den ersten 19 Zeichen, der blauen Zeilen haben und an den Positionen 22 und 23 „HA“ stehen haben. Gibt es eine solche Zelle nicht, so ist die Zelle leer zu lassen.

Ich habe bei diesen beiden Spalten überlegt, dass man mir der Funktion =SUMMEWENN(A2:A39;A2;B2:B39) arbeiten kann. Aber hier kommt nur überall nur eigentliche Länge raus, ohne dass eine addition stattgefunden hat und das Kriterium, dass ER an der 22. und 23. Stelle ist, habe ich nicht berücksichtigt.

Spalte E ist für mich lösbar.

In der Spalte F soll die Anzahl der Zellen addiert werden, deren ersten 19 Zeichen gleich den ersten 19 Zeichen, der blauen Zeilen haben und an den Positionen 22 und 23 „ER“ stehen haben. Gibt es eine solche Zelle nicht, so ist die Zelle leer zu lassen.

In die Spalte G soll die Anzahl der Zellen addiert werden, deren ersten 19 Zeichen gleich den ersten 19 Zeichen, der blauen Zeilen haben und an den Positionen 22 und 23 „HA“ stehen haben. Gibt es eine solche Zelle nicht, so ist die Zelle leer zu lassen.

Hier müsste es mit der Funktion =ZÄHLENWENN gehen, aber auch hier habe ich es trotz rumprobieren nicht geschafft.

Spalte H habe ich auch geschafft.


Vielen Dank für eure Hilfe…





https://www.herber.de/bbs/user/140387.xlsx

Betrifft: AW: teils inkorrekte Angaben...
von: neopa C
Geschrieben am: 23.09.2020 19:42:37

Hallo Melpomene,

... die Texte in den blauen Zellen in Spalte A sind nur 16 nicht 19 Zeichen lang!

In C2: =WENN(LÄNGE(A2)=16;SUMMEWENN(A:A;A2&"?????ER*";B:B);"") und nach unten kopieren.

Analog in Spalte D.

in F2: =WENN(LÄNGE(A2)=16;ZÄHLENWENN(A:A;A2&"?????ER*");"")

und in Spalte G analog

Gruß Werner
.. , - ...

Betrifft: AW: teils inkorrekte Angaben...
von: Melpomene X
Geschrieben am: 23.09.2020 19:52:38

Oh ja.... natürlich 16 Zeichen...Entschuldigung!

Ich bin vor lauter Zahlen und Zeichen schon blind gewesen....

Es klappt! Es klappt! Und die Formel ist so komplex, dass ich sie überhaupt nicht verstehe..

Werner - du hast mich heute Abend sehr, sehr glücklich gemacht!!! Vielen DANK

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 23.09.2020 20:04:26

Gruß Werner
.. , - ...