Microsoft Excel

Herbers Excel/VBA-Archiv

Tage pro Kalendermonat für Zeitraumliste zählen

Betrifft: Tage pro Kalendermonat für Zeitraumliste zählen von: Mikael
Geschrieben am: 24.09.2020 15:00:30

Ich habe eine vertikale Event-Tabelle in B6:C13 mit Start- und Enddatum verschiedener Events, eine Zeile pro Event.


Ich möchte nun wissen, wieviele Tage pro Kalendermonat insgesamt durch die Events in der Tabelle belegt sind. Dazu habe ich eine vertikale Monats-Liste, beginnend mit 01.09.2020 in F6, 1.10.2020 in F7 etc.


Ich weiß, wie ich die Anzahl der Tage für alle Kalendermonate berechnen kann, die von EINEM Event belegt sind. Dazu gibt es verschiedene schöne Methoden, siehe Beispielarbeitsmappe anbei:


mit MIN/MAX:

=MAX(;MIN($C$6-$F6+1;$F7-MAX($B$6;$F6)))


mit INDIREKT:

=SUMMENPRODUKT((JAHR(ZEILE(INDIREKT($B$6&":"&$C$6)))=JAHR(F6))*(MONAT(ZEILE(INDIREKT($B$6&":"&$C$6))) =MONAT(F6))*1)


Problem:

Nun möchte ich diese Berechnung erweitern, so dass ALLE Events bei der Zählung berücksichtigt werden. Hier komme ich nicht weiter (Haare bereits ausgerissen). Für sachdienliche Hinweise bin ich sehr dankbar!

Betrifft: AW: Tage pro Kalendermonat für Zeitraumliste zählen
von: onur
Geschrieben am: 24.09.2020 17:29:11

Hast du max immer nur ein Event pro Tag?
Wenn nein wird es mit Formeln schwierig.

Betrifft: AW: Tage pro Kalendermonat für Zeitraumliste zählen
von: Mikael
Geschrieben am: 24.09.2020 18:40:40

Ja, Events überschneiden sich nicht. Also ein bestimmter Tag gehört entweder zu keinem oder genau einem Event.

Betrifft: AW: Tage pro Kalendermonat für Zeitraumliste zählen
von: onur
Geschrieben am: 24.09.2020 21:04:11

Guckst du hier:
https://www.herber.de/bbs/user/140420.xlsm

Betrifft: AW: Tage pro Kalendermonat für Zeitraumliste zählen
von: Mikael
Geschrieben am: 25.09.2020 14:09:38

Danke Onur,
ja, ich nehme an ich muss es wohl mit VBA machen. Danke für das Makro!

Gruß, Mikael

Betrifft: AW: Tage pro Kalendermonat für Zeitraumliste zählen
von: Günther
Geschrieben am: 25.09.2020 14:47:56

Moin,
du kannst es mit VBA machen, es geht aber auch ohne (Stichwort: Power Query). PQ hat aber den Nachteil, dass bislang keine "pfannenfertige" Lösung vorliegt, du müsstest also selber etwas Arbeit hineinstecken. Copy/paste ist natürlich leichter…
 
Gruß
Günther  |  mein Excel-Blog

Betrifft: AW: Tage pro Kalendermonat für Zeitraumliste zählen
von: Günther
Geschrieben am: 24.09.2020 19:54:41

Moin,
warum auch immer, ich komme (mit Power Query) auf andere Ergebnisse:
Monatsname	Anzahl
August	        8
September	22
Oktober	        17
November	14
 
Gruß
Günther  |  mein Excel-Blog

Beiträge aus dem Excel-Forum zum Thema "Tage pro Kalendermonat für Zeitraumliste zählen"