Microsoft Excel

Herbers Excel/VBA-Archiv

letzter Wert in Spalte X

Betrifft: letzter Wert in Spalte X von: Jens Kasche
Geschrieben am: 25.09.2020 08:27:56

https://www.herber.de/bbs/user/140424.xlsx


Guten Tag,

ich brauche Hilfe für folgendes Problem:


https://www.herber.de/bbs/user/140424.xlsx


Für unsere Dienstplanung nutzen wir eine relativ große Tabelle, in der die Schichten mit Abkürzungen, wie z.B. T1, T2,N1, usw., benannt werden.
Für jeden Monat gibt es eine neue Tabelle, von daher brauchen die Tage des laufenden Monats nur mit 1., 2., 3., usw. angegeben werden.
Für jeden Mitarbeiter wird an seinem letzten Arbeitstag des Monats ein Stundennachweis ausgedruckt.
Jedenfalls sollte es so sein.
Da eben viele Mitarbeiter hier tätig sind, ist die Tabelle entsprechend groß und in Bezug auf den letzten Arbeitstag eines Mitarbeiters recht unübersichtlich.
Von daher wäre es wünschenswert, wenn, wie in der Beispiel-Datei dargestellt, der letzte Arbeitstag angezeigt werden würde.

So wie in der Spalte "Ergebnis".


Ich hoffe, mir kann geholfen werden.

Betrifft: So...
von: Case
Geschrieben am: 25.09.2020 08:45:08

Hallo, :-)
=WENNFEHLER(INDEX($B$3:$K$3;1;MAX(WENN(B4:K4<>"";SPALTE(B:K)))-1);"")
Servus
Case

Betrifft: AW: So...
von: Luschi
Geschrieben am: 25.09.2020 09:07:16

Hallo Case,

bei mir klappt die Formel aber nur mit Matrix-Abschluß

Gruß von Luschi
aus klein-Paris

Betrifft: Ja - vergesse ich immer,...
von: Case
Geschrieben am: 25.09.2020 09:20:14

Hallo Luschi, :-)

... weil das in meiner Version nicht mehr nötig ist. ;-)

Servus
Case

Betrifft: AW: So...
von: Daniel
Geschrieben am: 25.09.2020 09:43:40

Hi
1. wenn man im Index auf die ganze Zeile referenziert, muss man die Spalte nicht umrechnen und die Formel wird unempfindlich gegenüber zusätzlich eingefügten oder gelöschten Spalten.

2. mit Aggregat(14;...;1) anstelle von Max braucht man auch in älteren Versionen keinen Matrixformelabschluss:
=INDEX($3:$3;1;AGGREGAT(14;6;SPALTE(B4:K4)/(B4:K4<>"");1))
Gruß Daniel

Betrifft: AW: So...
von: Jens Kasche
Geschrieben am: 25.09.2020 11:57:57

@ Case

Funktioniert wunderbar.

Danke an alle.
Und Gruß.

Betrifft: AW: letzter Wert in Spalte X
von: SF
Geschrieben am: 25.09.2020 08:47:18

Hola,

schau mal hier:
https://www.herber.de/excelformeln/pages/Letzte_benutzte_Zelle_in_einer_Zeile_oder_Spalte_Frank_Kabel_in_memoriam.html

Gruß,
steve1da

Betrifft: AW: letzter Wert in Spalte X
von: Jens Kasche
Geschrieben am: 25.09.2020 11:51:36

Vielen Dank.
Das hilft mir nicht wirklich weiter.

Betrifft: AW: letzter Wert in Spalte X
von: SF
Geschrieben am: 25.09.2020 11:55:34

Weil?
Ein bisschen konkreter darfst du schon werden.

Betrifft: =VERWEIS(2;1/(B4:K4<>"");SPALTE(A4:Z4))
von: WF
Geschrieben am: 25.09.2020 10:15:39

.

Betrifft: oder =VERWEIS(2;1/(B4:K4<>"");B$3:X$3)
von: WF
Geschrieben am: 25.09.2020 10:27:30

.

Beiträge aus dem Excel-Forum zum Thema "letzter Wert in Spalte X"