Microsoft Excel

Herbers Excel/VBA-Archiv

Zähle Primezahlen?

Betrifft: Zähle Primezahlen? von: Stefan
Geschrieben am: 04.10.2020 16:34:34

Hallo Forum


Wünsche euch einen schönen Feiertag gehabt zu haben.

Ich steh voll auf dem Schlauch. Bekomme nichts gebacken.

Ich habe einen Bereich in der Tabelle 1 als Primezahlen deklariert, wo alle Primzahlen bis 47 drin stehen. Nun habe in der Tabelle 2 eine Tabelle wo Zahlen drinstehen die ab und an auch Prime zahlen sind.

Wie kann ich diese Prime zahlen in der Tabelle zählen?

Ich habe es so probiert.


In Zelle BB11 habe ich diese Formel "=ZÄHLENWENN(AV11:BA11;Primezahlen)"

Das sind meine Zahlen 48; 13; 20; 25; 33; 10 die überprüft werden sollen, ob sich dort Primzahlen drin befinden und diese zählen, wie viel sind vorhanden, aber es geht nicht. Es wird "0″ angezeigt, obwohl eine Primzahl dort in der Tabelle steht?

Bin echt zu dumm. Bekomme das einfachste nicht gebacken.

Betrifft: AW: Zähle Primezahlen?
von: Hajo_Zi
Geschrieben am: 04.10.2020 16:37:03

=Summe(ZÄHLENWENN(AV11:BA11;Primezahlen))

Zu Deiner Datei kann ich nichts schreiben, was wohl daran liegt das ich nicht auf fremde Rechner schaue.Ich baue keine Datei nach.

Sollte die Datei verlinkt werden?

Wenn du an Stelle einer Demomappe deine Originalmappe hochladen willst, diese aber sensible Daten enthält, kannst du diese Daten
http://www.ms-office-forum.de/forum/showthread.php?t=322895
änderrn.

Bilder lade ich mir nicht runter, da Excel damit nichts anfangen kann.

http://www.excel-ist-sexy.de/bilder-statt-datei/

Hochgeladene Bilder können zwar als solche in Excel importiert werden, sind jedoch bei der Lösung von Problemen nicht sehr hilfreich, da man die eigentlichen Daten nicht ohne große und zeitraubende Umwege direkt in die Tabelle übertragen kann.

Das ist nur meine Meinung zu dem Thema.

GrußformelHomepage

Betrifft: getestet
von: Hajo_Zi
Geschrieben am: 04.10.2020 16:55:07


Tabelle1
 G
13

verwendete Formeln
Zelle Formel Bereich N/A
G1{=SUMME(ZÄHLENWENN(AV11:BA11;Primezahlen))}$G$1 
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!


definierte Namen  
Name Bezieht sich auf Tabelle Z1S1-Formel
Primezahlen=Tabelle1!$A$10:$A$20 =Tabelle1!R10C1:R20C1
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.21 einschl. 64 Bit



Gruß Hajo

Betrifft: AW: getestet
von: Stefan
Geschrieben am: 04.10.2020 17:00:29

Hat erst nicht funktioniert bis ich deinen Hinweis gelesen hatte, dass man das ganze mit
Strg+Umschalt+Enter abschließen muss. danach ging es.

Danke dir für deine schnelle Hilfe.