Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenns - variabler Zellbereich

Betrifft: Zählenwenns - variabler Zellbereich von: Fritz_W
Geschrieben am: 05.10.2020 15:17:08

Hallo Forumsbesucher,
ich möchte die Formel
Zählenwenns(tabelle1!L2:L500;C1;tabelle1!P2:P500)
in Zelle D1 des Tabellenblatts Tabelle2 so verändern, dass der Zellbereich L2:L500 sowie P2:P500 hinsichtlich des Zeilenbereichs variabel gestaltet werden kann, je nach den Zahlen in den Zellen A1 und B1 der Tabelle2, wobei sich die erste Zeile des Zellbereichs in Tabelle2 A1 und die letzte Zeile des Zellbereichs in Tabelle2 B1
steht.

Beispiel:
In Tabelle2 A1. steht 6
in Tabelle2 B1 steht 220

dann sollte der Zellbereich der Formel Zählenwenns sich auf die Zellbereiche L6:L220 und P6:P220 beziehen.
Ist das so etwas über eine Formellösung machbar oder geht das nur per VBA?

Für eure Unterstützung besten Dank im Voraus.

mfg
Fritz

Betrifft: Ja
von: lupo1
Geschrieben am: 05.10.2020 15:25:49

=Zählenwenn(
index(tabelle1!L:L;tabelle2!A1):
index(tabelle1!L:L;tabelle2!B1);C1)


Betrifft: Ach so:
von: lupo1
Geschrieben am: 05.10.2020 15:27:30

=Zählenwenns(
index(tabelle1!L:L;tabelle2!A1):index(tabelle1!L:L;tabelle2!B1);C1;
index(tabelle1!P:P;tabelle2!A1):index(tabelle1!P:P;tabelle2!B1);X1)

Betrifft: AW: dazu brauchts kein VBA ...
von: neopa C
Geschrieben am: 05.10.2020 15:29:23

Hallo Fritz,

... so: =ZÄHLENWENNS(INDEX(Tabelle1!L:L;A1):INDEX(Tabelle1!L:L;B1);C1;INDEX(Tabelle1!P:P;A1):INDEX(Tabelle1!P:P;B1);C1)

Gruß Werner
.. , - ...

Betrifft: AW: Zählenwenns - variabler Zellbereich
von: Fritz_W
Geschrieben am: 05.10.2020 15:51:32

Hallo Lupo und Werner,

ganz toll, vielen Dank für eure Hilfe. Ich werde eure Vorschläge gleich testen.
Wenn ich noch Fragen haben sollte, melde ich mich wieder.

LG
Fritz

Betrifft: AW: Zählenwenns - variabler Zellbereich
von: Fritz_W
Geschrieben am: 05.10.2020 17:08:29

ich möchte meinen Helfern nochmals Rückmeldung geben:
hab das Ganze erfolgreich anwenden können, ihr habt mir wieder einmal sehr geholfen.
Dafür nochmals Dank.

mfg
Fritz