Microsoft Excel

Herbers Excel/VBA-Archiv

Duplikate entfernen - Werte verschoben

Betrifft: Duplikate entfernen - Werte verschoben von: Excel Lent
Geschrieben am: 09.10.2020 09:20:38

https://www.herber.de/bbs/user/140752.xlsx


Hallo allerseits,

ich zwei kleines Probleme mit einer Liste, die zum Entfernen von Duplikaten gedacht ist. Eine kurze Beschreibung:

F7 : F200 - Eingabe von IDs, die Duplikate enthalten

L31:L36 - Manuell eingegebene Standard IDs (sagen wir einfach mal 1 bis 6)

L37:L200 - Automatische Ergänzung von IDs, die noch nicht eingetragen wurden


1)

Meine Formel in L37 (wird runtergezogen):

=WENNFEHLER(INDEX(F:F;AGGREGAT(15;6;ZEILE(F$7:F$200)/ISTNV(VERGLEICH(F$7:$F$200;L$31:L37;)); 1))&""; "")


Wenn man in F7 eine ID (sagen wir einfach mal "7") eingibt, wird in L37 automatisch ein Eintrag erstellt.

Sobald man in F8 die gleiche ID nochmal eingibt, wird allerdings der Eintrag aus L37 in L38 verschoben und L37 ist leer.

Wiederhole ich das ganze in F9, ist wieder alles okay.


2)

In meiner Formel werden aktuell die manuell eingegebenen Standard IDs aus F31:F36 nicht in den Vergleich miteinbezogen. Das sollte natürlich auch nicht so sein. Sollte aber nur ein kleiner Denkfehler meinerseits sein, bei dem ich irgendwie auf dem Holzweg tappe.


Wieso tritt dieses Problem auf und wie lässt es sich lösen? Ich wäre sehr dankbar für einen Lösungsvorschlag - am liebsten bitte die Formel anpassen und keine Makros/VBA benutzen. Ansonsten auch gerne eine Alternativformel posten.

Betrifft: AW: Formel etwas anders definieren ...
von: neopa C
Geschrieben am: 09.10.2020 09:29:58

Hallo,

... mit einer Funktion weniger z.B. so:
=WENNFEHLER(INDEX(F:F;AGGREGAT(15;6;ZEILE(F$7:F$200)/(ZÄHLENWENN(L$31:L37;F$7:F$200)=0);1));"")

Gruß Werner
.. , - ...

Betrifft: AW: Formel etwas anders definieren ...
von: Excel Lent
Geschrieben am: 09.10.2020 09:37:28

In diesem Fall tritt der Fehler genauso auf, jedoch ist es jetzt keine Leerzelle mehr, sondern in der Zelle steht eine 0, obwohl die 0 gar keine ID hat, die in der Liste rechts aufgeführt werden sollte.

Betrifft: AW: ok, dann ...
von: neopa C
Geschrieben am: 09.10.2020 09:42:45

Hallo,

... erweitere die Formel wie folgt:

=WENNFEHLER(INDEX(F:F;AGGREGAT(15;6;ZEILE(F$7:F$200)/(ZÄHLENWENN(L$31:L36;F$7:F$200)=0) /(F$7:F$200<>"");1));"")

Gruß Werner
.. , - ...

Betrifft: AW: ok, dann ...
von: Excel Lent
Geschrieben am: 09.10.2020 09:47:40

Super, das hat geklappt! Vielen Dank :)

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 09.10.2020 09:50:59

Gruß Werner
.. , - ...