Microsoft Excel

Herbers Excel/VBA-Archiv

Zeit als Zahl eingeben

Betrifft: Zeit als Zahl eingeben von: besserist
Geschrieben am: 15.10.2020 20:42:00

Hallo zusammen,


ich würde gern meinen Kollegen und mir die Eingabe der Uhrzeit vereinfachen. Dies geben wir bestimmt mehr als 50x pro Tag ein. Fragt nicht warum, es ist einfach so ;)


ich würde gern eingeben steht als erstes, was rauskommen so steht danach:


6 - 6:00

62 - 6:20

23 - 23:00

231 - 23:10

2245 - 22:45


Ich hab es versucht mit vierstelliger Formatierung und dann = Links(Zelle;2)&":"&Rechts(Zelle;2),

dafür muss es aber immer vierstellig sein und bei 5Uhr kommt ja in Exel 5000 was 50:00 ergibt.

Und bei anderen Zeiten hab ich noch andere Probleme.

Hat jemand da eine fertige Lösung parat.

Das wär wirklich super und eine grosse Hilfe.

Ich dank Euch schon mal.


Sorry, bitte keine wilden Alternativen ;)


VG Jörn

Betrifft: AW: Zeit als Zahl eingeben
von: Hajo_Zi
Geschrieben am: 15.10.2020 20:44:21

Hallo jörn,

Autokorrektur ersetzen ,, durch :

GrußformelHomepage

Betrifft: AW: Zeit als Zahl eingeben
von: besserist
Geschrieben am: 15.10.2020 20:46:48

Hallo Hajo, wie meinst du das ? Ich benötige eine Formel oder einen VBA Code der mir meine Zahlen in eine Uhrzeit umwandelt.

VG Jörn

Betrifft: AW: Zeit als Zahl eingeben
von: Hajo_Zi
Geschrieben am: 15.10.2020 20:48:45

Hallo Jörn,

Gut meine Lösung ohne Formel und VBA hat Dir also nicht geallen.

Viel Erfolg noch.
Ich bin dann raus.

Gruß Hajo

Betrifft: AW: Zeit als Zahl eingeben
von: besserist
Geschrieben am: 15.10.2020 20:50:12

;) Nein, sie dauert zu lang, wenn ich die Zahl eintippe soll in der Zelle daneben gleich die Uhrzeit auftauchen .

Betrifft: AW: Zeit als Zahl eingeben
von: onur
Geschrieben am: 15.10.2020 21:20:45


Und wie soll der Code wissen, ob du z.B. mit 23 23:00 Uhr und nicht 2:30 Uhr meinst???

Betrifft: AW: Zeit als Zahl eingeben
von: besserist
Geschrieben am: 15.10.2020 21:31:14

mmmhh, ich merk schon, das wird so nichts :(

Und wenn die Zahl immer 3-stellig ist und die letzten beiden immer die Minuten sind?
Dann müsste man irgendwie sagen das von rechts die 2 immer die Minuten sind und was übrig bleibt nach links als Stunde muss.

Geht sowas ?

Betrifft: AW: Zeit als Zahl eingeben
von: besserist
Geschrieben am: 15.10.2020 21:36:06

Ick habs,

ist die Zahl kleiner 1000, nimm 1Zahl von rechts und 2 von links, ansonsten 2 von rechts und 2 von links.

Ich probiers mal, trotzdem Danke!

Bin für jede bessere oder schnellere Lösung dankbar

VG Jörn

Betrifft: AW: Zeit als Zahl eingeben
von: chris b.
Geschrieben am: 15.10.2020 22:36:53

Schau mal was hältst du davon ?
Geht mit 3 oder 4 Zahlen Eingabe.

=WENN(LÄNGE(A1)=4;ZEIT(LINKS(A1;2);RECHTS(A1;2);0);ZEIT(LINKS(A1;2);RECHTS(A1;1)&0;0))

Betrifft: AW: Zeit als Zahl eingeben
von: besserist
Geschrieben am: 18.10.2020 12:16:05

Danke, das hilft :-)

Betrifft: AW: Zeit als Zahl eingeben
von: chris b.
Geschrieben am: 15.10.2020 22:37:32

Schau mal was hältst du davon ?
Geht mit 3 oder 4 Zahlen Eingabe.

=WENN(LÄNGE(A1)=4;ZEIT(LINKS(A1;2);RECHTS(A1;2);0);ZEIT(LINKS(A1;2);RECHTS(A1;1)&0;0))

Betrifft: AW: Zeit als Zahl eingeben
von: chris b.
Geschrieben am: 15.10.2020 23:18:47

Hier eine Läsung mit VBA.
Vielleicht nicht Perfekt aber so kommst du zu deinem Wunsch ergebniss hoffe ich??
Lg Chris
Private Sub Worksheet_Change(ByVal Target As Range)
Application.EnableEvents = False

If Target.Value < 24 Then 'länge maximal 2 Stellen
    Cells(Target.Row, Target.Column + 1).NumberFormat = "[$-F400]h:mm:ss AM/PM"
    Cells(Target.Row, Target.Column + 1).FormulaR1C1 = "=TIME(" & Target.Value & ",0,0)"
    Application.EnableEvents = True
    Exit Sub
End If

If Target.Value <= 999 Then ' länge maximal 3 stellen
    Cells(Target.Row, Target.Column + 1).NumberFormat = "[$-F400]h:mm:ss AM/PM"
    h = Left(Target.Value, 2)
    m = Right(Target.Value, 1) & 0
    Cells(Target.Row, Target.Column + 1).FormulaR1C1 = "=TIME(" & h & "," & m & ",0)"
    Application.EnableEvents = True
    Exit Sub
End If

'länge mehr als 3 stellen
    Cells(Target.Row, Target.Column + 1).NumberFormat = "[$-F400]h:mm:ss AM/PM"
    Cells(Target.Row, Target.Column + 1).FormulaR1C1 = "=TIME(" & Left(Target.Value, 2) & "," &  _
Right(Target.Value, 2) & ",0)"
Application.EnableEvents = True

End Sub


Betrifft: AW: Zeit als Zahl eingeben
von: besserist
Geschrieben am: 18.10.2020 12:17:04

Hallo, vielen Dank!

Betrifft: Da hab ich was vor 14 Jahren gemacht ...
von: lupo1
Geschrieben am: 16.10.2020 07:43:26

... (Formeln), es müsste auch in VBA umzusetzen sein:

http://xxcl.de/0018.htm

Betrifft: AW: Da hab ich was vor 14 Jahren gemacht ...
von: besserist
Geschrieben am: 18.10.2020 12:17:56

Hallo Lupo,

das wars, vielen Dank, danach hat ich gesucht.

Viele Grüße

Betrifft: AW: Zeit als Zahl eingeben
von: Robert Amstutz
Geschrieben am: 16.10.2020 08:33:38

Hallo Jörn
Auch ich hatte dieses Problem vor etlichen Jahren. Dabei suchte ich aber nach einer Möglichkeit von Nummereingabe in Minuten:Sekunden,Hundertstel zu umwandeln.
Irgendjemand auf irgendeinem Forum hatte mir damals die perfekte Lösung präsentiert. Evtl. kannst Du diese auch bei Dir anwenden.

Ich schaffe es leider nicht, eine Datei hochzuladen. Evtl. hat es damit zu tun, dass ich auf Parallels arbeite. Wenn Du willst kannst Du mir deine Mail angeben und ich sende dir eine Excel-Datei.
Gruss Robert

Betrifft: AW: Zeit als Zahl eingeben
von: besserist
Geschrieben am: 18.10.2020 12:20:15

Hallo Robert,



vielen Dank. Ich bin mit der Formel vom Lupo zum Ziel gelangt.



trotzdem Danke für die Mühe!



VG

Betrifft: AW: Zeit als Zahl eingeben
von: Louis Siegrist
Geschrieben am: 16.10.2020 12:27:27

Hallo Jörn
Vielleicht hilft dir der folgende Link:
https://www.herber.de/excelformeln/pages/DatumZeit_ohne_Trennpunkte_umwandeln.html
Gruss Louis