Microsoft Excel

Herbers Excel/VBA-Archiv

2 Maximalwerte zum gleichen Zeitpunkt

Betrifft: 2 Maximalwerte zum gleichen Zeitpunkt von: Rossi
Geschrieben am: 23.10.2020 14:19:32

Moin, ich habe eine Frage kurz vor Abschluss meiner Abschätzung.


Ich hoffe ihr könnt mir wieder helfen...riesen Dank im voraus!


https://www.herber.de/bbs/user/141041.xlsx


Es geht darum, dass ein Zustand bestimmt werden soll, der bei einer bestimmten Geschwindigkeit v und unter einer bestimmten Beschleunigung a stattfindet.

Ich habe 5 Zustände definiert. Der Zustand trifft dabei NUR ein, wenn a und v zutreffen. (obere Tabelle)


Ich habe es bei 3 Spalten mit der Funktion SVERWEIS-Fkt ideal nutzen können, jetzt bin ich aber bei 2 Matrizen mit je 2 Spalten und einem Zustandsbereich überfragt. Ich habe es mit einer WENN-…sowie UND-Fkt m.H. einer SVERWEIS-Fkt versucht, aber da kam nichts bei raus.


So sah es bei der kleinen Matrix mit 3 Spalten aus:

=SVERWEIS(K43;$B$1832:$E$1838;3)

Lief einwandfrei und hat auch immer den Wert der 3ten Spalte ausgegeben, wenn der zu prüfende Wert in dem Bereich zwischen Spalte 1 und 2 war.


Jetzt sieht meine Tabelle wie folgt aus (könnte bei Bedarf natürlich komplett umgestaltet werden, aber ich wüsste nicht, inwiefern man es anpassen müsste).

Die rote Schrift zeigt den Betrieb, woraus dann der Faktor der Motoren ermittelt wird. Die gelb markierten Felder sind für die Funktionen.

Ideal wäre es natürlich, wenn jemand die passenden Befehle für BEIDES hätte. Dann könnte ich die Abschätzung direkt abschließen.


Im Prinzip ist der Betrieb des jeweiligen Motors von Bedeutung.

Zu den Beispielen (Tabelle unten):

Beschleunigung 1,5 und Geschwindigkeit 5 passt entweder bei Zustand 3, 3 oder 4.

Der dritte Zustand trifft zu, weil die Beiden Bedingungen unabhängig voneinander sind. Zustand 3 bedeutet VKM 1, EM 1 und Zustand 4 bedeutet (VKM 1, EM 0). Kommt es zu dem Fall, dass BEIDES zutrifft, hat 1 natürlich Priorität. dh Zustand 3 trifft zu. Betrieb: Motor an = 1 höhere Priorität als Motor aus = 0


Es soll nur dieser Faktor(das gelb markierte) ausgegeben werden.


Ich hoffe, ich konnte es verständlich erklären


Gruß Rossi

Betrifft: AW: 2 Maximalwerte zum gleichen Zeitpunkt
von: Felix
Geschrieben am: 24.10.2020 09:28:27

Hallo Rossi,
das lässt sich nicht so leicht durch Formeln darstellen.
Deshalb habe ich mich eine benutzerdefinierte Funktion erstellt, genau zugeschnitten auf deine Aufgabe.
Diese Benutzerdefinierte Funktion lässt sich nur nutzen, wenn du die Datei als .xlsm/.xlsb/.xls speicherst oder die Funktion in ein Add-In .xlam/.xla legst.

Mach dich zu benutzerdefinierten Funktionen am besten selbst noch ein bisschen schlau.

https://www.herber.de/bbs/user/141052.xlsm

Gruß Felix

Betrifft: AW: 2 Maximalwerte zum gleichen Zeitpunkt
von: Rossi
Geschrieben am: 24.10.2020 11:17:49

ich glaub das ist genau das, was ich gesucht habe :-D Ich werde mich damit nochmal intensiver befassen aber auf den ersten Blick ist es genau das was ich brauche :-) die beiden anderen Spalten kann ich ja seperataus dem Zustand zuordnen (die beiden sind in der Abschätzung auch eigenständig). Ich dachte man könnte es verbinden aber das hift mir schon enorm! Riesen Dank

Beiträge aus dem Excel-Forum zum Thema "2 Maximalwerte zum gleichen Zeitpunkt"