Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenn ohne Duplikate

Betrifft: Zählenwenn ohne Duplikate von: Neugierig
Geschrieben am: 25.10.2020 20:01:11

Werte Experten,

Hier meine Beispieldatei:

https://www.herber.de/bbs/user/141080.xlsx

Eine Formel in I1 soll alle Datensätze suchen, die in den Spalten B, D und F ein "x" haben, aber jeder Namen aus A, C und E soll nur einmal auftauchen. In diesem Beispiel wäre 9 das richtige Ergebnis.
Kann mir hier jemand helfen?
Herzlichen Dank im Voraus!

Betrifft: AW: Zählenwenn ohne Duplikate
von: Günther
Geschrieben am: 25.10.2020 20:32:10

Moin,
nurtze Daten | Abrufen und transformieren aka Power Query. Damit geht das mit wenigen Mausklicks.
 
Gruß
Günther  |  mein Excel-Blog

Betrifft: AW: Zählenwenn ohne Duplikate
von: Alwin WeisAngler
Geschrieben am: 25.10.2020 21:23:04

Vorschlag in VBA:
https://www.herber.de/bbs/user/141082.xlsm

Betrifft: per Formel wohl nur mit Hilfsspalte
von: WF
Geschrieben am: 25.10.2020 21:35:55

Hi,

schreib in H10:
=A2&B2
bis H25 runterkopieren

in H30:
=C2&D2
bis H45 runterkopieren

in H50:
=E2&F2
bis H65 runterkopieren

das Ergebnis dann in i1:
=SUMMENPRODUKT((RECHTS(H1:H99)="x")/ZÄHLENWENN(H1:H99;H1:H99&""))
ergibt Deine 9

WF

Betrifft: AW: per Formel wohl nur mit Hilfsspalte
von: Neugierig
Geschrieben am: 25.10.2020 23:34:50

Danke an alle!

Da ich für andere eine Datei zum Ausfüllen und ohne VBA zur Verfügung stellen will, nehme ich die Lösung von WF!
Funktioniert prima!

Betrifft: AW: ohne Hilfsspalte, mit nur einer Formel, ...
von: neopa C
Geschrieben am: 27.10.2020 10:24:20

Hallo,

... in I1:

=SUMMENPRODUKT((ZÄHLENWENNS(A2:E99;A2:E99;B2:F99;B2:F99)*(SPALTE(A1:E1)=1)>0)+(ZÄHLENWENNS(A2:E99;A2:E99;B2:F99;B2:F99)*REST(SPALTE(A1:E1);2)*(SPALTE(A1:E1)>1)=1))

Gruß Werner
.. , - ...

Betrifft: AW: ergänzend angemerkt ...
von: neopa C
Geschrieben am: 27.10.2020 14:03:09

Hallo,

... die Formel geht davon aus, dass wie im Beispiel je Spalte A, C und E für sich allein betrachtet keine Duplikate vorhanden sind. Wenn dies zusätzlich noch berücksichtigt werden soll, dann müsste die Formel erweitert werden. Das ist aber momentan nicht notwendig.

Gruß Werner
.. , - ...

Betrifft: AW: sehr neugierig scheinst Du nicht zu sein owT
von: neopa C
Geschrieben am: 28.10.2020 09:04:40

Gruß Werner
.. , - ...

Betrifft: Die Formel hat ja ne Macke
von: WF
Geschrieben am: 28.10.2020 09:22:55

wie Du selber festgestellt hast.

Betrifft: AW: nein hat sie nicht, die Formel ist korrekt ...
von: neopa C
Geschrieben am: 28.10.2020 09:59:53

Hallo WF,

... ich hattenur darauf hingewiesen, dass bei evtl. vorhandenen Duplikaten im gleichen Spaltenpaar die Formel eine Erweiterung bedarf. Derartiges ist aber aus dem bisherigen Angaben weder ersichtlich noch wahrscheinlich und da sah/seh ich keinen Grund hier eine Monsterformel einzustellen. Es sei denn der TE bedarf einer solchen Lösung. Deswegen hatte ich heute auch "nachgehakt". Wenn dem aber nicht so sein soll, ist mein Formelvorschlag Deiner ziemlich unvollkommenen Hilfsspaltenlösung (sollte mE formelbasierend ermittelt werden, damit sie flexibler auf Datenerweiterung reagieren kann).

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Zählenwenn ohne Duplikate"