Microsoft Excel

Herbers Excel/VBA-Archiv

Ergebnisliste abhängig von 3 Variablen

Betrifft: Ergebnisliste abhängig von 3 Variablen von: Dennis
Geschrieben am: 26.10.2020 12:35:04

Hallo zusammen,

als stiller Leser hat mir dieses Forum schon sehr oft weiter geholfen.
Bevor ich zu meiner eigentlichen Frage kommen, kurz zu meinem Background.
Ich arbeite (beruflich) sehr viel und auch erfolgreich mit Excel und VBA. Inzwischen sind meine Kenntnisse hier schon recht gut. Allerdings läuft das bei mir so, dass ich ein Verständnis dafür habe, wie etwas in VBA umgesetzt werden kann. Den Code recorde ich dann häufig oder Suche ich mir aus alten Arbeitsmappen und/ oder aus Foren.

Jetzt zu meiner Frage.
Ich stehe vor der Herausforderung, in einer Ergebnisliste Werte darzustellen (hier: Lagerfächer), die von 3 Variablen (Lagerort, Datum, Artikelnummer) abhängig sind.
Lager und Datum finden sind in den Zellen B1 und B2, die Artikelnummer jeweils als Überschrift über den Zellen, wo ich die Ergebnisliste benötige (s. Beispieldatei Tabelle2).
Die Basisdaten befinden sich auf Tabellenblatt Tabelle1.

Ich habe schon probiert mit einer (auch aus dem Internet übertragenen Index-Formel) zu arbeiten, was aber nicht den gewünschten Erfolg gebracht hat.

Deswegen wende ich mich jetzt an Euch, in der Hoffnung, dass ihr mir bei diesem konkreten Fall helen könnt bzw. einen Ansatz geben könnt.

Bei Fragen, germe melden.
Viele Grüße
Dennis

PS: In der Beispieldatei habe ich die erwartete/gewünschte Ergebnisliste zur Veranschaulichung manuell eingetragen.

Beispieldatei: https://www.herber.de/bbs/user/141088.xlsx

Betrifft: AW: Ergebnisliste abhängig von 3 Variablen
von: SF
Geschrieben am: 26.10.2020 12:40:08

Hola,

=WENNFEHLER(INDEX(Tabelle1!$D:$D;AGGREGAT(15;6;ZEILE(Tabelle1!$D$2:$D$57)/((Tabelle1!$A$2:$A$57=$B$1) *(Tabelle1!$B$2:$B$57=$B$2)*(Tabelle1!$C$2:$C$57=E$1));ZEILE(A1)));"")

Gruß,
steve1da

Betrifft: AW: Ergebnisliste abhängig von 3 Variablen
von: Dennis
Geschrieben am: 26.10.2020 13:04:24

Super - vielen Dank. Das funktioniert einwandfrei.

Von meinem bisherigen Ansatz garnicht so weit weg. Jetzt begebe ich mich mal auf die Suche, wo genau der Unterschied zu meinem Ansatz ist.

Vielen dank nochmal.

Beiträge aus dem Excel-Forum zum Thema "Ergebnisliste abhängig von 3 Variablen"