Microsoft Excel

Herbers Excel/VBA-Archiv

Datenüberprüfung

Betrifft: Datenüberprüfung von: Fritz_W
Geschrieben am: 26.10.2020 14:44:19

Hallo Forumsbesucher,

wie kann ich mit Hilfe der Datenüberprüfung erreichen, dass in eine Zelle nur Dezimalzahlen zwischen 0 und 8 eingegeben werden können, die Dezimalstellen aber nur 2 Dezimalstellen betragen darf.

Im Voraus besten Dank für eure Unterstützung

mfg
Fritz

Betrifft: AW: Datenüberprüfung
von: Pierre
Geschrieben am: 26.10.2020 15:31:52

Hallo Fritz,

Datenüberprüfung - Benutzerdefiniert - Formel:
=WENN(UND($A$1>=0;$A$1<=8);REST($A1*10^2;1)=0;"")
Gruß Pierre

Betrifft: AW: Datenüberprüfung
von: Fritz_W
Geschrieben am: 26.10.2020 15:43:57

Hallo Pierre,

super, vielen herzlichen Dank.

mfg
Fritz

Betrifft: mit benutzerdefinierte Formel
von: WF
Geschrieben am: 26.10.2020 15:34:19

=(A1>=0)*(A1<=8)*(REST(A1*100;1)=0)

WF

Betrifft: AW: mit benutzerdefinierte Formel
von: Fritz_W
Geschrieben am: 26.10.2020 18:10:28

Hallo WF,

perfekt, danke und beste Grüße

Fritz

Betrifft: Nur 1x A1: =ODER(A1+1=ZEILE($100:$900)%)
von: lupo1
Geschrieben am: 27.10.2020 08:31:58



Betrifft: AW: Nur 1x A1: =ODER(A1+1=ZEILE($100:$900)%)
von: Fritz_W
Geschrieben am: 27.10.2020 09:21:47

Hallo Lupo

Ja, ganz toll, vielen Dank und Gruß
Fritz

Betrifft: Erkennst Du auch den Nachteil meiner Formel?
von: lupo1
Geschrieben am: 27.10.2020 09:26:15



Betrifft: 1x im Formeltext aber 800x in der
von: Daniel
Geschrieben am: 27.10.2020 09:48:55

tatsächlichen Berechnung

Betrifft: Genau, i Ggs z WF mit nur 3 Wahrheitsprüfungen
von: lupo1
Geschrieben am: 27.10.2020 09:51:28