Microsoft Excel

Herbers Excel/VBA-Archiv

geordneter Verweis

Betrifft: geordneter Verweis von: Bernd
Geschrieben am: 27.10.2020 06:49:44

Moin zusammen,

ich habe eine Daten, deren Inhalt ich nach gewissen Kriterien sortiert in einem anderen Blatt angezeigt bekommen möchte.

In der Beispieldatei werden die Spalten a-k aus einem anderen System übernommen. Die Spalten M-Q sind die Kriterien nach denen in einem anderen Blatt sortiert werden soll. Dabei soll der Text der Spalte L mit übernommen werden.

Im Beispiel möchte ich im Blatt SR die Daten haben die in der Spalte M ein Kreuz haben.
Im Blatt SR steht zur eindeutigen Identifikation in der Zelle A1 die Überschrift der Spalte M aus dem Blatt Original.
In der Spalte A soll dann nach der Identifikation sowie nach Zelle A1 sortiert werden. (Das ist das was ich nicht hinbekomme!!!). In den Spalten B und C würde ich dann mit einem sverweis in Bezug auf Spalte A arbeiten.

Wäre sehr lieb wenn mir da jemand helfen könnte.

Vielen Dank !

https://www.herber.de/bbs/user/141116.xlsx

Betrifft: AW: geordneter Verweis
von: SF
Geschrieben am: 27.10.2020 06:54:34

Hola,

=WENNFEHLER(INDEX(Original!$D$2:$D$9;AGGREGAT(15;6;ZEILE(Original!$D$2:$D$9) -1/(Original!$M$2:$M$9="x");ZEILE(A1)));"")
Den Rest schaffst du alleine ;-)

Gruß,
steve1da

Betrifft: AW: geordneter Verweis
von: Bernd
Geschrieben am: 27.10.2020 07:10:50

Moin steve1da, vielen lieben Dank für die super schnelle Antwort.
Und ob du es glaubst oder nicht: Den Rest habe ich alleine geschafft :-) !!!

Noch einen schönen Tag !

LG Bernd

Betrifft: AW: alternativ AGGREGAT() und SVERWEIS() ...
von: neopa C
Geschrieben am: 27.10.2020 08:48:25

Hallo Bernd,

... in A3: =WENNFEHLER(AGGREGAT(15;6;Original!D$2:D$99/(Original!M$2:M$99="x");ZEILE(A1));"")

und nach unten kopieren und in Spalte B und C mit SVERWEIS() auf das Ergebnis in Spalte A kombiniert mit VERGLEICH() mit Bezug auf den Eintrag in Zeile 2 für das 3. Argument der SVERWIS()-Funktion.

Gruß Werner
.. , - ...

Betrifft: AW: alternativ AGGREGAT() und SVERWEIS() ...
von: Bernd
Geschrieben am: 27.10.2020 20:43:53

Moin Werner, auch dir einen lieben Dankesgruß.

VG Bernd

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 28.10.2020 09:01:55

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "geordneter Verweis"