Microsoft Excel

Herbers Excel/VBA-Archiv

Sverwei mit mehreren Suchkriterien

Betrifft: Sverwei mit mehreren Suchkriterien von: Sebastian
Geschrieben am: 30.10.2020 09:04:03

Hallo,


in Spalte A habe ich Werte von ausgelesene DataMatrix-Codes, die zu einem bestimmten Bauteil gehören (beide in Mappe 2).

In Spalte C ist das Auslesedatum angegeben (bsp.: 30.10.2020 08:55:40). In einer anderen Arbeitsmappe (Mappe 1="Datenabfrage") sind ebenso in Spalte A die Werte des DataMatrix-Codes angegeben und in Spalte C das Auslesedatum (im gleichen Format wie oben). In Mappe 1 sind allerdings noch weitere Werte zu den Bauelementen angegeben (Spalte 36), die ich in Mappe 2 mir zugeordnet nach DataMatrix-Code und gleichem Datum anzeigen lassen möchte. Achtung: DIe Uhrzeit ist beim gleichen Datum nicht unbedingt die gleiche! Daher müsste diese irgendwie ausgeblendet werden. Ich habe die nun mit folgender Formel versucht:


=SVERWEIS(A4&TEXT(C4;"TT.MM.JJ");WAHL({1.3};(Datenbankabfrage!$A$2:$A$1000) &(TEXT(Datenbankabfrage!$C$2:$C$1000;"TT.MM.JJ"));(Datenbankabfrage!$AJ$2:$AJ$1000));36;FALSCH)


Leider bekomm ich hier nur "#NV" angegeben und ich weiß nicht warum... Könntet ihr mir helfen?


Viele Grüße

Sebastian

Betrifft: AW: (D)eine (Beispiel)datei könnte aufklären owT
von: neopa C
Geschrieben am: 30.10.2020 09:08:25

Gruß Werner
.. , - ...

Betrifft: AW: Sverwei mit mehreren Suchkriterien
von: SF
Geschrieben am: 30.10.2020 09:09:41

Hola,

du hast die Formel als Matrixformel abgeschlossen?
Ansonsten:
https://www.herber.de/excelformeln/pages/SVERWEIS_bei_mehrspaltigen_Suchkriterien_Mehrfachtreffer.html

Gruß,
steve1da

Betrifft: AW: Sverwei mit mehreren Suchkriterien
von: Sebastian
Geschrieben am: 30.10.2020 09:41:21

Hallo Danke für eure Antworten. Leider funktioniert mein Dateiupload nicht. ich versuch es mal hier darzustellen:

Inhalt Mappe 1:
DMC Art Datum weitere Werte der Bauteile
1 neu 01.01.2020 08:05 20
1 alt 02.01.2020 08:05 17
1 alt 03.01.2020 08:05 15
1 alt 04.01.2020 08:05 13
1 alt 05.01.2020 08:05 11
2 neu 01.01.2020 08:05 23
2 alt 02.01.2020 08:05 14
2 alt 03.01.2020 08:05 13
2 alt 04.01.2020 08:05 22
2 alt 05.01.2020 08:05 11
3 neu 01.01.2020 08:05 19
3 alt 02.01.2020 08:05 17
3 alt 03.01.2020 08:05 7
3 alt 04.01.2020 08:05 6

Inhalt Mappe 2:
DMC Größe Datum hier sollen die zugeordneten Werte aus Tabelle 1 stehen
1 4 01.01.2020 08:00
1 7 02.01.2020 08:00
1 5 03.01.2020 08:00
1 4 04.01.2020 08:00
1 3 05.01.2020 08:00
2 6 01.01.2020 08:00
2 8 02.01.2020 08:00
2 5 03.01.2020 08:00
2 6 04.01.2020 08:00
2 7 05.01.2020 08:00
3 9 01.01.2020 08:00
3 11 02.01.2020 08:00
3 2 03.01.2020 08:00
3 3 04.01.2020 08:00

In Mappe 2 sollen dann die zugeordneten Werte stehen.
Viele Grüße

Betrifft: AW: Mappen ? oder doch Tabellenblatter ? ---
von: neopa C
Geschrieben am: 30.10.2020 09:52:06

Hallo Sebastian,

... und warum stellst Du Deine Datei nicht ein?

Gruß Werner
.. , - ...

Betrifft: AW: Mappen ? oder doch Tabellenblatter ? ---
von: Sebastian
Geschrieben am: 30.10.2020 09:55:09

Hallo, weil es leider nicht funktioniert

Betrifft: AW: Mappen ? oder doch Tabellenblatter ? ---
von: SF
Geschrieben am: 30.10.2020 10:00:06

Hola,

Matrixformel? Link angeschaut?

Gruß,
steve1da

Betrifft: AW: Mappen ? oder doch Tabellenblatter ? ---
von: Sebastian
Geschrieben am: 30.10.2020 10:04:48

Hey,

danke, ich habe es gerade mit Shift+Strg+Enter versucht, aber auch hier kommt #NV bei raus...

Betrifft: AW: Mappen ? oder doch Tabellenblatter ? ---
von: Sebastian
Geschrieben am: 30.10.2020 10:13:21

Hey,

es hat sich was getan. In einigen Zellen wird jetzt ein Wert angegeben, allerdings nicht der aus der gewünschten Spalte sonder die Kombination aus DataMatrix-Code und Datum (das geht wahrscheinlich auf die "&"-Funktion zurück). Wie komm ich da weiter? Ich habe die Formel nun wie folgt angepasst:

={SVERWEIS(A2&TEXT(C2;"TT.MM.JJ");WAHL({1.3};(Datenbankabfrage!$A$2:$A$1000) &(TEXT(Datenbankabfrage!$C$2:$C$1000;"TT.MM.JJ"));(Datenbankabfrage!$A$2:$AJ$1000));36;FALSCH) }

Wo liegt denn da mein Denkfehler?

Betrifft: AW: Mappen ? oder doch Tabellenblatter ? ---
von: SF
Geschrieben am: 30.10.2020 10:22:09

Hola,

ohne Beispieldatei wird das wilde Raterei.
Was bedeutet denn "Upload funktioniert nicht" genau?

Gruß,
steve1da

Betrifft: AW: hier liegt die Beispieldatei
von: Sebastian
Geschrieben am: 30.10.2020 10:41:32

hier liegt die Beispieldatei

https://www.herber.de/bbs/user/141184.xlsx

Betrifft: AW: hier liegt die Beispieldatei
von: SF
Geschrieben am: 30.10.2020 10:47:30

Hola,

=INDEX(Tabelle1!$D$2:$D$15;AGGREGAT(15;6;ZEILE(Tabelle1!$D$2:$D$15)-1/((Tabelle1!$A$2:$A$15=A2) *(GANZZAHL(Tabelle1!$C$2:$C$15)=GANZZAHL(C2)));1))

Gruß,
steve1da

Betrifft: AW: hier liegt die Beispieldatei
von: Sebastian
Geschrieben am: 30.10.2020 11:00:55

Hey,

in der Beispieldatei funktionierts. In der Datei, in der ich es eigentlich laufen lassen möchte nicht. Da kommt #Zahl bei raus. Leider versteh ich die Funktion Aggregat nicht und auch nicht warum du am Ende mit Ganzzahl arbeitest

Betrifft: AW: hier liegt die Beispieldatei
von: SF
Geschrieben am: 30.10.2020 11:02:32

Hola,

mit Ganzzahl() holt man aus einer Zelle mit Datum und Uhrzeit nur das Datum heraus.
Warum es in der Originaldatei nicht funktioniert kann man nicht beantworten.

Gruß,
steve1da

Betrifft: AW: also doch keine Mappen ...
von: neopa C
Geschrieben am: 30.10.2020 11:04:32

Hallo Sebastian,

...in D2:

=WENNFEHLER(A2&TEXT(C2;"TT.MM.")&TEXT(INDEX(Tabelle1!D:D;AGGREGAT(15;6;ZEILE(D$2:D$15)/(Tabelle1!A$2:A$99=A2)/(KÜRZEN(Tabelle1!C$2:C$99;)=KÜRZEN(C2;));1));"00");"")

und nach unten kopieren.

Gruß Werner
.. , - ...

Betrifft: AW: solltest Du einen Mac im Einsatz haben ...
von: neopa C
Geschrieben am: 30.10.2020 10:16:30

Hallo Sebastian,

... dann kannst Du Deine Datei gezippt hier einstellen.

Vielleicht solltest Du auch Dein angegebenes Excelprofil überdenken.

Gruß Werner
.. , - ...

Betrifft: AW: solltest Du einen Mac im Einsatz haben ...
von: Sebastian
Geschrieben am: 30.10.2020 10:18:03

Nein, kein Mac und auch Excel 2016 stimmt.

VG Sebastian

Betrifft: AW: meine erste Frage ist noch offen owT
von: neopa C
Geschrieben am: 30.10.2020 10:23:03

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Sverwei mit mehreren Suchkriterien"