Microsoft Excel

Herbers Excel/VBA-Archiv

Zeilennummer von Bereichsanfang u.- ende

Betrifft: Zeilennummer von Bereichsanfang u.- ende von: Thomas
Geschrieben am: 30.10.2020 09:42:01

Liebe Excel Gemeinde,

ich bräuchte bitte Euren Rat.
In Spalte A stehen Datumsangaben.
Manchmal aufeinanderfolgende Tage manchmal mit Sprüngen von mehreren Tagen.
Ziel soll sein die Bereiche zu identifizieren, bei denen die Differtenz zwischen den Daten 1 ist.
Anschließend soll die Zeilennummer des erste Datums und des letzt Datums in der entsprechenden Zeile der Spalte B ausgegeben werden.
Ist die Different größer als 1 beginn also ein neuer zu analysierender Bereich.
eine Bsp. Datei habe ich angehängt siehe Link.
Habt Ihr eine Idee?

Danke und Gruß
Thomas

https://www.herber.de/bbs/user/141180.xlsx

Betrifft: AW: warum ein neuer thread? Siehe unten! owT
von: neopa C
Geschrieben am: 30.10.2020 09:53:36

Gruß Werner
.. , - ...

Betrifft: AW: Zeilennummer von Bereichsanfang u.- ende
von: fcs
Geschrieben am: 30.10.2020 10:37:14

Hallo Thomas,

Hier eine Formel-Lösung
Die 0 Werte in Spalte D werden dann durch eine benutzerdefinierte Formatierung ausgeblendet.

LG
Franz
HTML add In




Tabelle1
 ABCDE
1EinsatzZeilennummerDiffZeilennummerDiff
230.09.20202 2 
301.10.2020  0 
402.10.20204242
505.10.20205 5 
606.10.20206161
719.10.20207 7 
820.10.2020  0 
921.10.2020  0 
1022.10.2020103103
1128.10.202011 11 
1229.10.2020121121

verwendete Formeln
Zelle Formel Bereich N/A
C4=B4-B2  
C10=B10-B7  
C6,C12=B6-B5  
D2: D12=WENN(ZEILE()=2;2;WENN(UND((A2-A1)=1;(A3-A2)=1);0;ZEILE()))  
E2:E12=WENNFEHLER(WENN(ODER(UND((D2-D1)=1;(A2-A1)=1);UND(D2>0;D1=0));D2-MAX(D$1:$D1);"");"")  

Zahlenformate
Zelle Format Inhalt
A2 'TT.MM.JJJJ  44104
A3 'TT.MM.JJJJ  44105
A4 'TT.MM.JJJJ  44106
A5 'TT.MM.JJJJ  44109
A6 'TT.MM.JJJJ  44110
A7 'TT.MM.JJJJ  44123
A8 'TT.MM.JJJJ  44124
A9 'TT.MM.JJJJ  44125
A10 'TT.MM.JJJJ  44126
A11 'TT.MM.JJJJ  44132
A12 'TT.MM.JJJJ  44133
D2 '0;-0;""  2
D3, D8: D9 '0;-0;""  0
D4 '0;-0;""  4
D5 '0;-0;""  5
D6 '0;-0;""  6
D7 '0;-0;""  7
D10 '0;-0;""  10
D11 '0;-0;""  11
D12 '0;-0;""  12
Zellen mit Format Standard werden nicht dargestellt
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.21 einschl. 64 Bit






Betrifft: AW: Zeilennummer von Bereichsanfang u.- ende
von: Thomas
Geschrieben am: 30.10.2020 10:48:58

Tausend Dank an Alle

neuer thread weil ich dachte ich habe mich "verquert" aussgedrückt.
Danke und Gruß
Thomas

Beiträge aus dem Excel-Forum zum Thema "Zeilennummer von Bereichsanfang u.- ende"