Microsoft Excel

Herbers Excel/VBA-Archiv

Anwesenheit

Betrifft: Anwesenheit von: Lena93
Geschrieben am: 03.11.2020 10:44:41

Guten Tag,

ich habe eine Liste mit Beginn/Ende. Daraus möchte ich anhand von Formeln eine Anwesenheitsliste erstellen.

In der Datei ist ein Beispiel zu erkennen, wie ist es gerne haben möchte. Ich weiß nur nicht, wie da die Lösung aussehen könnte.

https://www.herber.de/bbs/user/141269.xlsx


Ich bedanke mich für Eure Unterstützung und mfG Leni

Betrifft: AW: Anwesenheit
von: Yal
Geschrieben am: 03.11.2020 13:42:26

Hallo Lena,

eine komplizierte Zusammenstellung.

Ich würde zuert spaltenweise organisieren:
_ Spalte 1: die Zeiten
_ Spalte 2: Anfang
_ Spalte 3: Ende
_ Spalte 4: Dauer (beachte, wenn Ende vor Anfang steht:
=WENN(C2<B2;C2 + "24:00";C2)-B2
_ Spalte 5: die Anwesenheitbewertung an Anhadn eines SVerweis (Detail im Online-Hilfe):
=SVERWEIS(D2;$G$5:$H$28;2;1)

Ansonsten habe ich nicht soviel verstanden...


Viel Erfolg
Yal

Betrifft: AW: Anwesenheit
von: Lena93
Geschrieben am: 03.11.2020 14:43:37

Hallo,
ok, ich versuche es. Ansonsten melde ich mich wieder im Forum. Vielen Dank.

Betrifft: AW: zur vorhanden Datenstruktur ...
von: neopa C
Geschrieben am: 03.11.2020 17:54:59

Hallo Lena,

... würde ich vorschlagen diese wie wie folgt ändern.

Dann kannst Du mit der Hilfstabellenformel in D5 (diese weit genug ziehend nach rechts und unten kopieren) die einzelnen Differenzzeiten besser ermitteln und mit der einfachen Summenformel in B5 ( nach uten kopieren) die von Dir angestrebten Ergebniswerte leicht und nachvollziehbar ermitteln.

Arbeitsblatt mit dem Namen 'Tabelle2'
 ABCDEFGHI
1   06:30 - 16:3014:10 - 22:0006:25 - 14:1521:55 - 06:3506:30 - 16:30 
2  BEGINN6:3014:1006:2521:5506:30 
3  ENDE16:3022:0014:1506:3516:30 
4ZeitSumme       
500:001,0    1,  
601:001,0    1,  
702:001,0    1,  
803:001,0    1,  
904:001,0    1,  
1005:001,0    1,  
1106:001,0    1,  
1207:002,167 0,5 0,5830,5830,5 
1308:003,0 1, 1, 1, 
1409:003,0 1, 1, 1, 
1510:003,0 1, 1, 1, 
1611:003,0 1, 1, 1, 
1712:003,0 1, 1, 1, 
1813:003,0 1, 1, 1, 
1914:003,0 1, 1, 1, 
2015:003,083 1,0,8330,25 1, 
2116:003,0 1,1,  1, 
2217:002,0 0,51,  0,5 
2318:001,0  1,    
2419:001,0  1,    
2520:001,0  1,    
2621:001,0  1,    
2722:001,083  1, 0,083  
2823:001,0    1,  
2900:001,0    1,  
30         

ZelleFormel
B5=SUMME(D5:Z5)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Gruß Werner
.. , - ..

Betrifft: AW: ergänzend hierzu ...
von: neopa C
Geschrieben am: 03.11.2020 19:05:38

Hallo,

... habe gerade festgestellt, dass ich die entscheidende Hilfszellenformel D5 vorhin nicht dargestellt habe.

Diese:

=(D$3<D$2)+VORZEICHEN(D$3-D$2)*MAX((MIN($A5;MAX(D$2;D$3))-MAX($A5-1/24;MIN(D$2;D$3)))*24;0)

nach rechts und unten kopieren.

Gruß Werner
.. , - ...

Betrifft: Auch ergänzend hierzu …
von: Günther
Geschrieben am: 04.11.2020 20:08:38

Ist es nicht herzerfrischend, mit welchem Enthusiasmus sich die TE eurer Vorschläge annimmt und euch mit einem entsprechenden Feedback dankt?

Übrigens: Eine interessante und auch heraufordernde Aufgabe für PQ-Forscher ;-)
 
Gruß
Günther  |  mein Excel-Blog

Beiträge aus dem Excel-Forum zum Thema "Anwesenheit"