Microsoft Excel

Herbers Excel/VBA-Archiv

Durch. Wert gewichten mit bei selbem Erg

Betrifft: Durch. Wert gewichten mit bei selbem Erg von: Daniel
Geschrieben am: 04.11.2020 17:29:59

Hallo,


ich benötige etwas Hilfe bei einer Rechenlogik :)


Folgendes Beispiel: Ich habe einen jährlichen Betrag von durchschnittlich 10.000€ den ich pro Unternehmen einnehme. Insgesamt bekomme ich über einen Zeitraum von 4 Jahren 90 jährliche Zahlungen, d.h. ich nehme ich über die 4 Jahre 900.000€ ein. Allerdings kommen über den Zeitraum der 4 Jahre immer wieder neue Unternehmen hinzu, insgesamt 40 Unternehmen (die in Summe 90x zahlen. Soweit so gut :) Nun sind die 40 Unternehmen aber in 4 Gruppen eingeordnet und ich möchte den durchschnittlichen Betrag von 10.000€ unterscheiden, so dass z.B. Unternehmen der Gruppe A einen geringeren jährlichen Betrag bezahlen und Unternehmen der Gruppe D einen deutlich höheren jährlichen Betrag. Am Ende möchte ich aber trotzdem auf die 900.000€ kommen. Problem hierbei ist für mich, dann immer wieder neue Unternehmen innerhalb der 4 Jahr dazukommen.


Ich habe mal ein vereinfachtes Excel erstellt: https://www.herber.de/bbs/user/141312.xlsx


Könnt ihr mir hier helfen? Wie kann ich eine Faktor/Gewichtung einbauen, so dass sich der durchschnittliche Beitrag entsprechend anpasst, aber in Summe trotzdem die 900.000€ zustande kommen?


Beste Grüße

Daniel

Betrifft: Du hast einen unendlichen Ergebnisraum ...
von: lupo1
Geschrieben am: 04.11.2020 17:56:03

... mangels weiterer Bedingungen.

Im Beispiel sind übrigens die ersten 3 10.000 korrekt Null.

Betrifft: AW: Du hast einen unendlichen Ergebnisraum ...
von: Daniel
Geschrieben am: 04.11.2020 18:07:45

Ok, danke. Wie kann ich das noch weiter einschränken? Kann ich nicht 3 Faktoren/Gewichtungen (z.B. Für Gruppen A-C) vorgeben und die 4. Gruppe als Delta/Ausgleich nutzen?

Betrifft: AW: Du hast einen unendlichen Ergebnisraum ...
von: Daniel
Geschrieben am: 04.11.2020 18:07:47

Ok, danke. Wie kann ich das noch weiter einschränken? Kann ich nicht 3 Faktoren/Gewichtungen (z.B. Für Gruppen A-C) vorgeben und die 4. Gruppe als Delta/Ausgleich nutzen?

Betrifft: AW: eine evtl. Möglichkeit wäre ...
von: neopa C
Geschrieben am: 04.11.2020 19:08:16

Hallo Daniel,

... folgende (hier mal mit zwei "Faktoren" in Form von Zu-/Abschlag):

Z.B. in H4: -20% und in H6: +25%

Dann folgende Formel in G15: =WENN(RECHTS(B15;1)="D";C$10-SUMME(G$14:G14);C$10/G$8*G4*(1+H4))
nach unten kopieren.

und in C15: =$G15/$G4*(C4>0)
und diese nach unten und rechts kopieren.


Gruß Werner
.. , - ...