Microsoft Excel

Herbers Excel/VBA-Archiv

Matrixformel mit KGRÖSSTE

Betrifft: Matrixformel mit KGRÖSSTE von: Michael
Geschrieben am: 28.11.2020 11:28:57

Hallo Leute,

ich möchte Folgendes umsetzen: Ich habe 2 Spalten, eine mit dem Alter von Personen (Spalte C), die andere mit dem Gewicht (Spalte D).
Ziel ist es das Gesamtgewicht der 3 ältesten Personen zu bestimmen. Mein Versuch:

{=SUMME(WENN(C4:C9=KGRÖSSTE(C4:C9;ZEILE(1:3));D4:D9;0))}

Resultat ist der Fehler: "'#NV". Ohne "Summe" erhalte ich in 3 Zellen die Werte 80, 62 und 65. Wieso kann ich diese nicht summieren?

Hier die Demodatei:
https://www.herber.de/bbs/user/141901.xlsx
Mir ist es wichtig das Thema Matrixformeln wirklich zu verstehen, bitte daher KEIN simples Posten einer Alternativlösung, ich suche eine Erklärung, warum mein Versuch nicht funktioniert.

Beste Grüße und vielen Dank im Voraus
Michael

Betrifft: AW: Matrixformel mit KGRÖSSTE
von: Daniel
Geschrieben am: 28.11.2020 12:06:51

Hi

Ich vermute mal, dass die Doppelte Matrix (einmal über die Zeilen 1-3 und die zweite über die Zeilen 4-9) Excel hier über fordert.

Eine Matrixformel bildet ja eine For-Next-Schleife über den verwendeten Zellbereich und hier müssten zwei schleifen ineinander geschachtelt werden und ich vermute, das kann Excel noch nicht.

Gruß Daniel

Betrifft: AW: Matrixformel mit KGRÖSSTE
von: Michael
Geschrieben am: 28.11.2020 12:26:52

Vielen Dank Daniel, das macht Sinn!

Hast du eine Idee, wie ich diese -vermeintlich leichte- Herausforderung bewältigen kann? Also quasi ein Summwenn mit KGRÖSSTE!?

Betrifft: AW: Matrixformel mit KGRÖSSTE
von: Daniel
Geschrieben am: 28.11.2020 16:29:34

"bitte daher KEIN simples Posten einer Alternativlösung, ich suche eine Erklärung, warum mein Versuch nicht funktioniert."

Es war dein Wunsch, keine alternativlösung zu bekommen


Gruß Daniel

Betrifft: AW: Matrixformel mit KGRÖSSTE
von: Besserwisser
Geschrieben am: 28.11.2020 12:56:11


Hallo Michael,


={SUMME(WENN(C4:C9>KGRÖSSTE(C4:C9;4);D4:D9))}

Gruß


Christian

Betrifft: AW: Matrixformel mit KGRÖSSTE
von: Michael
Geschrieben am: 28.11.2020 13:04:30

Christian, du bist eine Maschine! Vielen Dank dir!

Betrifft: AW: Matrixformel mit KGRÖSSTE
von: Besserwisser
Geschrieben am: 28.11.2020 13:19:08

Hallo Michael,

besser ist falls Duplikate und tatsächlich immer die höchsten drei, in Deinem Beispiel gäbe es Probleme, wenn z. B. 19 3x vorkommt.

={SUMME(WENN(C4:C9-ZEILE(C4:C9)%%>KGRÖSSTE(C4:C9-ZEILE(C4:C9)%%;4);D4:D9))}

Gruß


Christian

Betrifft: AW: Matrixformel mit KGRÖSSTE
von: Michael
Geschrieben am: 28.11.2020 14:24:52

Vielen Dank Christian, eine Frage hätte ich noch, wenn ich darf. Wie würde ich vorgehen, wenn ich noch eine weiteres Kriterium hätte? Z. B. sollen nur die Personen betrachtet werden die Manuel heißen (Spalte B).

Mein Versuch:
=MITTELWERT(WENN(B4:B10="Manuel";WENN(C4:C10>KGRÖSSTE(C4:C10;4);D4:D10);""))
Das Ganze geht nicht auf, weil jetzt das durchschn. Gewicht von den Manuels genommen wird, die von allen Personen zu den 3 ältesten gehören (könnte ja sogar sein, dass dies bei keinem Manuel zutrifft).


Kann man das so schreiben, dass von alle Manuels geschaut wird, welche die 3 ältesten Manuels sind und davon das durchschn. Gewicht nehmen?

Das wäre die Datei:
https://www.herber.de/bbs/user/141905.xlsx

Betrifft: AW: Matrixformel mit KGRÖSSTE
von: Michael
Geschrieben am: 28.11.2020 14:31:10

PS:
Gerade probiert und so geht es wohl. Ka ob das die eleganteste Lösung ist:
=MITTELWERT(WENN(B4:B10="Manuel";WENN(C4:C10>KGRÖSSTE(WENN(B4:B10="Manuel";C4:C10);4);D4:D10);"")) 


Betrifft: AW: geht ganz ohne {}-Formel ...
von: neopa C
Geschrieben am: 29.11.2020 10:20:02

Hallo Michael,

.. wenn Du als Excelversion zumindest Excel 2010 im Einsatz hast.

Dann so: =MITTELWERTWENNS(D:D;B:B;"Manuel";C:C;">="&AGGREGAT(14;6;C4:C10/(B4:B10="Manuel");3))

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Matrixformel mit KGRÖSSTE"