Microsoft Excel

Herbers Excel/VBA-Archiv

Überschuss addieren

Betrifft: Überschuss addieren von: Tom
Geschrieben am: 08.04.2021 16:04:36

Hallo,

ich bin neu hier und fange gerade für den Privaten Gebrauch ein bisschen mit Excel an und habe schon die erste Frage.

Wie in der Beispieldatei zu sehen ( https://www.herber.de/bbs/user/145397.xlsx ), möchte ich alles was über 8 geht,addieren.
Bei dem Beispiel müsste dann unterm Strich 7 bei raus kommen.

Vielen Dank schon mal

Betrifft: AW: so: =SUMMENPRODUKT((C4:C9>8)*(C4:C9-8)) owT
von: neopa C
Geschrieben am: 08.04.2021 16:06:42

Gruß Werner
.. , - ...

Betrifft: AW: so: =SUMMENPRODUKT((C4:C9>8)*(C4:C9-8)) owT
von: Tom
Geschrieben am: 08.04.2021 17:19:42

Hi ich bins noch mal.
Soweit habe ich jetzt alles übertragen.
Problem ist,wenn ich in den Zellen was anderes einfüge, habe ich in Zelle D37,daß mir den Überschuss ausrechnet,
keinen Wert mehr.
Habe hier mal die ganze Tabelle hochgeladen um zu veranschaulichen,was ich überhaupt vor habe.
https://www.herber.de/bbs/user/145399.xlsx

Sorry nochmal, aber die Fehler sehe ich ja erst beim erstellen.

Gruss

Betrifft: AW: dann bedarf es anderen Rechnung ...
von: neopa C
Geschrieben am: 08.04.2021 17:36:42

Hallo Tom,

... folgende Formel: {=SUMME(WENN(ISTZAHL(D3:D31)*(D3:D31>8)*(A3:A31<>"So");D3:D31-8))}

Die geschweiften Klammern{} werden nicht mit eingegeben. Beende die Formeleingabe mit Strg + Shift + Enter, statt Enter alleine.

Gruß Werner
.. , - ...

Betrifft: AW: dann bedarf es anderen Rechnung ...
von: Tom
Geschrieben am: 08.04.2021 18:24:21

Danke klappt.

Was bedeutet den das So?

Betrifft: AW: das "So" hast Du für den Sonntag zu stehen owT
von: neopa C
Geschrieben am: 08.04.2021 18:34:18

Gruß Werner
.. , - ...

Betrifft: AW: dann bedarf es anderen Rechnung ...
von: Tom
Geschrieben am: 09.04.2021 17:19:53

Hallo Werner,

soweit klappt alles.
Ich bekomme, wie hier zu sehen, https://www.herber.de/bbs/user/145418.xlsx die eingetragenen Stunden nicht rein.
Sonntage werden auch nicht addiert bzw. unten als Überstunden angezeigt. Habe die Formel (falls richtig) um die Wochenenden
erweitert.

Danke

Betrifft: AW: die So-Stunden und mehr dazu ...
von: neopa C
Geschrieben am: 09.04.2021 17:32:03

Hallo Tom,

.. . könntest Du einfach mit folgender Formelergänzung: ...+SUMMEWENN($B3:$B33;"So";D3:D33) ermitteln,

Wie ich aber jetzt Deiner Beispieldatei entnehmen kann, sollen wohl auch evtl. Sa-Stunden auch noch addiert werden?

Außerdem wäre Deinerseits noch zu klären, wie mit den So-Stunden in einer Nachtschicht zu verfahren ist. Momentan würden die durch meine hier angegebene Formelerweiterung "doppelt" berechnet. Gib also dafür eine eindeutige Regelung vor.

Gruß Werner
.. , - ...

Betrifft: AW: die So-Stunden und mehr dazu ...
von: Tom
Geschrieben am: 09.04.2021 18:07:53

Hi,
richtig. Alle grauen Felder (Wochenenden) sollen (falls evtl. Überstunden anfallen) mit addiert werden.
Die bunten (Arbeitstage), nur die Stunden zusammenrechnen mehr als 8 plus eventuelle Wochenendarbeit.
Die überschuss Stunden die mehr als 8 und die Stunden, die in den grauen Wochenendtagen eingetragen werden, sollen
dann in die Zelle D37 addiert werden.
Sonntag Nacht ist ja ein normaler 8 Stunden Tag. Sonntage grau nimmt keine Werte an.

Danke

Betrifft: AW: dafür dann ...
von: neopa C
Geschrieben am: 10.04.2021 09:14:51

Hallo Tom,

... folgende Matrixformel in D37:
{=SUMME(WENN(ISTZAHL(D3:D33)*(D3:D33>8)*(C3:C33<>"");D3:D33-8))+SUMMEWENN(C3:C33;"";D3:D33)}

Gruß Werner
.. , - ...

Betrifft: AW: dafür dann ...
von: Tom
Geschrieben am: 10.04.2021 17:09:02

Hi,

Top,danke dir vielmals

Gruss
Tom

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 10.04.2021 19:05:08

Gruß Werner
.. , - ...

Betrifft: Term-Anzahl-Reduzierung auf 1
von: lupo1
Geschrieben am: 08.04.2021 17:22:11

(hier nicht nötig, da die Terme kurz sind; also nur generell)

=SUMMENPRODUKT((C4:C9>8)*(C4:C9-8))
würde dann zu
=SUMMENPRODUKT(WENNFEHLER(EXP(LN(C4:C9-8));))

Betrifft: AW: aber so nicht in XL2016 ...
von: neopa C
Geschrieben am: 08.04.2021 18:33:14

Hallo lupo,

... und der Fragesteller hat nun mal XL2016 wo er damit nur ein #WERT!-Fehlermeldung erhalten würde.

In Versionen vor Office365 bedarf Deine Formel nämlich des Matrixformelabschluss und dann ist aber auch nicht mehr SUMMENPRODUKT() notwendig, denn es würde dafür SUMME() reichen.

Zu der von Dir vorgenommen Lösungsart würde mich aber nun schon mal interessieren, welcher Zeitgewinn denn bei einem auszuwertenden Datenbereich von sagen wir mal 1.000 und 10.000 Datenwerten möglich wäre. Hast Du denn mal Messungen vorgenommen? Wie würde es denn ganz konkret für das vom TE zuerst eingestellte Beispiel ausfallen?

Gruß Werner
.. , - ...

Betrifft: es geht nicht um Zeitersparnis ...
von: lupo1
Geschrieben am: 08.04.2021 18:53:22

... sondern um Termreduzierung, mit der gleichen Begründung wie bei meinem GLÄWEXWDH gegenüber FINDEN-Lösungen. Solltest Du eigentlich mittlerweile wissen.

Der SUMME/SUMMENPRODUKT/{}-Quirl betrifft mich mit xl365 nicht mehr, so dass ich das nicht mehr ausprobieren kann und auch langsam ganz einfach vergesse. Dafür gibt es aber ja Dich. :-) Danke!

Betrifft: AW: Deine Termreduzierung ...
von: neopa C
Geschrieben am: 08.04.2021 19:50:48

Hallo,

... nimmst Du doch nicht seiner selbst wegen vor sondern doch zur Reduzierung der internen Rechenoperationen. Je weniger derartige Operationen notwendige sind, desto weniger hat der PC zu rechnen, was sich doch letztendlich in einem Zeitgewinn niederschlagen sollte und sei er noch so klein. Insofern wäre schon interessant zu wissen, was man gewinnt, wenn man reduziert.

Gruß Werner
.. , - ...

Betrifft: Das wird eigentlich von niemandem i Frage gestellt
von: lupo1
Geschrieben am: 08.04.2021 21:45:47

Verwendet man ein kurzes Argument mehr als 1mal, ist es nicht schlimm.

Wenn aber der Ausdruck A1:A5 selbst erst berechnet werden muss, vielleicht sogar mit VERGLEICH, BEREICH.VERSCHIEBEN, INDEX oder anderen Funktionen, ist es schön, ihn statt dessen gleich bei dieser Berechnung nur einmal verwenden zu müssen und auf Hilfszellen verzichten zu können.

Über LET und LAMBDA ist nun erstmals die mehrfache Verwendung (bzw. Berechnung) langer Ausdrücke (außerhalb von VBA) nur einmal nötig. Nicht nur ich habe darauf 30 Jahre lang gewartet, sondern viele User auf der Welt. Bei den älteren Excel-Versionen vor xl365 braucht es =WENNFEHLER(EXP(LN(... für den speziellen Fall. Und vor xl2007 bleibt einem halt nur VBA. Deswegen gibt es ja auch viele VBA-Apologeten, wie Luc und sulprobil, weil mit VBA jegliche Diskussion über Sinn oder Unsinn erstirbt, denn es wird alles damit möglich. Nachteil von VBA: Damit kann ich auch gleich meine Firma von dunklen Mächten steuern lassen (etwas überspitzt).

Ich habe schon (oft) mehrere Fälle behandelt:

  • Array-MAX(;MIN-MAX): ---- MIN-MAX sind - wie alle statistischen Funktionen - selbst nach außen nicht arrayfähig, nur nach innen. Anwendungsbeispiel: Meine abschließende Zuschlagszeiten-Datei (schon oft gepostet, leider nicht verstanden/akzeptiert, da sie gleich (fast) alle hypothetischen Fälle mit beherrscht, die der Fragensteller aber gar nicht benötigt) mit der erweiterten Pausenabzugsformel.
  • Schar linearer Funktionen als Pfad einer zusammengestellten Funktion: österreichische Einkommensteuer, Formel-1-Punkte, Hartz4-Zuverdienst, Provisionsberechnungen ...

  • Wenn Du die Sache trotzdem in Frage stellst: Das ist Dir erlaubt. Ich aber weigere mich, auf Funktionen, die ich auch verwenden musste, bis ich diese "richtigen" hatte, wieder "zurück zu fallen". Du verwendest ja auch =SUMME(A1:A5) statt =A1+A2+A3+A4+A5 und stellst das nicht in Frage. SUMME() lernt man im Excelkurs. =WENNFEHLER(EXP(LN(... oder GLÄWEXWDH muss man sich selbst beibringen, ab dann "gekapselt" betrachten (wie eine getestete VBA-UDF) und nicht mehr in Frage stellen. Natürlich nur, wenn Einschränkungen bei deren Auswahl bekannt sind!

    Wieso also muss ich noch mal (A1:A5>8)*(A1:A5-8) verwenden, wenn das mit dem =WENNFEHLER(EXP(LN(...-Standardkonstrukt auch kürzer, also nur (A1:A5-8), möglich ist? Richtig! Dann, wenn ich in dem anderen Beispiel nur =A1+A2 statt =SUMME(A1:A2) benötige. So ist auch (A1:A5>8)*(A1:A5-8) ist immer noch kürzer, als das Standardkonstrukt. Deswegen hatte ich es Dir im anderen Beitrag ja auch gnädig "erlaubt".

    Betrifft: AW: ich stell(t)e es ja auch nicht in Frage ...
    von: neopa C
    Geschrieben am: 09.04.2021 10:38:12

    Hallo Lupo1,

    ... mich interessiert jedoch nach wie vor, wie sich eine derartige Termreduzierung in Zeitgewinn niederschlägt. Das war und ist meine Fragestellung.
    Ich kann dies mangels entsprechenden Voraussetzungen nicht selbst ermitteln. Erst wenn ich diese kenne, und diese unter Berücksichtigung weiterer Faktoren (be)werten kann , ist es mir möglich, die für mich notwendigen Schlussfolgerungen daraus zu ziehen .

    Gruß Werner
    .. , - ...

    Betrifft: AW: Überschuss addieren
    von: SF
    Geschrieben am: 08.04.2021 16:06:44

    Hola,
    =SUMMENPRODUKT((C4:C9-8>0)*(C4:C9-8))
    
    Gruß,
    steve1da

    Betrifft: AW: Überschuss addieren
    von: Tom
    Geschrieben am: 08.04.2021 17:21:39

    Hi ich bins noch mal.
    Soweit habe ich jetzt alles übertragen.
    Problem ist,wenn ich in den Zellen was anderes einfüge, habe ich in Zelle D37,daß mir den Überschuss ausrechnet,
    keinen Wert mehr.
    Habe hier mal die ganze Tabelle hochgeladen um zu veranschaulichen,was ich überhaupt vor habe.
    https://www.herber.de/bbs/user/145399.xlsx

    Sorry nochmal, aber die Fehler sehe ich ja erst beim erstellen.

    Gruss

    Betrifft: AW: Überschuss addieren
    von: Tom
    Geschrieben am: 08.04.2021 16:14:11

    Boh,das ging schnell.
    Vielen lieben dank

    Gruss

    Betrifft: AW: Überschuss addieren
    von: Tom
    Geschrieben am: 08.04.2021 16:46:41

    Hi ich bins noch mal.
    Soweit habe ich jetzt alles übertragen.
    Problem ist,wenn ich in den Zellen was anderes einfüge, habe ich in Zelle D37,daß mir den Überschuss ausrechnet,
    keinen Wert mehr.
    Habe hier mal die ganze Tabelle hochgeladen um zu veranschaulichen,was ich überhaupt vor habe.
    https://www.herber.de/bbs/user/145399.xlsx

    Sorry nochmal, aber die Fehler sehe ich ja erst beim erstellen.

    Gruss

    Betrifft: AW: Überschuss addieren
    von: Tom
    Geschrieben am: 08.04.2021 16:52:42

    Hi ich bins noch mal.
    Soweit habe ich jetzt alles übertragen.
    Problem ist,wenn ich in den Zellen was anderes einfüge, habe ich in Zelle D37,daß mir den Überschuss ausrechnet,
    keinen Wert mehr.
    Habe hier mal die ganze Tabelle hochgeladen um zu veranschaulichen,was ich überhaupt vor habe.
    https://www.herber.de/bbs/user/145399.xlsx

    Sorry nochmal, aber die Fehler sehe ich ja erst beim erstellen.

    Gruss

    Betrifft: Bitte checke immer die Beitragsliste ...
    von: lupo1
    Geschrieben am: 08.04.2021 17:24:39

    ... um nicht doppelt zu posten. Denn Deine Beiträge sind alle schon da, werden aber (leider) mit Zeitverzögerung im Forum angezeigt.

    Betrifft: off topic, Lupo
    von: RPP63
    Geschrieben am: 08.04.2021 17:29:24

    Ich finde die Benutzerführung besser als vorher.
    Nach Absenden dieses meines Beitrags erscheint irgendwann eine Schaltfläche, in der ich sofort die aktualisierte Forums-Liste sehe.
    Da ich das jetzt nicht im Kopf habe, werde ich in einer halben Minute einen erneuten Post absetzen, in dem ich den Namen des Buttons nenne.

    Betrifft: Beitragsliste aktualisieren,
    von: RPP63
    Geschrieben am: 08.04.2021 17:30:06

    heißt sie! ;)

    Betrifft: Korrektur: Forumsliste aktualisieren, owT
    von: RPP63
    Geschrieben am: 08.04.2021 17:30:54

    .

    Betrifft: Auch wenn die Benutzerführung besser ist, so ...
    von: lupo1
    Geschrieben am: 08.04.2021 17:57:19

    ... ist doch "in-time"-Darstellung am Ende immer das Entscheidende. In jedem System. In manchen Systemen ist es sogar lebensentscheidend.

    Und es ist nun mal so, dass seit der Forumsumstellung die Beiträge im Forum erst nach 1-10 Minuten auftauchen, mit einem Peak um ca. 3 Minuten. Ganz wenige sind auch sofort da.

    [Beobachtung mit Win10/Chrome]

    Betrifft: AW: würde es anders darlegen...
    von: neopa C
    Geschrieben am: 08.04.2021 19:47:04

    Hallo lupo1,

    ... manchmal wäre es vielleicht schon wünschenswert , wenn die Aktualisierung der Forumsliste nach jedem eingestellten Beitrag automatisch sofort erfolgen würde. Ist aber mE nicht notwendig und hier im Forum erst Recht nicht entscheidend.

    Wer ein aktuelles Listing will und braucht, muss lediglich den Aktualisierungsbutton im Menü betätigen. Danach sind alle Beiträge mE auch sofort ersichtlich. Dies leider aber nur in der (Standard-)Forumsliste. Für die im Listenmodus erstellte Liste (bei mir in einem eigenen Tab) , wird durch Betätigung dieses Aktualisierungsbutton diese in die (Standard-)Forumsliste gewandelt. Aber das kann man umgehen, in dem man da einfach klassisch [F5] tätigt.

    Wie und wo hast Du denn festgestellt, dass es bis zu 10 Min. dauern würde, das ein Beitrag erscheint? Ist mir jedenfalls so noch nicht aufgefallen (mit WIN 10 und FF) und auch nicht, dass es länger dauern würde, als in der vorangegangen Version. Muss allerdings dazu sagen, dass ich seit einem Monat eine schnellere Verbindung ins Internet habe. Und in meinem FF lösche ich auch ab und zu (bewusst nicht automatisch) mal den Web-Site-Daten-Cache. Das musste ich bei noch langsamerer Internetverbindung häufiger tun als derzeit. Vielleicht ist gleiches in Chrome notwendig/möglich.

    Gruß Werner
    .. , - ...

    Betrifft: "Aktualisieren" habe ich nicht bemerkt, weil ...
    von: lupo1
    Geschrieben am: 08.04.2021 22:03:21

    ... es bisher nicht nötig war.

    Betrifft: AW: habe dies zuvor mit F5 schon tun müssen owT
    von: neopa C
    Geschrieben am: 09.04.2021 10:39:16

    Gruß Werner
    .. , - ...

    Betrifft: Das ist normal und gilt für alle Foren
    von: lupo1
    Geschrieben am: 10.04.2021 05:42:08



    Betrifft: Das ist normal und gilt für alle Foren
    von: lupo1
    Geschrieben am: 10.04.2021 05:42:16



    Betrifft: AW: Das ist normal und gilt für alle Foren
    von: Hans W. Herber
    Geschrieben am: 10.04.2021 06:08:19

    ... zum Thema Aktualisierung:
    Die Forumsliste wird nach dem Absenden der Nachricht und dem nachfolgenden Klick auf "Forumsliste aktualisieren" brandneu erstellt. Wird dennoch eine überholte Liste angezeigt, nimmt sich der Rechner die aus seinem Cache, das hat aber mit der forumsseitigen Aktualisierung nichts zu tun.

    Gruss hans

    Betrifft: Der Unterschied zu vor dem 12.3. ist aber, ...
    von: lupo1
    Geschrieben am: 10.04.2021 09:14:32

    ... dass damals ein 1maliges Aktualisieren, egal wie, also meinetwegen per F5, da mir das Menü "Aktualisieren" damals nie begenget ist, falls es das schon gab,

    (fast) immer den tatsächlich Stand erbrachte (Ausnahmen waren manchmal irgendwelche Reorganisationsläufe, in die man zeitlich gerade kam).

    Jetzt aber reicht F5 nicht mehr. Ich hätte das ganze ja nicht geschrieben, wenn mir keine Verhaltensänderung aufgefallen wäre. Es ist ja auch keine "Katastrophe". Aber früher habe ich nie die "Beitragsliste" benötigt. Jetzt sieht das anders aus. Einfach, damit die sehr häufigen Minutenüberschneidungen bei angeregtem Threadverlauf zumindest weniger anfallen.

    Betrifft: In der Familie kommen grad die SMS-Bomben ...
    von: lupo1
    Geschrieben am: 10.04.2021 09:28:18

    ... als Thema auf den Tisch. Und, wie schnell man beim Löschversuch auf den jeweiligen Link rutscht, da man ohne das Darstellen der SMS-Liste eine einzelne (oder auch alle) SMS nicht löschen kann. (Unterschied WhatsApp: Ich kann einen ganzen Chat löschen; denn dort ist ein Chat 1:1 mit einer Quelle, bei SMS nicht (unbedingt)).

    Auch mein alter Vater hat ein Smartphone und einen Computer. Er hat nun gelernt, dass man F5 löschen kann, damit sich eine Webseite aktualisiert. Möglicherweise kann er sich auch noch merken, dass man in Excel abweichend mit F9 neu berechnet. Aber wie löscht man einen Cache? Das weiß ich auch nicht.

    Betrifft: AW: hierzu folgendes ...
    von: neopa C
    Geschrieben am: 10.04.2021 10:14:37

    Hallo lupo1,

    ... wie es in Deinem Browser geht, weiß ich nicht. IIn FF gibt es aber unter Einstellungen "Datenschutz & Sicherheit" ein Funktionsgruppe "Cookies und Website-Daten", in der ich entsprechende Funktionalität aktivieren kann. Dies dort unter Berücksichtigung dessen, dass ich die von mir benötigten Cookies (soweit ich das einschätzen kann) von deren Löschung auch aushalten kann. Aber diese Löschung wirkt sich mE spürbar nur dann aus, wenn der PC bzgl. RAM-Ausstattung zu schwach auf der Brust ist und die Cachespeicherbelegung so groß geworden ist, dass diese zumindest teilweise auf die Festplatte ausgelagert wird. Ob und wie der Website-Cache z.B. in bestimmten Zeitabständen über Einstellung im Betriebssystem automatisch aktualisiert wird bzw. werden kann, weiß ich nicht, denn ich habe nur äußerst rudimentäre Betriebssystemkenntnisse. Da es aber [F5] gibt und Hans in der Forumssoftware den Aktualisierungsbutton zur Verfügung gestellt hat, kann man es hier, von Ausnahmen abgesehen (die ich mir wünschen würde), im Wesentlichen selbst beeinflussen.

    Gruß Werner
    .. , - ...

    Betrifft: Das ist eine Anleitung (danke!), die man ...
    von: lupo1
    Geschrieben am: 10.04.2021 10:20:26

    ... vorher nicht brauchte, weil da F5 ausreichte. Es hat sich also technisch etwas verändert.

    Auch jetzt geht es noch mit F5, wenn man sich mit 1-10minütiger Nichtaktualität zufrieden gibt.