Microsoft Excel

Herbers Excel/VBA-Archiv

Text ansprechen in VBA

Betrifft: Text ansprechen in VBA
von: reinhard
Geschrieben am: 17.04.2003 - 20:30:01

hallo,

bin gerade auf ein problem gestoßen....
wie kann man in VBA-Excel per Code einen Text ansprechen...

also in etwa so:

wenn in zelle A1 ein text steht, dann soll der Wert in Zelle B1 z.B: "Die Nachbarzelle ist ein Text" stehen...

würde mich über eine info sehr freuen...

reinhard


  

Re: Text ansprechen in VBA
von: Ramses
Geschrieben am: 17.04.2003 - 20:38:22

Hallo

If Not IsNumeric(Range("A1")) Then
Range("B1") = "In der Nachbarzelle steht Text"
End If

Aber muss es wirklich VBA sein ?
Das geht mit einer stinknormalen WENN-Formel auch.

Gruss Rainer

  

Re: Text ansprechen in VBA
von: reinhard
Geschrieben am: 17.04.2003 - 20:53:24

allo Rainer,

jo...muss VBA sein....muss ein etwas für meine verhältnisse komplexeren code verfassen...
genauer gesagt muss ich folgendes programmieren:

wenn in spalte A ein text steht muss die aktive zelle in spalte b als text formatiert werden und die bedingte formatierung von dieser annehmen---wie ich das gebacken bekomme weiß ich noch nicht...aber ich denke mal den code direkt in das z.B: Tabelle1 setzen mittels der target(byVal.......funktion, damit der code ohne auf einen button zu drücken seine arbeit verrichtet...

reinhard

  

Re: Text ansprechen in VBA
von: Sigi E.
Geschrieben am: 17.04.2003 - 21:50:00

Hallo Reinhard,

warum nicht einfach die Excelfunktion "=Typ(A1)"?
Erg.: 1=Zahl, 2=Text, 4=logisch, 16=Fehler

Gruß
Sigi

  

Re: Text ansprechen in VBA
von: reinhard
Geschrieben am: 18.04.2003 - 06:54:36

ich denke mal das ganze muss man in eine (jede) zelle einfügen, oder?
es sollte für das gnaze tabellenblatt gültigkeit haben
wenn ich es in jede zelle schreiben müsste wäre es sehr viel aufwand
....oder habe ich deinen vorschlag hier falsch verstanden?
wie muss ich mir das bei deiner methode vorstellen?

Reinhard

  

Re: Text ansprechen in VBA
von: Sigi E.
Geschrieben am: 18.04.2003 - 11:24:14

Hallo Reinhard,

ich habe es so verstanden: in Spalte A (A1, A2, ...) wird etwas
eingegeben. In Spalte B (B1, B2, ...) soll dann, sofern in der
entsprechenden Zeile unter Spalte A ein Text eingegeben wurde,
eine Meldung "in Zelle steht Text" erscheinen.

Formel in B1:
"=WENN(TYP(A1)=2;"nebenan steht Text";"")"
und dann die ganze Spalte herunterkopieren.

Gruß
Sigi

 

Beiträge aus den Excel-Beispielen zum Thema "Text ansprechen in VBA"