doppelte Werte nur einmal zählen

Bild

Betrifft: doppelte Werte nur einmal zählen
von: Alyssia
Geschrieben am: 14.08.2003 10:17:25

Hallo

Ich habe in Spalte A etwa 9'000 Adressen, vondenen einige mehrmals vorkommen.
Nun habe ich mit bedingter Formatierung folgende Formel, um die doppelten Adressen einzufärben: =ZÄHLENWENN(A$2:A2;A3)>=1

Nun möchte ich in A1 die gesamten Adressen zusammenzählen, damit ich weiss, wie viele es sind.
Das Problem ist jetzt, dass ich die Adressen, welche mehrmals vorkommen, nur
einmal zählen möchte.

Welche Formal brauche ich?

Gruss Alyssia

Bild


Betrifft: AW: doppelte Werte nur einmal zählen
von: Boris
Geschrieben am: 14.08.2003 10:25:32

Hi Alyssia,

schreib die gleiche Formel in die Tabelle in eine Hilfsspalte (z.B. F) - deine gepostete Formel gehört also in F3 - und kopier diese dann runter.
Mit =ZÄHLENWENN(F:F;WAHR)
kannst du dann alle zählen.

Grüße Boris


Bild


Betrifft: Kleine Korrektur:
von: Boris
Geschrieben am: 14.08.2003 10:27:09

Mit =ZÄHLENWENN(F:F;WAHR) zählst du alle doppelten.
Mit =ZÄHLENWENN(F:F;FALSCH) zählst du alle nicht doppelten.

Boris


Bild


Betrifft: AW: doppelte Werte nur einmal zählen
von: Alyssia
Geschrieben am: 14.08.2003 10:30:05

Hallo Boris

Ich glaub, Du hast mich falsch verstanden, ich muss alle Adressen zählen, auch die welche nur einmal vorhanden sind. Aber wenn 4x die selbe Adresse vorkommt, muss
es nicht als 4, sondern als 1x gezählt werden.

Kannst Du mir da helfen?

Vielen Dank und Grüsse
Alyssia


Bild


Betrifft: Du hast es noch nicht ausprobiert...?
von: Boris
Geschrieben am: 14.08.2003 10:37:58

Hi Alyssia,

Schreib mal - beginnend bei A1 - folgende Einträge untereinander:
a
b
a
b
a
a
b
c

Jetzt in B1 folgende Formel und runterkopieren:
=ZÄHLENWENN(A$1:A1;A1)>1

Und in C1:
=ZÄHLENWENN(B:B;FALSCH)
Ergebnis: 3 (a,b,c)

Alles klar?

Grüße Boris


Bild


Betrifft: AW: Du hast es noch nicht ausprobiert...?
von: Alyssia
Geschrieben am: 14.08.2003 11:03:16

Hi Boris

Hab wohl erst was falsch gemacht, aber jetzt hat's funktioniert.

Vielen vielen Dank

Gruss Alyssia


Bild


Betrifft: Lieblingsformel LOL
von: ingo
Geschrieben am: 14.08.2003 13:26:25

Hallo zusammen,

für dieses Problem gibts doch meine Lieblingsmatrixformel ;-) aus www.excel-formeln.de

=SUMME((A1:A9000<>"")/ZÄHLENWENN(A1:A9000;A1:A9000)

(Eingabe abschliessen mit Strg-Shift-Enter)

Gruß Ingo


Bild


Betrifft: AW: Lieblingsformel richtig
von: ingo
Geschrieben am: 14.08.2003 13:34:42

Hallo nochmal,

man soll sich nicht tot-optimieren ;-)

besser ist:

=SUMME(WENN((A1:A9000<>"");1/ZÄHLENWENN(A1:A9000;A1:A9000);0))

Gruß Ingo


Bild


Betrifft: AW: Lieblingsformel richtig
von: Alyssia
Geschrieben am: 14.08.2003 14:37:17

Hi zusammen

Die Formeln sind super, doch nun hab ich noch ein kleines Problem.
Wenn ich per Autofilter suche und von den gesamten 9'000 3'000 rausfiltere,
dann gibt die Formel =SUMME((A1:A9000<>"")/ZÄHLENWENN(A1:A9000;A1:A9000)
nachwievor alle 9'000 an.

Wie kann man die Formel abändern, damit sie noch immer die doppelten Werte nur
einmal zählt, dafür nur die gefilterten Werte?

Vielen Dank.

Gruss Alyssia


Bild


Betrifft: Dauert bei 9000 Zeilen so ca. 10 Sek. ...
von: Boris
Geschrieben am: 14.08.2003 15:03:40

Hi Ingo,

...so schön die Lösung auch ist (ich verwende sie auch gerne) - die Performance wird bei 9000 Zeilen gekillt...;-)

Grüße Boris


 Bild

Beiträge aus den Excel-Beispielen zum Thema " doppelte Werte nur einmal zählen"